LINUX.ORG.RU

снести удев поставить форк
а, ну и не забыть выставить для eudev юзы аналогичные

megabaks ★★★★ ()
Ответ на: комментарий от Kindly_Cat

Промах. Куча блокировок :)

emerge -N eudev
Calculating dependencies... done!
[ebuild  N     ] sys-fs/udev-197-r3  USE="acl gudev hwdb introspection keymap kmod openrc -doc (-selinux) -static-libs" 
[ebuild  N     ] virtual/udev-197  USE="gudev hwdb introspection keymap kmod (-selinux) -static-libs" 
[ebuild  N    ~] sys-fs/eudev-1_beta2-r1  USE="modutils openrc -doc -gudev -hwdb -introspection -keymap -kmod -legacy-libudev (-selinux) -static-libs" 
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-1_beta2-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-197-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-197-r3[gudev,hwdb,introspection,keymap,kmod] required by (virtual/udev-197::gentoo, ebuild scheduled for merge)

  (sys-fs/eudev-1_beta2-r1::gentoo, ebuild scheduled for merge) pulled in by
    eudev

yura_ts ★★ ()
Ответ на: комментарий от megabaks

Включил. Всё равно где-то туплю.

emerge -N eudev
Calculating dependencies... done!
[ebuild  N     ] sys-fs/udev-197-r3  USE="acl gudev hwdb introspection keymap kmod openrc -doc (-selinux) -static-libs" 
[ebuild  N     ] virtual/udev-197  USE="gudev hwdb introspection keymap kmod (-selinux) -static-libs" 
[ebuild  N    ~] sys-fs/eudev-1_beta2-r1  USE="gudev hwdb introspection keymap modutils openrc -doc -kmod -legacy-libudev (-selinux) -static-libs" 
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-1_beta2-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-197-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-197-r3[gudev,hwdb,introspection,keymap,kmod] required by (virtual/udev-197::gentoo, ebuild scheduled for merge)

  (sys-fs/eudev-1_beta2-r1::gentoo, ebuild scheduled for merge) pulled in by
    eudev
yura_ts ★★ ()
Ответ на: комментарий от J
blackstar package.accept_keywords # equery d sys-fs/udev
 * These packages depend on sys-fs/udev:
blackstar package.accept_keywords # emerge -N eudev
Calculating dependencies... done!
[ebuild  N     ] sys-fs/udev-197-r3  USE="acl gudev hwdb introspection keymap kmod openrc -doc (-selinux) -static-libs" 
[ebuild  N     ] virtual/udev-197  USE="gudev hwdb introspection keymap kmod (-selinux) -static-libs" 
[ebuild  N    ~] sys-fs/eudev-1_beta2-r1  USE="gudev hwdb introspection keymap modutils openrc -doc -kmod -legacy-libudev (-selinux) -static-libs" 
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-1_beta2-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-197-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-197-r3[gudev,hwdb,introspection,keymap,kmod] required by (virtual/udev-197::gentoo, ebuild scheduled for merge)

  (sys-fs/eudev-1_beta2-r1::gentoo, ebuild scheduled for merge) pulled in by
    eudev
yura_ts ★★ ()
Ответ на: комментарий от Kindly_Cat

О, спасибо! Теперь поставился виртуальный пакет и eudev, а также udev-init-scripts. А что делает kmod?

yura_ts ★★ ()
Ответ на: комментарий от Kindly_Cat

Ок. А почему eudev поставилось лишь после добавления в make.conf в USE слагаемого -kmod? И будет ли теперь всё работать?

yura_ts ★★ ()

в переходе на eudev нет ничего грамотного. наоборот! это очень и очень глупо.

anonymous ()
Ответ на: комментарий от Kindly_Cat

Хм. Ок, но при этом пакет module-init-tools у меня не стоит (и не подхватывается при попытке обновления), а kmod — стоит. Поменял только юзы в make.conf (глобально). Ничего не понимаю...

yura_ts ★★ ()
Ответ на: комментарий от yura_ts

Как именно поменял? Если флаг module-init-tools включен, этот пакет должен притягиваться.

Kindly_Cat ()
Ответ на: комментарий от Kindly_Cat

в make.conf USE="....-kmod" Если бы я перезагрузился, всё сломалось бы? Если я правильно понял, теперь добавить флаг module-init-tools?

yura_ts ★★ ()
Последнее исправление: yura_ts (всего исправлений: 2)
Ответ на: комментарий от Kindly_Cat

После USE="...-kmod module-init-tools" в make.conf и emerge -auvDN world пакет module-init-tools таки не подхватился.

Руками снес kmod, поставил module-init-tools, вроде всё работает.

yura_ts ★★ ()
Последнее исправление: yura_ts (всего исправлений: 1)
Ответ на: комментарий от megabaks

Небольшое замечание для тех, у кого не ~. Размаскировать перед установкой.

shell-script ★★★★★ ()
Ответ на: комментарий от Kindly_Cat

А у наркоманов, типа меня, у коьорых модулей нет, профита ноль.

funeralismatic ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.