LINUX.ORG.RU

Сегфолт иксов

 , ,


0

1

Ставлю gentoo. Дошла до установки xorg + openbox. Openbox запускается, рабочий стол, двигаешь мышью, но при нажатии на любую кнопку (мышь\клава - без разницы) иксы отваливаются. Вот лог: http://pastebin.com/0fp7RkrK И конфиг иксов: http://pastebin.com/taWThH0w Карточка nvidia.

Мб что не так собрала. Даже не знаю куда копать. Пихните хотя бы в нужном направлении =)

Конфиг иксов вручную создавала? ACPI в ядро вкомпилен? Какой драйвер невидии используется?

vurdalak ★★★★★ ()

попробуй пересобери sys-fs/udev с юзом «keymap»

punya ★★ ()

xf86-input- и xf86-video- пакеты пересобери

vertexua ★★★☆☆ ()

Попробуй перебрать пакеты, зависящие от этих библиотек и видеодрайвер.

#revdep-rebuild -L /lib64/libpthread.so.0 && revdep-rebuild -L /lib64/libc.so.6 && module-rebuild -X rebuild
glibych ★★ ()

-=:=-

гугол подсказывает
Тыц 1
Тыц 2

Походу напилили чегото или hardware- специфик проблемы..

KosmiK ()
Ответ на: комментарий от glibych

Попробуй перебрать пакеты, зависящие от этих библиотек
revdep-rebuild -L /lib64/libc.so.6

То есть судя по библиотеке заново пересобрать весь мир?

Может что с CFLAGS перекрутила?

imul ★★★★★ ()
[    28.988] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[    28.988] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[    28.988] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[    28.988] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[    28.988] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.

как бы там все написано.

ubiquitine ()
Ответ на: комментарий от vurdalak

ACPI включен, конфиг иксов xorg -config, пробовала править руками - ничего не меняется. А драйвер «nvidia». Чёрт его знает, что там поставилось...

asyaka ()
zgrep ^[^#]*ACPI /proc/config.gz
rc-update show
ls /lib/modules/`uname -r`/video/nvidia.ko

в студию.

Deleted ()
Ответ на: комментарий от imul

Хз как в 64-битке, а в 32 - только glibc по идее должен пересобраться. Сейчас читаю более внимательных парней - у нее оптимус не настроен. Скорее всего из-за него и весь сыр-бор.

glibych ★★ ()
Ответ на: комментарий от vurdalak

Обновила систему, пересобрала пакеты, сконфигуряла nvidia-xconfig... Теперь при загрузке иксов отрубаются мышь и клава. хо хо хо. А в логах вот:

[  1493.873] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1493.873] (WW) Disabling Keyboard0
[  1493.873] (WW) Disabling Mouse0

пойду схожу погуглю )

asyaka ()
Ответ на: комментарий от PaxtonFettel

/etc/make.conf:

CFLAGS="-march=k8 -02 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
MAKEOPTS="-j2"
GENTOO_MIRRORS="http://ftp.byfly.by/pub/gentoo/"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="gtk qt4 X glib"
INPUT_DEVICES="evdev"
VIDEO_CARDS="nvidia"

закоментала упоминание клавы\мыши в xorg.conf, скопирировала конфиг evdev

cp /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/
новый лог: http://pastebin.com/PTy9Pnxj

asyaka ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.