LINUX.ORG.RU

[Archlinux] Висят иксы


0

0

Всем доброго времени суток! Столкнулся я с проблемой Иксов. Вчера обновил систему х главного зеркала, выключился. Сегодня загружаюсь, startx и все, Xorg висит. Т.е. на совсем висит, индикатор процессора и сети в Ion'е работают, значение меняется, а вот ни на клава, ни на мышь он не реагирует. Работают только Alt+SysRq+*. В частности Alt+SysRq+E вернул меня в консоль, и там я стал исследовать логи (dmesg/Xorg.0.log), но ничего интересного я там не нашел за исключением того, что в Xorg.0.log нет ни слова ни о клаве, ни о мыши (ни о каком другом input device). Смена видеодрайвера (да он тут, вроде бы, и ни при чем) не помогла. В консоли клава и мышь (gpm) работают, в стареньком Дебиане (откуда сейчас пишу) - тоже. Если кто-нибудь с чем-нибудь подобным сталкивался, подскажите, пожалуйста, куда копать.

P.S. Во время обновления обновились ядро, xproto и еще что-то из xorg'а, что точно - не помню.

P.P.S. Ядро откатывать пока не пробовал, времени сейчас мало, если надо будет - попробую.

Re: [Archlinux] Висят иксы

/etc/rc.d/hal start ?

fat_angel ★★★★★ ()
Ответ на: Re: [Archlinux] Висят иксы от fat_angel

Re: [Archlinux] Висят иксы

Хотя справедливости ради стоит сказать что pekwm (да и openbox) на ноуте тоже както странно работает с evdev'ом (не все кейбиндинги отрабатываются) и xmodmap тоже както не так работает. Все это лечится рестартом wm'а (через кейбиндинги), но это имхо костыль.

Пока отключил добавление устройств через хал и все конфигурирую через xorg.conf, но желание разобраться имеется.

fat_angel ★★★★★ ()
Ответ на: Re: [Archlinux] Висят иксы от fat_angel

Re: [Archlinux] Висят иксы

>/etc/rc.d/hal start ?

Спасибо, помогло.
Только осталось два вопроса:

1) В чем была проблема? Почему раньше все работало нормально без hal'а, а теперь не работает? Если я пропустил что-нибудь в новшествах xorg, киньте ссылочкой, плиз.

2) Почему перестала работать переключалка раскладок xorg?

Ни это:

    Option "XkbRules"	"xorg"
    Option "XkbModel"	"pc104"
    Option "XkbLayout"	"us,ru"
    Option "XkbOptions"	"grp:lwin_toggle,keypad:oss,kpdl:dotoss,compose:ralt,numpad:micros
oft"

ни это:
	Option      "XkbRules" "xorg"
	Option      "XkbModel" "pc104"
	Option      "XkbLayout" "us,ru,ua"
	Option      "XkbOptions" "grp:lwin_toggle,grp_led:scroll,compose:ralt"

не работает. Приходится или вручную делать setxkbmap us,ru -option grp:lwin_toggle, или добавить это в .xinitrc, чтобы запускалось при загрузке.

DiGital ()
Ответ на: Re: [Archlinux] Висят иксы от DiGital

Re: [Archlinux] Висят иксы

В поиск по словам xorg hal fdi. На вашей (арчевской в смысле) вике есть есть неплохие статьи по этому делу.

Начинаная с xorg-server 1.5 (1.4?) настройки input devices идут через hal. Незнаю накуа так нужно было делать, наверно для разрабов оно проще но для меня (да и для тысяч других думаю) проще было возиться с xorg.conf чем с hal fdi.

fat_angel ★★★★★ ()

Re: [Archlinux] Висят иксы

Надо новости внимательнее читать на офф сайте Арча перед обновлением. Это нвые X'ы с очень плотной интеграцией с hal.

Подробности про пляски с бубном вокруг мышей с клавами:

http://wiki.archlinux.org/index.php/Xorg_input_hotplugging

marsijanin ★★ ()
Ответ на: Re: [Archlinux] Висят иксы от DiGital

Re: [Archlinux] Висят иксы

У кого-нибудь получилось настроить ЭТО?  Сделал все как в вики, но переключалка по капсу не работает. Собственно, по любым другим клавишам тоже не работает. Хоткеи из ВМ работают только после его перезапуска.
Вот /etc/hal/fdi/policy/10-keymap.fdi

<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">us,ru</merge>
      <merge key="input.xkb.variant" type="string">,winkeys</merge>
      <merge key="input.xkb.options" type="string">grp:caps_toggle,grp_led:num,ctrl:nocaps</merge>
    </match>
  </device>
</deviceinfo>

/etc/hal/fdi/policy/10-x11-input.fdi:

    <!-- FIXME: Support tablets too. -->
    <match key="info.capabilities" contains="input.mouse">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.x11_driver" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>
  </device>
</deviceinfo>

anonymous ()
Ответ на: Re: [Archlinux] Висят иксы от anonymous

Re: [Archlinux] Висят иксы

$ cat /etc/hal/fdi/policy/10-xorg-input.fdi

<?xml version="1.0" encoding="UTF-8"?>

<deviceinfo version="0.2">
    <device>
        <match key="info.capabilities" contains="input.keymap">
            <append key="info.callouts.add" type="string">hal-setup-keymap</append>
        </match>
        <match key="info.capabilities" contains="input.keyboard">
            <merge key="input.xkb.rules"   type="string">xorg</merge>
            <merge key="input.xkb.model"   type="string">pc105</merge>
            <merge key="input.xkb.layout"  type="string">us,ru(winkeys)</merge>
            <merge key="input.xkb.variant" type="string">winkeys</merge>
            <merge key="input.xkb.options" type="string">grp:ctrl_shift_toggle</merge>
        </match>
    </device>
</deviceinfo>

sysmouse ()
Ответ на: Re: [Archlinux] Висят иксы от anonymous

Re: [Archlinux] Висят иксы

Я добавил Option "AutoAddDevices" "False" в секцию ЫerverFlags файла xorg.conf и отключил к чертям hal, ибо без hotplugging'а я пока прекрасно обхожусь, и чистый xorg.conf меня вполне устраивает.

P.S. Переключалка как работала до ЭТОГО, так и работает сейчас после этой опции.

DiGital ()
Ответ на: Re: [Archlinux] Висят иксы от anonymous

Re: [Archlinux] Висят иксы

> ничего не изменилось

Ну.. значит тебе не повезло. У остальных работает.

sysmouse ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.