LINUX.ORG.RU

Проблема запуска nvidia драйвера


0

0

Видео карточка nvidia GeForce4 Ti 4200.
Debian unstable.
Пробую ставить
apt-get install nvidia-glx-legacy-96xx

Пакеты, имеющие неудовлетворённые зависимости:
nvidia-glx-legacy-96xx: Зависит: nvidia-kernel-legacy-96xx-96.43.16 но он не может быть установлен

Запустил установщик с сайта nvidia.
Все установилось. Падает без ошибок, лог: http://pastebin.com/xdspGiK3
Ошибок нет, по факту не работает.
Настроил свой xorg.conf - поудалял там все, оставил только, что драйвер был nvidia, поведение такое же, лог: http://pastebin.com/WexGLsVk.

Пока пишу сообщение попробую откатиться на stable Xorg.

Куда копать?

★★★★★

как ставил?
что за версии дров и ядра?
что значит «падает»?

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>как ставил?

Что значит - как ставил? Запустил установщик нвидиевский и ответил на вопросы.

ядро 2.6.32-3-686, дрова - NVIDIA-Linux-x86-96.43.16-pkg1.run

Падает значит - черный экран, потом «X сервер не смог запуститься, бла, бла, бла. (см. лог выше).

p.s. stable версию Xorg поставить не получится она тянет за собой старое ядро (2.6.26, которое мне не подходит).

Попробую сейчас еще testing.

pi11 ★★★★★ ()

Попробуй вручную не настраивать. Попробуй настроить классическим
# X -configure

Bod ★★★★ ()
Ответ на: комментарий от pi11

логи ни о чём!
а тот самый «бла, бла, бла.» можно увидеть?

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>логи ни о чём!

а тот самый «бла, бла, бла.» можно увидеть?

тот самый бла-бла-бла, это кусок этого лога.

pi11 ★★★★★ ()
Ответ на: комментарий от pi11

И попробуй вообще убрать куда-нибудь xorg.conf.

Смущают эти строчки:
-----------------------------
(II) LoadModule: «nvidia»
(II) Reloading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) UnloadModule: «nvidia»
(II) Failed to load module «nvidia» (already loaded, 136078353)
--------------------

Bod ★★★★ ()
Ответ на: комментарий от pi11

sudo aptitude install xserver-xorg-dev linux-headers-`uname -r` binutils pkg-config build-essential

вот у меня без этого тоже не вставал, они для сборки нужны оказывается

dima1981 ()
Ответ на: комментарий от Bod

Вобщем откатил Xorg до testing-> сервер запустился.
Но 3D видимо не работает:

serge@pi11-desk:[~] glxinfo
Ошибка сегментирования

cat /var/log/Xorg.0.log | grep GLX
(==) AIGLX enabled
(II) Loading extension GLX
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(II) Loading extension NV-GLX

полный лог:
http://pastebin.com/7Ffan28i

(это с конфигом настроеным через X -configure)
Собственно он от моего принципиально не отличается.

pi11 ★★★★★ ()
Ответ на: комментарий от dima1981

А их разве nvidia-вский инсталлятор автоматически не докачивает?

Bod ★★★★ ()
Ответ на: комментарий от Bod

Не про то я тут что то до этого.

А их разве nvidia-вский инсталлятор автоматически не докачивает?

у меня не докачивает, когда раньше ставил щас в ubuntu nouveau с ними не поспоришь )

dima1981 ()
Ответ на: комментарий от dima1981

>sudo aptitude install xserver-xorg-dev linux-headers-`uname -r` binutils pkg-config build-essential

Это все стоит.
Нвидиевский инсталлер все поставил, модуль ядра загружается.
Сейчас даже сервер стартанул. Но не все работает.

pi11 ★★★★★ ()

debian? откройте для себя m-a ака module-assistant

hizel ★★★★★ ()
Ответ на: комментарий от pi11

А попробовать сейчас переустановить дрова?

Bod ★★★★ ()
Ответ на: комментарий от hizel

Этот способ тоже пробовал. Не собирается. К сожалению что там за проблема была - не помню.

Сейчас попробую переустановить дрова.

pi11 ★★★★★ ()
Ответ на: комментарий от Bod

Скажите пожалуйста, сори что влазиваю, это нормально, что у меня папки нет какой то?

AIGLX error: dlopen of /usr/lib/dri/nouveau_vieux_dri.so failed (/usr/lib/dri/nouveau_vieux_dri.so: cannot open shared object file: No such file or directory)

это от этой команды показал cat /var/log/Xorg.0.log | grep GLX спс pi11

dima1981 ()
Ответ на: комментарий от dima1981

Толком не знаю :)
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/537721

пишут, что:
-----------------------
nouveau_vieux_dri.so does not exist in lucid, it is something in mesa 7.8 and the error message is normal and harmless. 2D acceleration is not dependant on AIGLX, there is not going to be any 3D support for nouveau in lucid. From your logs 2D EXA acceleration is working as intended.
------------------

Bod ★★★★ ()

А потом они говорят, что unstable стабильнее Убунты...

Divius ★★ ()
Ответ на: комментарий от Bod

>пишут, что:

в общем так и есть, и если не играть в игры с супер графикой типа аленарена то все супер и видео и остальное, значит все путем спс успокоение пришло )

dima1981 ()

Smth like

apt-get install module-assistant nvidia-kernel-source && m-a build nvidia-kernel-source && m-a install nvidia-kernel-source
Но нвидиевский блоб таки зло.

Deleted ()
Ответ на: комментарий от Deleted

Но нвидиевский блоб таки зло.

А что делать? Свободных-то модулей до сих пор нет.

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от Eddy_Em

>Но нвидиевский блоб таки зло.

Ницше тоже так думал, итог известен, оптимальный способ думать правильно

anonymous ()
Ответ на: комментарий от Deleted

>debian? откройте для себя m-a ака module-assistant

Этот способ тоже пробовал.

pi11 ★★★★★ ()
Ответ на: комментарий от pi11

А в README в дровах что написано, на предмет «dri» «dri2» и проч.?

Ygor ★★★★★ ()

Почитал, проникся

nvidia-glx-legacy-96xx

С этим вроде как 3d работать и не будет, да. :-(

Ygor ★★★★★ ()
Ответ на: комментарий от pi11

Тогда попробуйте nvidia-kernel-legacy-96xx-source.
Всё работало, работает и будет работать ещё долго.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.