LINUX.ORG.RU

[Xorg] Xorg -configure: Configuration failed.


0

1

X'ы стартуют с разрешением 1024x768, когда надо 1920x1080, консоль в нативном разрешении, а Xorg -configure выдает вот что: Помогите решить пожалуйста.

X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-5-amd64 i686 Debian
Current Operating System: Linux tvr 2.6.38-bpo.2-686 #1 SMP Tue Jun 14 11:43:18                                                                                         UTC 2011 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.38-bpo.2-686 root=UUID=cfb94d5                                                                                        d-082d-4612-b978-7581606a0efa ro quiet video=1920x1080-24@60
Build Date: 29 August 2011  12:12:25AM
xorg-server 2:1.10.4-1~bpo60+1 (Cyril Brulebois <kibi@debian.org>)
Current version of pixman: 0.24.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan 30 17:10:49 2012
List of video drivers:
        ztv
        apm
        radeon
        tdfx
        savage
        i128
        vmwlegacy
        sis
        geode
        siliconmotion
        rendition
        neomagic
        r128
        mga
        intel
        trident
        nouveau
        s3
        ati
        openchrome
        tseng
        mach64
        vmware
        cirrus
        sisusb
        s3virge
        i740
        voodoo
        ark
        chips
        fbdev
        vesa
(EE) Failed to load module "vmwgfx" (module does not exist, 0)
(EE) vmware: Please ignore the above warnings about not being able to to load mo                                                                                        dule/driver vmwgfx
(EE) vmware: Unexpected failure while loading the "vmwlegacy" driver. Giving up.
(EE) Failed to load module "vmware" (a required submodule could not be loaded, -                                                                                        1078867496)
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
FATAL: Module fbcon not found.
Number of created screens does not match number of detected devices.
  Configuration failed.

★★★★★

Запускаешь в вмвари?
/root/xorg.conf.new оно вроде сгенерило. Попробуй скопировать в /etc/X11 и прописать вручную нужный видеодрайвер и разрешения.

stormblastt ★★★ ()
Ответ на: комментарий от stormblastt

Запускаешь в вмвари?

нет, на реальной машине с intel'ом.

zgen ★★★★★ ()

man gtf

man xrandr

Ну и куда нить cat /var/log/Xorg.0.log

ЗЫ Здаёца мне у тебя ядерный модуль для графики не загружен

Ygor ★★★★★ ()
Ответ на: комментарий от zgen

Иксы например могут у тебя загружать весу и запускаца нормально.

Ты бы в логе поглядел какой он у тебя драйвер загружает, а то с весой например можно и не получить желаемого разрешения.

http://otvety.google.ru/otvety/thread?tid=3c8d4ef171a31f67

Ygor ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.