LINUX.ORG.RU

Brightness — продолжение проблемы


0

1

Сочетания для изменения яркости не работают, параметр acpi_backlight=vendor/acpi_backlight=video и пр. не работают, в ядре всё связанное с backlight и acpi включено

ls /sys/class/backlight/
acpi_video0  acpi_video1  intel_backlight
(судя по X-овому логу, работает он с acpi_video1, хотя у меня интел)
Но при попытке редактировать/перезаписывать brightness в какой-либо из папок получаю write error

Ответ на: комментарий от Deleted

Если речь об этом:

setpci -s 00:02.0 F4.B=13
setpci -s 00:02.0 F4.B=80
то нет

botater ()

У меня вот такая хрень забиндена (Intel HD 3000):

     awful.key({  }, "XF86MonBrightnessDown",
         function ()
             awful.util.spawn_with_shell("xbacklight -dec 10%")
         end),
     awful.key({  }, "XF86MonBrightnessUp",
         function ()
             awful.util.spawn_with_shell("xbacklight -inc 20%")
         end)
mega_venik ★★★ ()
Ответ на: комментарий от botater

В смысле просто ничего не происходит (ошибок как бы тоже нет)

А 00:02.0 точно то, что нужно?

Выложи вывод lspci.

Deleted ()
Ответ на: комментарий от Deleted

00:02.0 VGA compatible controller: Intel Corporation Device 0116 (rev 09)

Казалось бы, как раз оно

botater ()
Ответ на: комментарий от botater

Ох :( Помню, на предыдущем ноуте даже вне иксов подсветка работала :(

Так причём здесь консоль или не консоль?:) Команды эти отрабатывают?

mega_venik ★★★ ()
Ответ на: комментарий от botater

А, ну да, протупил, сорри)

Надо было в первом посте конкретизировать, что надо именно без иксов

mega_venik ★★★ ()
Ответ на: комментарий от botater

Попробуйте при загрузке передать ядру параметр acpi

dumal ★★ ()
Ответ на: комментарий от botater

Хм. У меня Dell Inspiron и проблема очень похожа на твою, при чём появилась она после того, как я что-то обновил(подозреваю, что udev). Раньше яркость регулировалась нормально. Проверь, у тебя яркость меняется после того, как ноут выходит из ждущего режима?

thelonelyisland, пробовал, ничего не даёт.

Megabyte ()
Ответ на: комментарий от Megabyte

Такие же проблемы с подсветкой в генту на самсунге. Точно так же совсем недавно сломалось после обновления системы. Сначала подумал на samsung-tools и easy-slow-down-manager, но похоже дело не в них. Похоже, дело действительно в udev

anonymous ()
Ответ на: комментарий от botater

ХЗ, больше нечему, вроде. У меня как у мегабайта - всё работало, потом, после обновления системы, перестало. Тупо не ловятся нужные сочетания fn+key. Есть ещё варианты, из-за чего это может быть, учитывая, что проблема проявилась на ноутбуках от разных производителей?

P.S. Только что заметил - нету файла /lib/udev/rules.d/95-keymap.rules хотя раньше был. Посмотрите у себя.

anonymous ()
Ответ на: комментарий от botater

После обновления kmod всё заработало! Я был прав. Kmod полностью запилили в udev, при чём криво, поэтому вот такие баги и возникают.

Megabyte ()
Ответ на: комментарий от anonymous

Хм, а как проверить, правильно ли определил udev, что нужно использовать?

botater ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.