LINUX.ORG.RU

Error activating XKB configuration.


0

0

Всем привет!

Обновил систему (С Debian/Sarge/Апрель до Sarge/Сегодня), возникла следующая проблема: Gnome выдает на загрузке окошко со следующим описанием:

Error activating XKB configuration. Probably internal X server problem.

X server version data: The XFree86 Project, Inc 40300001 You are using XFree 4.3.0. There are known problems with complex XKB configurations. Try using simpler configuration or taking more fresh version of XFree software. If you report this situation as a bug, please include: - The result of xprop -root | grep XKB - The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

Вывод xprop -root | grep XKB

_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc104", "us, ru", "winkeys,winkeys", "grp:toggle,grp_led:scroll" _XKB_RULES_NAMES(STRING) = "xfree86", "pc104", "us, ru(winkeys)", "winkeys", "grp:toggle,grp_led:scroll"

Вывод gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

layouts = [us winkeys, ru winkeys] model = pc104 overrideSettings = false options = [grp grp:toggle,grp_led grp_led:scroll]

Причем как может заметить уважаемый All с переключением раскладки проблем нет - то есть все работает отлично, только вот окошко вылазит.

★★★★

Re: Error activating XKB configuration.

Все оказалось просто - надо было удалить из конфига опцию XkbVariant и перезагрузить системные настройки Xkb в GConf.

WFrag ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.