LINUX.ORG.RU

GTK. Проблемы с шрифтами.


0

0

slackware-10.0
Предыстория:
Все шрифты в gtk приладах всегда выглядели мелко, но это не достовляло больших проблем потому забивал. Недавно взялся компилить sylheed-2.1.1 и обнаружил что все надписи в готовом продукте наезжают друг на друга и половина текста вообще съезжает за пределы видимости. Обновлял galeon - то-же самое. Откатил обновления glib/gtk 2.8.1/2.8.3 -> 2.6.5/2.6.7.
Перекомпилил sylpheed - всё ок. Точнее почти ок. Шрифты выгядят нормально, но мелко. И что более важно мельче стали шрифты на всех gtk-приложениях.
Попытка решения проблемы:
Нашел гномовую утилиту для упревления шрифтами(gnome-font-properties). При запуске получил 4 одинаковых окна с сообщением о некоей проблеме xkb (см. ниже). Если на менять ничего и закрыть конфигуратор то шрифты становятся нормальными (я - менял). 
Новая проблема:
Перешел к mc на соседней вкладке консоли, нажал вниз и жду... Курсор сдвинулся на одну позицию после первого нажатия и замер. Аналогичная ситуация повторялась во всех приложениях в пределах иксов. В консоли (оно и понятно) всё ок.
Парадокс:
Перезапуск иксов восстановил прежнее положение дел (как движение курсора так и размер шрифтов). Повторный запуск gnome-font-properties снова привёл к появлению окна с ошибкой (1 шт.) и другим вышеуказанным симптомам. Опыт повторялся 4 раза -> эффект устойчивый.
---------------
само сообщение:
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
60802000

If you report this situation as a bug, please include:
- The result of <b>xprop -root | grep XKB</b>
- The result of <b>gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd</b>

------------
$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc101", "us,ru", ",winkeys", "grp:alt_shift_toggle,lv3:win_switch,grp_led:scroll,altwin:meta_win"
_XKB_RULES_NAMES(STRING) = "xorg", "pc101", "us,ru(winkeys)", "", "grp:alt_shift_toggle,lv3:win_switch,grp_led:scroll,altwin:meta_win"
------------
$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
------------
$ gconftool-2 -R /desktop/gnome/peripherals/keyboard
 /desktop/gnome/peripherals/keyboard/kbd.sysbackup:
  layouts = [us,ru      winkeys]
  model = pc101
  options = [grp        grp:alt_shift_toggle,lv3        lv3:win_switch,grp_led  grp_led:scroll,altwin   altwin:meta_win]
-----------
Вопрос:
"Что  делать?"

Re: GTK. Проблемы с шрифтами.

А в слаке под рутом всегда шрифты мелкие!!! Работать под рутом зло!

Sof1x ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.