LINUX.ORG.RU

gnome keyboard layout


0

0

Проблема в следующем, при попытке внести какие-либо изменения в настройки через апплет gnome-keyboard-properties появляется такое сообсщение об ошибке:

Ошибка активирования параметров XKB.
Она может произойти при следующих обстоятельствах:
- ошибка в библиотеке libxklavier
- ошибка в X-сервере (утилиты xkbcomp, xmodmap)
- X-сервер имеет несовместимую реализацию libxkbfile

Данные о версии X-сервера:
The X.Org Foundation
10400090

При составлении отчета об ошибке пожалуйста включите:
- Результат xprop -root | grep XKB
- Результат gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

Вот что получается после ввода этих комманд:
$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "evdev", "us", "winkeys", "grp:ctrl_shift_toggle,grp_led:scroll"
_XKB_RULES_NAMES(STRING) = "xorg", "evdev", "us", "winkeys", "grp:ctrl_shift_toggle,grp_led:scroll"

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
layouts = [us winkeys,ru winkeys]
model =
overrideSettings = false
options = [grp grp:ctrl_shift_toggle,grp_led grp_led:scroll,altwin altwin:meta_win]



★★★

Ответ на: Re: gnome keyboard layout от svu

Re: gnome keyboard layout

а я х.з. что это. в xorg.conf написано следующее:
Section "InputDevice"

Identifier "Keyboard1"
Driver "kbd"
Option "AutoRepeat" "500 30"
Option "CoreKeyboard"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us,ru(winkeys)"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
EndSection

в ветке /desktop/gnome/peripherals/keyboard/kbd все значения сбросил. сделал logout из gnome и перезапустил X. маты все равно сыпятся =/

cobold ★★★ ()
Ответ на: Re: gnome keyboard layout от cobold

Re: gnome keyboard layout

Напишите, пожалуйста, XkbLayout просто "us". А остальные установки сделайте в гноме. Так должно работать.

Если уж так сильно хочется все в xorg - сделайте

XkbLayout "us,ru"
XkbVariant ",winkeys"

svu ★★★★★ ()
Ответ на: Re: gnome keyboard layout от svu

Re: gnome keyboard layout

Да действительно нет. Ну значит не судьба.

anonymous ()
Ответ на: Re: gnome keyboard layout от svu

Re: gnome keyboard layout

Фишка с Option "XkbLayout" "us" не работала до тех пор пока не перенес лежащие рядом с xorg.conf файлы xorg.conf.backup, xorg.conf.bad, xorg.conf.bak, xorg.conf.example в другую директорию. вот только тогда стало:
$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "evdev", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "evdev", "us", "", ""

cobold ★★★ ()
Ответ на: Re: gnome keyboard layout от cobold

Re: gnome keyboard layout

внимательное изучение логов показало, что глюк был из-за того, что при старте X-ов(они у меня запускаются через gdm) подцеплялся xorg.conf из домашней директории пользователя, который нарисовался там после запуска nvidia-xconfig от того самого пользователя. прямо мистика какая-то. или оно так и работает?

cobold ★★★ ()
Ответ на: Re: gnome keyboard layout от cobold

Re: gnome keyboard layout

Занятно. По идее не должно, если пользователь не рут...

Но в результате - ругань-то исчезла?

svu ★★★★★ ()
Ответ на: Re: gnome keyboard layout от cobold

Re: gnome keyboard layout

>подцеплялся xorg.conf из домашней директории пользователя... или оно так и работает?

Да, если путь к xorg.conf не задан в опциях запуска и переменной $XORGCONFIG, то сначала он ищется в домашнем каталоге, а затем в нескольких других..

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.