LINUX.ORG.RU

Ошибка активирования параметров XKB в Федоре 7


0

0

Каждый раз при входе в систему у  меня выскакивает вот такая ошибка:

Ошибка активирования параметров XKB.
Она может произойти при следующих обстоятельствах:
- ошибка в библиотеке libxklavier
- ошибка в X-сервере (утилиты xkbcomp, xmodmap)
- X-сервер имеет несовместимую реализацию libxkbfile

Данные о версии X-сервера:
The X.Org Foundation
10300000

При составлении отчета об ошибке пожалуйста включите:
- Результат xprop -root | grep XKB
- Результат gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

Вот как выглядит у меня нужная часть xorg.conf: 
Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us,ru(winkeys)"
	Option	    "XkbOptions" "grp:shifts_toggle,grp_led:scroll"
	Option	    "XkbVariant" "."
EndSection

И раскладка работает так как мне нужно. Проблема лишь в появлении ошибки каждый раз при входе в систему.

Причем если закоментировать - Option	    "XkbVariant" "." то ошибки не возникает но раскладка работает неправильно. Если убрать (winkeys) оставить просто ru, то ошибка появляется но клавиатура так же не работает. 
Option	    "XkbVariant" "winkeys"-Клавиатура не работает ни в каком варианте. Причем ошибка выскакивает все равно.

Может у кого Федора 7 покажет что он поставил в xorg.conf или как лечить проблему.


Re: Ошибка активирования параметров XKB в Федоре 7

Option "XkbVariant" ",winkeys" Имеется ввиду запятая перед winkeys, это не опечатка? Так как без нее я пробывал и оно не работала.

gres ()

Re: Ошибка активирования параметров XKB в Федоре 7

Да, это не опечатка. Хотя у меня в fedora 7 и без XkbVarian работает без проблем
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru(winkeys)"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
EndSection

Delay ★★ ()

Re: Ошибка активирования параметров XKB в Федоре 7

У меня семерка. Со времен написания ответа в LOR FAQ ничего у себя не менял.

jackill ★★★★★ ()

Re: Ошибка активирования параметров XKB в Федоре 7

Специально заглянул - у меня XkbVariant убран.

Я так предполагаю, что твои иксовые настройки конфликтуют с переключателем клавиатуры, встроенным в твою среду (а у тебя Gnome/KDE?).

В случае гнома с иксами можно не извращаться и пользоваться встроенным переключателем. В случае KDE - наоборот.

jackill ★★★★★ ()

Re: Ошибка активирования параметров XKB в Федоре 7

Комрад спасибо! Заработало только в твоей конфигурации. Никакие другие не работают :-(
Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us,ru"
	Option	    "XkbOptions" "grp:shifts_toggle,grp_led:scroll"
	Option	    "XkbVariant" ",winkeys"	
EndSection

gres ()

Re: Ошибка активирования параметров XKB в Федоре 7

Незачт. А вообще - лучше (речь ведь идет о гноме) оставить xorg.conf в покое и все делать через гномовскую конфигурилку gnome-keyboard-properties. Она мной для того и сделана.

svu ★★★★★ ()

Re: Ошибка активирования параметров XKB в Федоре 7

> Незачт. А вообще - лучше (речь ведь идет о гноме) оставить xorg.conf в покое и все делать через гномовскую конфигурилку gnome-keyboard-properties. Она мной для того и сделана

И где же там ты сделал чтобы можно было указывать нужный вариант раскладки? Где там можно указать что раскладка не просто русская а еще и winkeys? Сколько сидел под гномом всегда правил руками и не потому что Гуй не люблю,а потому что не позволяет такое делать. И вообще непонятно, почему по умолчанию в Гноме расскладка клавиатуры не такая как у большинства пользователей и приходиться ее менять?

gres ()

Re: Ошибка активирования параметров XKB в Федоре 7

Беру свои слова обратно. Действительно нужно всего лишь найти раскладку Русская раскладка Widnows вместо просто Русской раскладки и будет счастье. Но все равно остается вопрос почему бы не сделать ее по умолчанию?

gres ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.