LINUX.ORG.RU

[гентупроблемы] Отвалился transmission


0

1

После обновления отвалился transmission. При запуске transmission-gtk пишет, что «ошибка сегментирования». USE-флаги: «gtk libnotify nls -kde -libcanberra -qt4 -utp». Пробовал пересобирать, не помогло. Если собрать с +qt4, то transmission-qt4 тоже сегфолтится. Куда копать? ~x86 (Да, ССЗБ).

★★★

~x86, transmission-gtk, УМВР. revdep-rebuild запускал?

gentoo_root ★★★★★ ()
Ответ на: комментарий от gentoo_root

Да, запускал.

CFLAGS в студию.

CFLAGS="-O2 -pipe -march=native"

ktan ★★★ ()
Ответ на: комментарий от gentoo_root

Странно. А я думал, что -match=native более правильно. Разве не лучше указывать либо native, либо свой процессор?

ktan ★★★ ()
Ответ на: комментарий от iZEN

>Гентушники наконец-то доигрались?

УМВР.

//И дежурное «фряха уже может ставиться на IdeaPad Y550P, как остальные?»

devl547 ★★★★★ ()

Может, попробуешь ту версию, которая уже стояла? Вдруг и она не заработает. Если сильно нужны торренты, есть и другие клиенты, их много.

У меня такая ошибка возникала у aMule. Оказалось, одна из библиотек-зависимостей aMule компилируется жёстко с sse3 или sse4, а у меня на процессоре этой функции нет. Вручную устанавливаю старую версию crypto++ и всё работает.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от devl547

УМВР.

У меня тоже:

> pkg_info -Ex transmission
transmission-gtk2-2.32
transmission-web-2.32

iZEN ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Может. Как правильно установить предыдущую версию? Попробовал собрать qbittorrent - работает, но я к трансмишену уже как-то привык, да и торренты переносить долго.

ktan ★★★ ()
Ответ на: комментарий от gentoo_root

Пересобрал с твоими настройками - он заработал, спасибо. А в чём дело-то было?

ktan ★★★ ()
Ответ на: комментарий от ktan

Как правильно не знаю, я ставлю так: emerge -av =programma-4.1.0 либо emerge -av sys-apps/programma-4.1.0-r1. Или замаскировываю новые версии.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ktan

>А я думал, что -match=native более правильно.

Ну хз, почитал ман, вроде и -march=native работает. Но лучше всё же руками выставить нужный, чем native.

gentoo_root ★★★★★ ()
Ответ на: комментарий от ktan

>А в чём дело-то было?

Видимо, native не сработал, как надо и включил неподдерживаемый набор инструкций.

gentoo_root ★★★★★ ()

у меня в ~amd64 решилось маскировкой =net-libs/miniupnpc-1.6

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.