LINUX.ORG.RU

FreeBSD глюк с Xfce


0

0

всем здраствуйте.
FreeBSD 8.0 графическая среда Xfce запускаю через startx
так вот я использую файловый менеджер Tunar
но когда устанавливал из портов File Roller вместе с ним установился Nautilus как зависимость.
после этого момента при загрузке Xfce на рабочем столе сначало появляются значки характерные для гнома (например «мой компьютер»)
а через несколько секунд появляются значки Xfce
(думаю связано с установкой наутилуса)
это конечно не сильно мешает но хочется исправить, посоветуйте что можно сделать? это проблема настроек Xfce или чтото другое?

★★★★★

>File Roller вместе с ним установился Nautilus как зависимость

криворукие же там мейнтеры

thunar ★★★★★ ()

Nautilus не мешает. Кстати, его можно выпилить совсем, достаточно при помощи утилит portupgrade сделать «pkg_deinstall -f x11-fm/nautilus» и правильно ответить на вопросы при ремонте («pkgdb -vfFu») базы данных установленных пакетов, чтобы зависимости от него были разорваны раз и навсегда.

А вообще странно, у меня nautilus сам по себе до Xfce4 никогда не стартует. Смотрите стартовые скрипты. Не может оно само туда прописаться.

iZEN ★★★★★ ()
Ответ на: комментарий от iZEN

просто после наутилуса началось может и не из за него.
даже не знаю где смотреть такие настройки какие файлы отвечают за показ иконок на рабочем столе?
в .xinitrc у меня всего 2 строчки:

setxkbmap -layout «us,ru(winkeys)» -option «grp:ctrl_shift_toggle»
/usr/local/bin/startxfce4

первая устанавливает раскладку клавиатуры, вторая запускает xfce4



xfce4-autostart-editor

ненаходит такую команду(

TDrive ★★★★★ ()
Ответ на: комментарий от TDrive

попробовал startx > ~/test.txt
после загрузки в файле test.txt было

/usr/local/bin/startxfce4: X server already running on display :0
Agent pid 1250
xfdesktop[1269]: starting up
xfdesktop[1294]: starting up

xfdesktop это запуск рабочего стола? почему он повтаряется?
я в правильную сторону двигаюсь?)

TDrive ★★★★★ ()
Ответ на: комментарий от TDrive

в общем это 100% наутилус:
ввожу
localhost# ps | grep nautilus

1439 v0 S 0:02,71 nautilus --sm-client-id 23799e84c-9695-11df-8bef-0030

localhost# ps | grep Thunar

1271 v0 S 0:00,20 Thunar --sm-client-id 23456b9d2-8bc9-11df-9587-00304f

потом ввожу:
kill 1439
и после этого открывается сам наутилус и на пару секунд меняются значки на рабочем столе как при загрузке xfce4 тоесть наутилус перезапускается автоматически
проверяем:
localhost# ps | grep nautilus

1478 v0 S 0:02,52 nautilus --sm-client-id 23799e84c-9695-11df-8bef-0030

ещё когда ввёл top заметил что наутилус size: 85908K если сравнить с Thunar size:16816K

значки на рабочем столе ещё ладно а вот 85 мегабайт оперативки уже жалко как это дело можно поправить?

TDrive ★★★★★ ()
Ответ на: комментарий от TDrive

У меня

~/.login:

startx
~/.xinitrc:
/usr/local/bin/xfce4-session

У себя посмотрите здесь:

1) Меню Xfce4 -> Настройки -> Сеансы и запуск -> вкладка «Автозапуск приложений» — может что-то прописалось лишнее.

2) Меню Xfce4 -> Настройки -> Сеансы и запуск -> вкладка «Дополнительные» — снимите все галки с пунктов раздела «Совместимость».

iZEN ★★★★★ ()
Ответ на: У меня от iZEN

нашел в
Меню Xfce4 -> Настройки -> Сеансы и запуск -> вкладка «сеанс»
там был прописан наутилус с приоритетом 50 и стилем перезагрузки «немедленно»

после удаления его оттуда всё стало нормально. спс за помощь.

TDrive ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.