LINUX.ORG.RU

Проблема с запуском Compiz Fusion на XFCE


0

0

Здравствуйте! Понимаю, что "семейство проблем" уже избито, но все решения, которые нашёл, не совсем подходят к моему случаю и не помогают. Поставил себе Compiz Fusion и Emerald. Видео-карта nVidia GeForce 6100 / nForce 430. Оф.драйвер для nVidia установил. С xfwm4 по крайней мере, работал без проблем. После всех установок пишу и вижу:

assador@assador-desktop:~$ compiz --replace Checking for Xgl: not present. Detected PCI ID for VGA: 00:0d.0 0300: 10de:03d0 (rev a2) (prog-if 00 [VGA controller]) Checking for texture_from_pixmap: present. Checking for non power of two support: present. Checking for Composite extension: present. Comparing resolution (1152x864) to maximum 3D texture size (4096): Passed. Checking for nVidia: present. Checking for FBConfig: present. Checking for Xgl: not present. /usr/bin/compiz.real (dbus) - Error: dbus_bus_get error: Failed to execute dbus-launch to autolaunch D-Bus session /usr/bin/compiz.real (dbus) - Error: InitObject failed /usr/bin/compiz.real (core) - Error: Couldn't activate plugin 'dbus' Couldn't find a perfect decorator match; trying all decorators Starting emerald /usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

(emerald:6398): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(emerald:6398): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

(emerald:6398): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

Дальше всё, вроде, работает, но смущают эти перечисленные ошибки. Кроме того, при перезагрузке компа, emerald не грузится, все окошки появляются без заголовков. На emerald --replace в терминале комп никак не реагирует - просто после ввода команды остается курсор в начале строки. Помогает compiz --replace. Правда, после этого десктоп выглядит ужасно, но это мелочи. Помогите ламеру... :)

Re: Проблема с запуском Compiz Fusion на XFCE

Запускаю через fusion-icon, ее(го) и прописал в .xinitrc

anonymous ()

Re: Проблема с запуском Compiz Fusion на XFCE

Это ещё ни чего, у меня ati radeon 9660,

после compiz --replace kde ловко падает, в общем иксы работают, десктопа нет, юзаю altlinux сизифовский репозитарий

anonymous ()
Ответ на: Re: Проблема с запуском Compiz Fusion на XFCE от anonymous

Re: Проблема с запуском Compiz Fusion на XFCE

Спасибо, проблема решилась полной переустановкой Compiz Fusion с Compiz Fusion Icon. Проблема была в файле xorg.conf, в котором перед установкой нужно было прописать следующие опции:

Section "Device" ... Option "AllowGLXWithComposite" "True" ... EndSection

Section "Screen" ... Option "RenderAccel" "True" Option "NoRenderExtension" "False" Option "AddARGBGLXVisuals" "True" Option "DamageEvents" "True" Option "DisableGLXRootClipping" "True" ... EndSection

Section "Extensions" ... Option "Composite" "Enable" ... EndSection

Assador ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.