LINUX.ORG.RU

SIM не ставится


0

0

Всем привет

У мну Gentoo 2008, Xfce 4. Делаю так:

# emerge sim
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) net-im/sim-0.9.4.3-r1 to /
* sim-0.9.4.3.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]

!!! net-im/sim-0.9.4.3-r1 has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually. See the comments in the ebuild for more information.

* net-im/sim-0.9.4.3 contains icons and sounds with unclear licensing and thus
* you have to download and it put into '/usr/portage/distfiles' by yourself.
* Download location:

* mirror://berlios/sim-im/sim-0.9.4.3.tar.bz2
http://dev.gentoo.org/~pva/sim-0.9.4.3-r1919_1924.patch.bz2

* See http://archives.gentoo.org/gentoo-dev/msg_144003.xml for further
* information.
* Fetch failed for 'net-im/sim-0.9.4.3-r1'

* Messages for package net-im/sim-0.9.4.3-r1:

* Fetch failed for 'net-im/sim-0.9.4.3-r1'

Пробовал собирать из исходников:

checking if UIC has KDE plugins available... yes
checking for KDE paths... defaults
checking for dcopidl... /usr/kde/3.5/bin/dcopidl
checking for dcopidl2cpp... /usr/kde/3.5/bin/dcopidl2cpp
checking for mcopidl... not found
configure: error: The important program mcopidl was not found!
Please check whether you installed aRts correctly or use
--without-arts to compile without aRts support (this will remove functionality).

Что такое этот "aRts"? На сколько я понимаю, это что-то связанное с кедами?

★★

Re: SIM не ставится

С GIMP тоже какая-то хрень:

jpegqual.o: In function `analyze_file':
jpegqual.c:(.text+0x4bd): undefined reference to `jpeg_std_error'
jpegqual.c:(.text+0x4ff): undefined reference to `jpeg_CreateDecompress'
jpegqual.c:(.text+0x511): undefined reference to `jpeg_stdio_src'
jpegqual.c:(.text+0x522): undefined reference to `jpeg_read_header'
jpegqual.c:(.text+0x5c1): undefined reference to `jpeg_destroy_decompress'
jpegqual.c:(.text+0x5ed): undefined reference to `jpeg_destroy_decompress'
collect2: ld returned 1 exit status
make[3]: *** [jpegqual] Ошибка 1
make[3]: Leaving directory `/var/tmp/portage/media-gfx/gimp-2.4.2/work/gimp-2.4.2/plug-ins/jpeg'
make[2]: *** [all-recursive] Ошибка 1
make[2]: Leaving directory `/var/tmp/portage/media-gfx/gimp-2.4.2/work/gimp-2.4.2/plug-ins'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Leaving directory `/var/tmp/portage/media-gfx/gimp-2.4.2/work/gimp-2.4.2'
make: *** [all] Ошибка 2
*
* ERROR: media-gfx/gimp-2.4.2 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 2605: Called die
* The specific snippet of code:
* emake || die "emake failed"
* The die message:
* emake failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/media-gfx/gimp-2.4.2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/media-gfx/gimp-2.4.2/temp/environment'.
*

* Messages for package media-gfx/gimp-2.4.2:

*
* ERROR: media-gfx/gimp-2.4.2 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 2605: Called die
* The specific snippet of code:
* emake || die "emake failed"
* The die message:
* emake failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/media-gfx/gimp-2.4.2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/media-gfx/gimp-2.4.2/temp/environment'.
*

SaBo ★★ ()

Re: SIM не ставится

arts -- это кедский звукосервер.

lodin ★★★★ ()

Re: SIM не ставится

Поищи в числе опций сборки нечто типа --wihouth-kde. Раньше симу требовались только kdelibs

Unforgiven ()
Ответ на: Re: SIM не ставится от Unforgiven

Re: SIM не ставится

> arts -- это кедский звукосервер.

А зачем он тогда его ищет, если у меня xfce??? =)

> Поищи в числе опций сборки нечто типа --wihouth-kde. Раньше симу требовались только kdelibs


У меняю в USE стоит -kde
Пересобрал из сорцов:

# ./configure --without-arts

Конфиг прошёл нормально, но вот make:

# make

{...}

creating sim
make[3]: Leaving directory `/sim'
make[2]: Leaving directory `/sim'
Making all in plugins/_core
make[2]: Entering directory `/plugins/_core'
Making all in pict
make[3]: Entering directory `/plugins/_core/pict'
make[3]: Цель `all' не требует выполнения команд.
make[3]: Leaving directory `/plugins/_core/pict'
Making all in styles
make[3]: Entering directory `/plugins/_core/styles'
make[3]: Цель `all' не требует выполнения команд.
make[3]: Leaving directory `/plugins/_core/styles'
Making all in jisp
make[3]: Entering directory `/plugins/_core/jisp'
make[3]: *** Нет правила для сборки цели `*.png', требуемой для `sim.jisp'. Останов.
make[3]: Leaving directory `/plugins/_core/jisp'
make[2]: *** [all-recursive] Ошибка 1
make[2]: Leaving directory `/plugins/_core'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Leaving directory `/'
make: *** [all] Ошибка 2

SaBo ★★ ()

Re: SIM не ставится

> net-im/sim-0.9.4.3 contains icons and sounds with unclear licensing and thus
* you have to download and it put into '/usr/portage/distfiles' by yourself.



А почему бы не сделать так, как Вам советует emerge?

nortrace ()
Ответ на: Re: SIM не ставится от Unforgiven

Re: SIM не ставится

>Поищи в числе опций сборки нечто типа --wihouth-kde.
Раньше sim и kdelibs не требовались с такой опцией, только qt.

koTuk ()
Ответ на: Re: SIM не ставится от nortrace

Re: SIM не ставится

> А почему бы не сделать так, как Вам советует emerge?

Я так понимаю, он предлагает положить исходники в папку /usr/portage/distfiles
Скачал сорцы с sim-im.org и положил их туда - результат тот же самый.

SaBo ★★ ()

Re: SIM не ставится

Ты читать умеешь?

* net-im/sim-0.9.4.3 contains icons and sounds with unclear licensing and thus
* you have to download and it put into '/usr/portage/distfiles' by yourself.

Deleted ()
Ответ на: Re: SIM не ставится от chapay

Re: SIM не ставится

> Скачайте, пожалуйста, именно этот пакет: http://dev.gentoo.org/%7Epva/sim-0.9.4.3-r1919_1924.patch.bz2, и положите его в '/usr/portage/distfiles' собственноручно.

Спасибо!!! А я-то, блин, думал, что нужно сорцы положить...

А с GIMP'ом чего может быть? =)

SaBo ★★ ()
Ответ на: Re: SIM не ставится от SaBo

Re: SIM не ставится

> А с GIMP'ом чего может быть? =)

По приведенному куску лога однозначно не скажу...

Попробуйте выполнить следующее:

#emerge --sync
#emerge -uND world
#revdep-rebuild
#emerge gimp

nortrace ()
Ответ на: Re: SIM не ставится от nortrace

Re: SIM не ставится

#emerge -uND world
>>> Emerging (55 of 65) net-print/cups-1.3.7-r1 to /

* cups-1.3.7-source.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking cups-1.3.7-source.tar.bz2 ;-) ... [ ok ]

* In order to have cups working with avahi zeroconf support, you need
* to have net-dns/avahi emerged with "mdnsresponder-compat" in your USE
* flag. Please add that flag, re-emerge avahi, and then emerge cups again.
*
* ERROR: net-print/cups-1.3.7-r1 failed.
* Call stack:
* ebuild.sh, line 49: Called pkg_setup
* cups-1.3.7-r1.ebuild, line 84: Called die
* The specific snippet of code:
* die "net-dns/avahi is missing the mdnsresponder-compat feature."
* The die message:
* net-dns/avahi is missing the mdnsresponder-compat feature.
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/net-print/cups-1.3.7-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/net-print/cups-1.3.7-r1/temp/die.env'.
*

* Messages for package sys-libs/timezone-data-2008c:

* You do not have TIMEZONE set in /etc/conf.d/clock.
* Skipping auto-update of /etc/localtime.

* Messages for package media-libs/freetype-2.3.7:

* After upgrading to freetype-2.3.5, it is necessary to rebuild
* libXfont to avoid build errors in some packages.
* The utilities and demos previously bundled with freetype are now
* optional. Enable the utils USE flag if you would like them
* to be installed.

* Messages for package sys-libs/com_err-1.40.9:

* PLEASE PLEASE take note of this
* Please make *sure* to run revdep-rebuild now.
* Certain things on your system may have linked against a different
* version of com_err -- those things need to be recompiled.
* Sorry for the inconvenience

* Messages for package app-editors/nano-2.1.2-r1:

* More helpful info about nano, visit the GDP page:
* http://www.gentoo.org/doc/en/nano-basics-guide.xml

* Messages for package net-misc/wget-1.11.3:

* The /etc/wget/wgetrc file has been relocated to /etc/wgetrc

* Messages for package dev-lang/python-2.5.2-r6:

*
* If you have just upgraded from an older version of python you will
* need to run:
*
* /usr/sbin/python-updater
*
* This will automatically rebuild all the python dependent modules
* to run with python-2.5.
*
* Your original Python is still installed and can be accessed via
* /usr/bin/python2.x.
*

* Messages for package sys-apps/coreutils-6.10-r2:

* Make sure you run 'hash -r' in your active shells.

* Messages for package net-misc/rsync-3.0.3:

* The rsyncd.conf file has been moved for you to /etc/rsyncd.conf
* Please make sure you do NOT disable the rsync server running
* in a chroot. Please check /etc/rsyncd.conf and make sure
* it says: use chroot = yes

* Messages for package app-misc/ca-certificates-20080514-r2:

* You should run update-ca-certificates manually after etc-update

* Messages for package x11-misc/xdg-utils-1.0.2-r1:

* Install >=x11-libs/gtk+-2 if you need command gtk-update-icon-cache.

* Messages for package sys-fs/udev-124-r1:

* If you build an initramfs including udev, then please
* make sure that the /sbin/udevadm binary gets included,
* as the helper apps udevinfo, udevtrigger, ... are now
* only symlinks to udevadm.
*
* mount options for directory /dev are no longer
* set in /etc/udev/udev.conf, but in /etc/fstab
* as for other directories.
*
* persistent-net does assigning fixed names to network devices.
* If you have problems with persistent-net rules,
* just delete the rules file
* rm /etc/udev/rules.d/70-persistent-net.rules
* and then trigger udev by either running
* udevadm trigger --subsystem-match=net
* or by rebooting.
*
* This may number your devices in a different way than it is now.
*
* For more information on udev on Gentoo, writing udev rules, and
* fixing known issues visit:
* http://www.gentoo.org/doc/en/udev-guide.xml

* Messages for package sys-kernel/gentoo-sources-2.6.25-r7:

* If you are upgrading from a previous kernel, you may be interested
* in the following document:
* - General upgrade guide: http://www.gentoo.org/doc/en/kernel-upgrade.xml

* Messages for package sys-devel/gcc-4.1.2:

* If you have issues with packages unable to locate libstdc++.la,
* then try running 'fix_libtool_files.sh' on the old gcc versions.

* Messages for package net-print/cups-1.3.7-r1:

* In order to have cups working with avahi zeroconf support, you need
* to have net-dns/avahi emerged with "mdnsresponder-compat" in your USE
* flag. Please add that flag, re-emerge avahi, and then emerge cups again.
*
* ERROR: net-print/cups-1.3.7-r1 failed.
* Call stack:
* ebuild.sh, line 49: Called pkg_setup
* cups-1.3.7-r1.ebuild, line 84: Called die
* The specific snippet of code:
* die "net-dns/avahi is missing the mdnsresponder-compat feature."
* The die message:
* net-dns/avahi is missing the mdnsresponder-compat feature.
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/net-print/cups-1.3.7-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/net-print/cups-1.3.7-r1/temp/die.env'.
*
* Regenerating GNU info directory index...
* Processed 168 info files.
* IMPORTANT: 6 config files in '/etc' need updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

SaBo ★★ ()
Ответ на: Re: SIM не ставится от Dudraug

Re: SIM не ставится

[dudraug@localhost ~]$ apt-cache policy sim
sim:
Установлен: (отсутствует)
Кандидат: 0.9.5~svn20080806-1
Таблица версий:
0.9.5~svn20080806-1 0
500 ftp://ftp.fi.debian.org sid/main Packages

О-о, я думал оно уже как давно мертво.

Dudraug ★★★★★ ()
Ответ на: Re: SIM не ставится от Dudraug

Re: SIM не ставится

ну гроб тоже можно распилить на части, а потом собрать. Только смысл не изменится :).

jcd ★★★★★ ()
Ответ на: Re: SIM не ставится от jcd

Re: SIM не ставится

>не вытаскивай покойников из гроба, используй пиджин.

:) пиджину до сима еще развиваться и развиваться...

petrosha ★★★★★ ()
Ответ на: Re: SIM не ставится от SaBo

Re: SIM не ставится

Сорри, был в отъезде.

Не очень понял, зачем нужно было приводить весь лог, и тем более не понял, собрался ли gimp.

Что касается лога... Либо Вы невнимательны, либо проблемы с английским...

Например, относительно cups:

> * In order to have cups working with avahi zeroconf support, you need

* to have net-dns/avahi emerged with "mdnsresponder-compat" in your USE
* flag. Please add that flag, re-emerge avahi, and then emerge cups again.

По всему остальному в логе также даны вполне четкие рекомендации, достаточно внимательно их прочитать.

nortrace ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.