LINUX.ORG.RU

Funtoo не находит Adobe-Flash 64-bit

 ,


0

1
# emerge --ask www-plugins/adobe-flash

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] www-plugins/adobe-flash-26.0.0.137  USE="nsplugin ppapi" 

Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) www-plugins/adobe-flash-26.0.0.137::net-kit
>>> Downloading 'https://fpdownload.adobe.com/pub/flashplayer/pdc/26.0.0.137/flash_player_npapi_linux.x86_64.tar.gz'
--2017-08-23 20:19:24--  https://fpdownload.adobe.com/pub/flashplayer/pdc/26.0.0.137/flash_player_npapi_linux.x86_64.tar.gz
Resolving fpdownload.adobe.com... 23.61.243.122
Connecting to fpdownload.adobe.com|23.61.243.122|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-08-23 20:19:24 ERROR 404: Not Found.

!!! Couldn't download 'adobe-flash-26.0.0.137-npapi.x86_64.tar.gz'. Aborting.
 * Fetch failed for 'www-plugins/adobe-flash-26.0.0.137', Log file:
 *  '/var/tmp/portage/www-plugins/adobe-flash-26.0.0.137/temp/build.log'

>>> Failed to emerge www-plugins/adobe-flash-26.0.0.137, Log file:

>>>  '/var/tmp/portage/www-plugins/adobe-flash-26.0.0.137/temp/build.log'

 * Messages for package www-plugins/adobe-flash-26.0.0.137:

 * Fetch failed for 'www-plugins/adobe-flash-26.0.0.137', Log file:
 *  '/var/tmp/portage/www-plugins/adobe-flash-26.0.0.137/temp/build.log'
# emerge --ask www-plugins/freshplayerplugin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] www-plugins/adobe-flash-26.0.0.137  USE="nsplugin ppapi" 
[ebuild  N     ] www-plugins/freshplayerplugin-0.3.7  USE="-gles2 -gtk3 -jack (-libav) -libressl -pulseaudio -v4l -vaapi -vdpau" 

Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 2) www-plugins/adobe-flash-26.0.0.137::net-kit
 * Fetching files in the background.
 * To view fetch progress, run in another terminal:
 * tail -f /var/log/emerge-fetch.log
>>> Downloading 'https://fpdownload.adobe.com/pub/flashplayer/pdc/26.0.0.137/flash_player_npapi_linux.x86_64.tar.gz'
--2017-08-23 20:22:04--  https://fpdownload.adobe.com/pub/flashplayer/pdc/26.0.0.137/flash_player_npapi_linux.x86_64.tar.gz
Resolving fpdownload.adobe.com... 23.61.243.122
Connecting to fpdownload.adobe.com|23.61.243.122|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-08-23 20:22:04 ERROR 404: Not Found.

!!! Couldn't download 'adobe-flash-26.0.0.137-npapi.x86_64.tar.gz'. Aborting.
 * Fetch failed for 'www-plugins/adobe-flash-26.0.0.137', Log file:
 *  '/var/tmp/portage/www-plugins/adobe-flash-26.0.0.137/temp/build.log'

>>> Failed to emerge www-plugins/adobe-flash-26.0.0.137, Log file:

>>>  '/var/tmp/portage/www-plugins/adobe-flash-26.0.0.137/temp/build.log'

 * Messages for package www-plugins/adobe-flash-26.0.0.137:

 * Fetch failed for 'www-plugins/adobe-flash-26.0.0.137', Log file:
 *  '/var/tmp/portage/www-plugins/adobe-flash-26.0.0.137/temp/build.log'

Подскажите, пожалуйста, как правильно ставить flash player?

★★

после скачки архивов вручную как правильно их использовать

# ls /home/user/Desktop
flash_player_npapi_linux.x86_64.tar.gz  flash_player_ppapi_linux.x86_64.tar.gz

куда распаковать libpepflashplayer.so и libflashplayer.so ?

как я понимаю, один из них для фаерфокс, другой для хрома ? как в этих браузерах настроить эти библиотеки после распаковки?

znavko ★★ ()

тут написана инструкция https://www.vivaolinux.com.br/dica/Funtoo-com-Fresh-Plugin-Pepper-Flash-no-Fi... установки из репозитария https://github.com/i-rinat/freshplayerplugin

установил архив из репозитария, выполнив три волшебные команды: `cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo && make && make install` и для выполнения cmake установив три библиотеки: x11-libs/libva x11-libs/libvdpau media-libs/libv4l. прописал в ~/.config/freshwrapper.conf в переменную plugin_path адрес libpepflashplayer.so, распаковав его в домашнюю папку юзера из архива выше. перезапуск бледной луны не произвел эффекта.

znavko ★★ ()
Последнее исправление: znavko (всего исправлений: 1)

Funtoo не находит Adobe-Flash 64-bit

Норм фича. Как в Генту добавить?

BceM_IIpuBeT ★★★★ ()

1) с августа фунта перешла на киты и старая репа с ебилдами не обновляется

2) если ебилда нет в официальных китах, то поищи его в публичных оверлеях. оверлеи проще подключать через layman

3) в крайнем случае сохрани файл с флешом в distfiles, а ебилд в локальный оверлей

anonymous ()

Во первых funtoo, во вторых adobe, в третьих flash. Трижды ненужно! Поздравляем вы победили. За призом обращайтесь в спортлото.

anonymous ()
Ответ на: комментарий от Bruce_Lee

Что не работает?

для справедливости ради замечу, что хоть у меня флеш в хроме и разрешен, но на некоторых сайтах вместо флеша заглушка «поставьте флеш»

включить/выключить флеш можно в настройках хрома: chrome://settings/content/flash

anonymous ()
Ответ на: комментарий от anonymous

спасибо, я почему-то всегда думал, что нужно обновить хром, с которым обновится и плугинъ.

Bruce_Lee ★★ ()

TS-у:

Только что проверил на фунте с китами - флеш нормально собирается:

# eix adobe-flash                                                                                             
[I] www-plugins/adobe-flash [1]                                                                                             
     Available versions:  (22) 26.0.0.151^ms{tbz2}                                                                          
       {+nsplugin +ppapi ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}                       
     Installed versions:  26.0.0.151(22)^ms{tbz2}(08:21:29 AM 08/24/2017)(nsplugin ppapi ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Homepage:            http://www.adobe.com/products/flashplayer.html http://get.adobe.com/flashplayer/ https://helpx.adobe.com/security/products/flash-player.html
     Description:         Adobe Flash Player

[1] "net-kit" /var/git/meta-repo/kits/net-kit
# emerge adobe-flash                                                                                          
Calculating dependencies... done!                                                                                           
>>> Verifying ebuild manifests                                                                                              
>>> Emerging (1 of 1) www-plugins/adobe-flash-26.0.0.151::net-kit                                                           
>>> Installing (1 of 1) www-plugins/adobe-flash-26.0.0.151::net-kit                                                         
>>> Recording www-plugins/adobe-flash in "world" favorites file...                                                          
>>> Jobs: 1 of 1 complete                           Load avg: 0.63, 0.31, 0.47                                              
>>> Auto-cleaning packages...                                                                                               
                                                                                                                            
>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

Итого: мигрируй на киты: https://github.com/funtoo/meta-repo

anonymous ()
Ответ на: комментарий от anonymous

что может сказать пользователь фанту, прочитавший ровно половину мануала установки.

$ su -
Password: 
localhost ~ # install -d /var/git
localhost ~ # cd /var/git
localhost git # git clone https://github.com/funtoo/meta-repo.git
fatal: destination path 'meta-repo' already exists and is not an empty directory.
localhost git # emerge adobe-flash
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) www-plugins/adobe-flash-26.0.0.137::net-kit
>>> Downloading 'https://fpdownload.adobe.com/pub/flashplayer/pdc/26.0.0.137/flash_player_npapi_linux.x86_64.tar.gz'
--2017-08-24 18:01:42--  https://fpdownload.adobe.com/pub/flashplayer/pdc/26.0.0.137/flash_player_npapi_linux.x86_64.tar.gz
Resolving fpdownload.adobe.com... 23.61.243.122
Connecting to fpdownload.adobe.com|23.61.243.122|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-08-24 18:01:42 ERROR 404: Not Found.

!!! Couldn't download 'adobe-flash-26.0.0.137-npapi.x86_64.tar.gz'. Aborting.
 * Fetch failed for 'www-plugins/adobe-flash-26.0.0.137', Log file:
 *  '/var/tmp/portage/www-plugins/adobe-flash-26.0.0.137/temp/build.log'

>>> Failed to emerge www-plugins/adobe-flash-26.0.0.137, Log file:

>>>  '/var/tmp/portage/www-plugins/adobe-flash-26.0.0.137/temp/build.log'

 * Messages for package www-plugins/adobe-flash-26.0.0.137:

 * Fetch failed for 'www-plugins/adobe-flash-26.0.0.137', Log file:
 *  '/var/tmp/portage/www-plugins/adobe-flash-26.0.0.137/temp/build.log'
localhost git # 

оверлей подключать не хочу, так как мне нравится безопасная голая система. гугл-хром сломался об случайно открытый сайт checkflashinchrome.... удалил. а хромиум уже ставится больше 8 часов на этапе 1 оф 1. https://itmag.es/8zoc

но мне не нужны уязвимые бразуеры, надо флеш для pale moon (на базе фаерфокса).

znavko ★★ ()
Ответ на: комментарий от znavko

Убил! ;)

но мне не нужны уязвимые бразуеры

Расскажи пожалуйста, чем Хром уязвим? Чем так хорош PaleMoon? Я не поржать, я серьёзно! Встречаю постоянно просто это - Хром «уязвим».

masterdilly ()
Ответ на: комментарий от masterdilly

1 компания монополизирует рынок, в частности: навязчивый маркетинг услуг рекламы

2 компани собирает информацию об интересах пользователей без согласия и без предупреждения

3 в хромиум нашли бинарный код захвата аудио. хромиум, как и хром, причиняет вред пользователю.

znavko ★★ ()
Ответ на: комментарий от znavko

в хромиум нашли бинарный код захвата аудио

Желаю им удачи в захвате аудио на компьютере без микрофона.

Deleted ()
Ответ на: комментарий от anonymous

помогло, поставилось

с заменой файла libflashplayer.so, который яя распаковывал вручную.

видимо теперь надо как-то добавить плагин флеша в пэйлмун /home/fo/.mozilla/plugins ???

 # ego sync
# emerge adobe-flash
...
>> Installing (1 of 1) www-plugins/adobe-flash-26.0.0.151::net-kit
 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at https://bugs.gentoo.org/ unless you report exactly
 * which two packages install the same file(s). See
 * https://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how
 * to solve the problem. And once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 * 
 * Detected file collision(s):
 * 
 * 	/usr/lib64/nsbrowser/plugins/libflashplayer.so
 * 
 * Searching all installed packages for file collisions...
 * 
 * Press Ctrl-C to Stop
 * 
 * None of the installed packages claim the file(s).
 * 
 * Package 'www-plugins/adobe-flash-26.0.0.151' merged despite file
 * collisions. If necessary, refer to your elog messages for the whole
 * content of the above message.

>>> Recording www-plugins/adobe-flash in "world" favorites file...

 * Messages for package www-plugins/adobe-flash-26.0.0.151:

 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at https://bugs.gentoo.org/ unless you report exactly
 * which two packages install the same file(s). See
 * https://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how
 * to solve the problem. And once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 * 
 * Detected file collision(s):
 * 
 * 	/usr/lib64/nsbrowser/plugins/libflashplayer.so
 * 
 * Searching all installed packages for file collisions...
 * 
 * Press Ctrl-C to Stop
 * 
 * None of the installed packages claim the file(s).
 * 
 * Package 'www-plugins/adobe-flash-26.0.0.151' merged despite file
 * collisions. If necessary, refer to your elog messages for the whole
 * content of the above message.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

znavko ★★ ()
Ответ на: комментарий от znavko

Как так? Неужели мы не можем ничего утверждать о работе PaleMoon? Странно это. Скорее всего они белые и пушистые. Зачем иначе им делать бесплатный продукт?

masterdilly ()
Ответ на: комментарий от znavko

в хромиум нашли бинарный код захвата аудио

Долго искали? В настройках есть опция разрешать ли доступ к вебке и микрофону. Это нужно для всяких вебклментов-чатов.

grem ★★★★★ ()
Ответ на: комментарий от znavko

поставился хромиум, притянув с=библиотеку pepperflash: https://itmag.es/3JuWm

беда в том, что при старте браузер показываетс вот такую вкладку (настроено - показыват пустую вкладку) https://itmag.es/4EUvN

то же было и в гугл-хром.

и другой вопрос: как в xfce4 нижнюю панель, закрепленную вннизу сделать не поверх окна, а чтобы окно программы не подлазило под строку:: https://itmag.es/5PdrB

znavko ★★ ()
Ответ на: комментарий от znavko

компьютер несколько раз зависал без каких-либо признаков жизни при просмотре нескольких сайтов (блоги о линукс, каждый раз разные), перегруженных джавой, в pale moon: просто картинка экрана останавливалась, курсор не двигался, клавиатура не реагировала.

пользуюсь хромиум, ставлю браузеры, изучаю надежность пакетов.

znavko ★★ ()
Ответ на: комментарий от grem

В настройках есть опция разрешать ли доступ к вебке и микрофону. Это нужно для всяких вебклментов-чатов.

Не... Это был код для определения «окей, гугл». Если включаешь эту фичу, этот код постоянно слушает через микрофон и ищет маркер начала вопроса. Локально, конечно. Проблема была в том, что этот код скачивался из интернета тайком, без баннеров на весь экран. И скачивался всегда.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

не всем еще доступна идея по с открытым исходным кодом

znavko ★★ ()
Ответ на: комментарий от i-rinat

У меня яндекс-карты почему-то сначала не реагировали на слово «слушай», а на «слышь» нормально отзывались.

Так скачивался он всегда или после включения фичи?

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
Ответ на: комментарий от grem

Так скачивался он всегда или после включения фичи?

Я разве забыл упомянуть? Всегда он скачивался. Включаешь браузер, а через некоторое время он выкачивает себе разные обновляющиеся компоненты. Среди них в какой-то момент появился системый аддон, в составе которого и был тот закрытый NaCl модуль.

Активировался он, только когда фичу включаешь. Но просто сам факт непрошенной загрузки блоба заставил многих отложить кирпичей.

i-rinat ★★★★★ ()

Поставь себе Funtoo kits как сказано на официальном сайте в разделе News.

LongLiveUbuntu ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.