LINUX.ORG.RU

[gentoo][newbie] Правильно обновить adobe-flash


0

1

Вчера с утра впервые поставил gentoo, обжился и вздумал обновить мир. И вот возникло непонимание, не разобрался еще толком с портажем.
Ставил из ~amd64 нативный флеш, были предложения из версий 10.2 (64-битная) и 10.3 (32-битная). Выбрал нативную, ручками указав версию и вписав юз-флаги «64bit -32bit» в packages.use. Обновляюсь:

space ~ # emerge -avDNu world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] app-emulation/emul-linux-x86-gtklibs-20110129  USE="-development" 5,861 kB
[ebuild  N    ] www-plugins/nspluginwrapper-1.3.0  422 kB
[ebuild     U ] www-plugins/adobe-flash-10.3.181.14-r1 [10.2.159.1_p201011173] USE="vdpau (-kde) (-32bit%) (-64bit%*) (-bindist%) (-multilib%*)" 5,320 kB

Total: 3 packages (1 upgrade, 2 new), Size of downloads: 11,601 kB

Would you like to merge these packages? [Yes/No] 
То есть обновляется то, что не нужно обновлять. Скажите, как правильно организовать так, чтобы обновление вылезло только при появлении более свежего ебилда с флагом 64bit?

★★★

Не заморачивайся из-за этого. Флэша 64 битного пока еще считай, что нет. Пусть обновляется. Кстати, чистое ИМХО, но не рекомендую на ~arch сидеть, пока не освоишься. Лучше нужные вещи размаскируй через package.keywords

MahMahoritos ★★★ ()
Ответ на: комментарий от anonymous

> * Messages for package www-plugins/adobe-flash-10.3.181.14-r1:

...

* Adobe has no stable 64-bit native version at this time.


Суть моего пожелания в том, чтоб при обновлении emerge не обновлял нативную версию 10.2.159.1_p201011173 до 32-битной 10.3.181.14. О том, что эта версия считается нестабильной, я в курсе.

metar ★★★ ()
Ответ на: комментарий от MahMahoritos

> Не заморачивайся из-за этого. Флэша 64 битного пока еще считай, что нет. Пусть обновляется.
В общем это не принципиально, наверное, поставлю таки 32-битный. Тут скорее «спортивный» интерес.

Кстати, чистое ИМХО, но не рекомендую на ~arch сидеть, пока не освоишься. Лучше нужные вещи размаскируй через package.keywords

Спасибо. Собсно, я так и делаю. :)

metar ★★★ ()
Ответ на: комментарий от metar

package.mask

www-plugins/adobe-flash-10.2.159.1_p201011173

Вообще в package файлах можно применять разные модификаторы - =,<,>. Я обычно размаскирую пакеты формой <package-9999 **. Это чтобы гитовые версии не ставились.

MahMahoritos ★★★ ()

Флеш ставится с флагом 32bit. И он тянет за собой multilib-x86 чтобы запускать эти самые библиотеки, которые 32bit.

Хотя у тебя почему-то флеш ставится -32bit -64bit. Подумай об этом.

Deleted ()

Попробуй(должно помочь)

из под юзера: nspluginwrapper -i /opt/Adobe/flash-player32/plugin/libflashplayer.so

xelftd ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.