LINUX.ORG.RU

не собирается net-mail/mailutils-3.1.1

 


0

1

Всем привет! При обновлении мира net-mail/mailutils-3.1.1 не собирается, требует постгресовую либу (libpq).

Проверил, она есть:

equery f dev-db/postgresql | grep libpq.so
/usr/lib64/postgresql-9.5/lib64/libpq.so
/usr/lib64/postgresql-9.5/lib64/libpq.so.5
/usr/lib64/postgresql-9.5/lib64/libpq.so.5.8

вот часть вывода:


checking for struct utmp.ut_user... yes
checking for struct utmp.ut_name... yes
checking for wcwidth... (cached) yes
checking for mysql_real_connect in -lmysqlclient... -lmysqlclient -lm
checking for PQconnectStart in -lpq... no
configure: error: in `/var/tmp/portage/net-mail/mailutils-3.1.1/work/mailutils-3.1.1':
configure: error: The requested library libpq is not found or is unusable
See `config.log' for more details

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/net-mail/mailutils-3.1.1/work/mailutils-3.1.1/config.log
 * ERROR: net-mail/mailutils-3.1.1::gentoo failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *               ebuild.sh, line  115:  Called src_configure
 *             environment, line 4133:  Called econf 'MU_DEFAULT_SCHEME=maildir' 'CURSES_LIBS=-lncurses -ltinfo ' '--with-berkeley-db' '--without-fribidi' '--disable-ipv6' '--with-gdbm' '--with-gsasl' '--with-guile' '--without-gssapi' '--without-ldap' '--with-mysql' '--enable-nls' '--enable-pam' '--with-postgres' '--enable-python' '--with-gnutls' '--disable-static' '--enable-pthread' '--without-tokyocabinet' '--without-kyotocabinet' '--with-tcp-wrappers' '--disable-build-servers' '--enable-build-clients' '--with-mail-spool=/var/spool/mail' '--with-readline' '--enable-sendmail' '--disable-debug' '--disable-rpath'
 *        phase-helpers.sh, line  665:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *   		die "$@"
 * 
 * If you need support, post the output of `emerge --info '=net-mail/mailutils-3.1.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-mail/mailutils-3.1.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-mail/mailutils-3.1.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-mail/mailutils-3.1.1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-mail/mailutils-3.1.1/work/mailutils-3.1.1'
 * S: '/var/tmp/portage/net-mail/mailutils-3.1.1/work/mailutils-3.1.1'

>>> Failed to emerge net-mail/mailutils-3.1.1, Log file:

>>>  '/var/tmp/portage/net-mail/mailutils-3.1.1/temp/build.log'
 * 
 * The following package has failed to build, install, or execute postinst:
 * 
 *  (net-mail/mailutils-3.1.1:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/net-mail/mailutils-3.1.1/temp/build.log'

checking for PQconnectStart in -lpq... no

В логе посмотри, почему тест не проходит.

/var/tmp/portage/net-mail/mailutils-3.1.1/work/mailutils-3.1.1/config.log
Radjah ★★★★★ ()
Ответ на: комментарий от Radjah

заново перекомпилировал, плюс еще с USE=«guile postgres», все также «configure: exit 0» config.log

lor4ik ()

А тебе postgresql для mailutils действительно нужен?

Я в этой же ситуации сделал вырубил его через USE flag.

anonymous ()
Ответ на: комментарий от lor4ik

а линк есть в /usr/lib64?

 # ls -l /usr/lib64/libpq.so*
lrwxrwxrwx 1 root root 33 май 22 11:40 /usr/lib64/libpq.so -> postgresql-9.5/lib64/libpq.so.5.8
lrwxrwxrwx 1 root root 33 май 22 11:40 /usr/lib64/libpq.so.5 -> postgresql-9.5/lib64/libpq.so.5.8
lrwxrwxrwx 1 root root 33 май 22 11:40 /usr/lib64/libpq.so.5.8 -> postgresql-9.5/lib64/libpq.so.5.8

samy_volosaty ★★★★★ ()
Ответ на: комментарий от samy_volosaty
ls: невозможно получить доступ к '/usr/lib64/libpq.so*': Нет такого файла или каталога

и что я должен сам создавать?

lor4ik ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.