LINUX.ORG.RU

compton подтормаживает на nvidia

 ,


0

1

есть такие настройки. mc при up/down тормозит как-то. Отключил compton - не тормозит

backend = "glx";
vsync = "opengl-swc";
sw-opti = false; # Ограничение количества отрисовок (--sw-opti)
shadow = false;
no-dnd-shadow = true;
no-dock-shadow = true;
fading = false;
no-fading-openclose = true;
paint-on-overlay = true;
# inactive-dim = 0.1; # Затемнение неактивных окон (--inactive-dim)
★★★★

На проприетарном драйвере разве когда-то было иначе?

Гугли про проблемы nvidia с 2D (и композиторами в том числе) в Linux.

mord0d ★★★★★ ()

комптона уже год как не существует. дебиан такой смешной. зато стабильность, да?

anonymous ()
Ответ на: комментарий от mord0d

На проприетарном драйвере разве когда-то было иначе?

ну у меня было иначе. если карту чаще чем раз в 10 лет обновлял

moot ★★★★ ()

> backend = «glx»

Используй обычный xrender. Например с бэкендом glx у меня тормоза на GeForce 7025 (интеграшка в чип nForce 630a). И это странно, ведь Compiz чувствует себя прекрасно.

У меня так:

compton --vsync opengl

И всё.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от hotpil

комптон разве в репах дебиана был

был, есть и будет - потому что если в сиде есть, значит и в релиз отправят... лично у меня ничего не тормозит - тем более под проприетарщиной, она собственно именно для того и существует, что бы раскрыть весь потенциал видеокарты - потому как без нее невидиа говна кусок, но с ней помудиться надо для одной карты просто драйвера хватит, другой еще nvidia-xconfig подавай, а третья без nvidia-settings и дополнительной настройки тупит как проклятая...

amd_amd ★★★★ ()
Последнее исправление: amd_amd (всего исправлений: 2)
Ответ на: комментарий от hotpil

я не знаю. тс вообще не написал какой у него дистр, но, судя по толщине мха, получается что дебиан или его производное.

anonymous ()
# nvidia
backend = "glx";
glx-no-stencil = true;
# glx-swap-method = "copy";
glx-no-rebind-pixmap = true;
xrender-sync-fence = true;
# unredir-if-possible = true;
shadow = false;
no-dnd-shadow = true;
no-dock-shadow = true;
fading = false;
no-fading-openclose = true;

вот так работает

bryak ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.