LINUX.ORG.RU

Ubuntu 18.04.4 - уроды

 


0

1

Всем привет, всю жизнь переключался между языками по CapsLock. Поставил убунту в виртуалку, но теперь при переключении лезет окно по середине экрана, притом если постоянно нажимать CapsLock то окно не убирается, ввод блокируется. Как убрать эту хрень не знаю.

Вот это

1. Проблема третегнома? У меня в кедах норм работает.
2. Три языка. Гоняет по кругу. Как ты капсом по кругу три языка переключать собрался?

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

Фотка для примера, у меня два языка, гоняется по кругу. Однако, если нажать капс и сразу начать писать окно висит, а текст не пишется. Нужно бросать ввод на 3 секунды и только тогда окно пропадает и я могу писать

AntonyRF ★★☆ ()
Ответ на: комментарий от AntonyRF

А в штатных настройках переключения нет галки про это окно?
Или в gnome-tweak-tool, например?
Я просто третьегномом не пользовался, а в кедах такой фигни нет =)

Zhbert ★★★★★ ()
Ответ на: комментарий от AntonyRF

Выручайте плиз

Я подакдакго за тебя тут: https://askubuntu.com/questions/988895/keyboard-layout-choice-popup-shows-up-in-gnome-when-pressing-caps-lock-how-to-d

Оно? Сам гномом не пользуюсь, но вроде у страдальца по ссылке те же были вопросы.

gutaper ★★★★ ()
Последнее исправление: gutaper (всего исправлений: 1)
Ответ на: комментарий от Zhbert

Как ты капсом по кругу три языка переключать собрался?

Нажимаешь Caps Lock, пока язык не переключится на нужный. У меня возле часов есть индикатор (KDE5). Какая здесь проблема?

Pravorskyi ★★ ()

Этой Гномопроблеме уже лет 500. Причём они её не только залихватски решают, но и возрождают. Проще снести нафиг. Или биндить иксовые приблуды.

anonymous ()

Ставил ту же версию той же убунты на виртуалку под масдаем. Ничего не менял и переключался по Alt+Пробел. Всё нормально работало. Полагаю, когда ты Alt+Пробел менял на Ctrl+Alt, что-то не совсем грамотно сделал. Советую переставить убунту и привыкнуть в Alt+Пробел.

PahomUbuntu ()

В дефолтной ubuntu для переключения раскладок используется ibus Как у тебя там всё настроено для гнома посмотри так:

gsettings list-recursively org.gnome.desktop.input-sources

Потом сделай apt purge ibus и настрой переключение раскладки через xkb, вот мои настройки:

[org/gnome/desktop/input-sources]
per-window=true
sources=[('xkb','us'), ('xkb','ru')]
xkb-options=['grp_led:scroll', 'compose:ralt', 'grp:caps_toggle']
bass ★★★★★ ()
Последнее исправление: bass (всего исправлений: 1)