LINUX.ORG.RU

Переключение раскладки по CapsLock: светодиодные индикаторы


0

1

Если настроить переключение раскладки по CapsLock, то собственно капс будет включаться как shift-caps, но индикатор CapsLock будет показывать текущую раскладку вместо состояния капса.

Можно ли сделать так что бы раскладка переключалась по CapsLock, её состояние показывалось индикатором Scroll Lock, а собственно режим ЗАГЛАВНЫХ БУКВ переключался по shift-caps, ctrl-caps или как-то так, но не молча, а показывая своё состояние индикатором Caps Led?

★★★★★

По крайней мере через панель управления в гноме без проблем, насчёт KDE и прочего не в курсе.

Interlace ★★ ()
Ответ на: комментарий от gentoo_root

А в чём проблема?

При переключении раскладки меняются оба индикатора: и скролл и капс.

А я хочу, что бы при этом менялся только скролл, а капс показывал состояние капса (который теперь по шифт-капслок)

Xenius ★★★★★ ()
Ответ на: комментарий от mopsene

У меня как ты хочешь

setxkbmap -print в студию!

а ты как?

Через гномовскую управлялку. Впрочем вроде через КДЕшную так же было. И когда через setxkbmap вроде тоже так

Кстати, прошу отметиться в треде, если можно

Xenius ★★★★★ ()
Ответ на: комментарий от mopsene

xfce4-plugin

Он ставит раскладку typewriter, где например на крайней правой в нижнем ряду клавише не запятая и точка, а какие-то другие символы.

Xenius ★★★★★ ()

У тебя какой-то неправильный Caps

anonymous ()
Ответ на: комментарий от Xenius

setxkbmap -print в студию!

Не знаю, чем тебе это поможет. Но лови:

xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+us+ru:2+inet(evdev)+terminate(ctrl_alt_bksp)+capslock(grouplock)+compose(lwin)"	};
	xkb_geometry  { include "pc(pc104)"	};
};

Кстати, прошу отметиться в треде, если можно

Уже гоняю твои команды, пока ничего не найдено.

P.S. Работают у меня эти светодиодные индикаторы из коробки, ничего не настраивал. Если воткнуть другую клаву и попробовать на ней, то не работает, сейчас думаю как такое получается (обе подключены по USB).

mopsene ★★★ ()
Ответ на: комментарий от Xenius

При переключении раскладки меняются оба индикатора: и скролл и капс.

Давно такое было. Обновиться надо, это очень давно пофиксили.

gentoo_root ★★★★★ ()
Ответ на: комментарий от Xenius

В гномовских параметрах раскладки есть пункт «Использовать клавиатурные индикаторы для отображения доп. раскладок». У меня там включён только Scroll Lock. При этом, даже если раскладка переключается капсом, загорается только Scroll Lock. У меня гном 3.2

Interlace ★★ ()
Ответ на: комментарий от fractaler
$ setxkbmap -option -print
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+us+ru:2+inet(evdev)"	};
	xkb_geometry  { include "pc(pc105)"	};
};
$ setxkbmap -layout us,ru -option -option terminate:ctrl_alt_bksp,grp:caps_toggle,grp_led:scroll,compose:rwin -print
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete+ledscroll(group_lock)+ledcaps(group_lock)"	};
	xkb_symbols   { include "pc+us+ru:2+inet(evdev)+capslock(grouplock)+compose(rwin)+terminate(ctrl_alt_bksp)"	};
	xkb_geometry  { include "pc(pc105)"	};
};

Как видишь, caps диод тоже задействуется для переключения раскладки, хотя я его не задавал в опциях.

Xenius ★★★★★ ()

Я правильно понял, что должно быть так?

Жму caps lock - загорается scroll lock led.
Жму caps lock ещё раз - scroll lock led тухнет.

Жму shift + caps lock - загорается caps lock led.
Жму shift + caps lock ещё раз - caps lock led тухнет.

Тогда у меня так и работает.

blackst0ne ★★★★★ ()
Ответ на: комментарий от Xenius

Как видишь, caps диод тоже задействуется для переключения раскладки, хотя я его не задавал в опциях.

Да, точно, я сейчас проверил, опция только добавляется. Нужно гуглить, какой командой отключать опцию.
Дело в том, что у меня раскладка назначается скриптом из автозапуска, а не настройками окружения (потому что работает в любом DE, WM). Так вот, если сначала выполнить

setxkbmap -layout us,ru -option -option terminate:ctrl_alt_bksp,grp:caps_toggle,grp_led:caps

а потом

setxkbmap -layout us,ru -option -option >terminate:ctrl_alt_bksp,grp:caps_toggle,grp_led:scroll

то работают оба индикатора. Тебе надо искать, что включает капс. Наверняка это DEшная переключалка, которая или глючит, или неправильно настроена. Её можно отключить и настраивать переключалку скриптом.
Кстати, что за DE/WM?

fractaler ★★★★★ ()

Включает заглавные буквы по Shift+Capslock и caps lock led, раскладку меняет по Capslock и показывает по scroll lock led.

/usr/bin/setxkbmap -layout "us,ru" -variant ",winkeys" -option "grp:caps_toggle,grp_led:scroll"
Fedora16, fluxbox

fjoe ()
Ответ на: комментарий от fjoe

см. выше — не выключает grp_led:caps, который включается у топикстартера где-то ещё.

fractaler ★★★★★ ()

у меня в кде из коробки так.

DrF ()
Ответ на: комментарий от blackst0ne

Тогда у меня так и работает.

Видимо, это где-то у меня баг.

На ноуте такой проблемы нет, потому что там scroll led нет и приходится юзать caps led...

Xenius ★★★★★ ()
Ответ на: комментарий от fractaler

ой, какие-то это не правильные команды.

Вторая -option что бы вначале очистить все опции. Можешь попробовать -option " или отдельный вызов setxkbmap

Xenius ★★★★★ ()
Ответ на: комментарий от Xenius

Вторая -option что бы вначале очистить все опции.

Попробовал с двумя -option. Всё работает как надо.

setxkbmap -layout us,ru -option -option terminate:ctrl_alt_bksp,grp:caps_toggle,grp_led:scroll

А вот как ты выше написал действительно не срабатывает — caps_led не отключается.

fractaler ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.