LINUX.ORG.RU

Два нубских вопроса - про обновление ядра и про установку более свежией версии программы, нежели в репах (Mint 18.2)

 , , , ,


0

1

Здравствуйте товарищи!

Не захотел плодить две отдельные темы. Поэтому два вопроса. Оба гуглил - не нагуглил. Может не так гуглил, но старался, если что тапками не кидайте, я только вникаю в Linux =)

Стоит Linux Mint 18.2 KDE. После установки были проблемы с ядром, оказалось, что 4.8 вообще плохо дружит с моим ноутом (писал об этом тут Linux Mint 18.2 - постоянно включается и выключается экран).

В итоге обновился до 4.9, Mint предложил обновиться до 4.10. Обновился... Заметил, что комп иногда подвисает. Экспериментировал несколько недель, теперь уверено могу сказать, что это связано с ядром. На 4.10 время от времени виснет, на 4.9 работает как часы.

Собственно, накатил заново Mint, поставил ядро 4.9 и живу. Он предлагает обновить ядро до 4.10, я просто это не делаю и все.

Суть вопроса: вместе с ядром менеджер обновлений предлагает обновить пакеты linux-firmware и linux-libc-dev, я так понял, тесно связанные с ядром. Стоит их обновить, или лучше не трогать вместе с ядром?

Вдогонку второй вопрос. Когда жил на Debian 9, там была версия K3B 2.0.3а, которая замечательно дружила с моим Blu-ray резаком.

В Mint 18.2 версия 2.0.3 и в самом конце записи она не редко выдает ошибку.

Как правильно установить себе 2.0.3а? В репозитории Ubuntu - 2.0.3, на сайте K3B пакетов для скачивания нет. Не ставить же пакет от Debian? Или можно?

ЗЫ. На Debian назад пока не хочу, т.к. у меня ноут с Nvidia Optimus. В Debian только «шмель», в Ubuntu-подобных можно использовать nvidia-prime, с ним как-то повеселее в игрушки играть.

linux-firmware и linux-libc-dev

Первый — фирмвари, второй — сишные хедеры.
Если всё работает, то первый обновлять не стоит — проблема может расти оттуда (отсутствие нужного фирмваря, дропнутая поддержка твоей железки в новой версии), второй, если он напрямую тянется ядром или linux-firmware, тоже не имеет смысла, но он может тянуться и другим пакетом, смотри зависимости (как это делается в твоём дистрибутиве я не знаю).

r3lgar ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.