LINUX.ORG.RU

Переключение раскладки в Ubuntu Gnome

 , , ,


0

1

Всем привет.

В Gnome под Ubuntu 16.04 (судя по репортам на форумах, проблема тянется аж с 11 года) хоткеи срабатывают не по отпусканию клавиш, а по их нажатию (?).

Суть проблемы - пользуюсь для смены языка сочетанием клавиш ctrl+shift. И благодаря сочетанию этого и бага (фичи?) выше, я не могу адекватно пользоваться хоткеями в приложениях - в терминале не могу через раз делать вставку, открывать новые вкладки (ибо как только жмется ctrl+shift меняется раскладка).

Можете подсказать как с этим бороться? Как понимаю проблема давняя, но вменяемого решения на просторах интернета и лора я найти не сумел. А данная проблема очень сильно мешает пользоваться системой.

хоткеи срабатывают не по отпусканию клавиш, а по их нажатию (?).

всё правильно делают.

darkenshvein ★★★★★ ()

Не хоткеи, а переключение раскладки срабатывает по нажатию.

Как бороться. Вешать баги, горячие клавиши должны работать в любой раскладке.

Aceler ★★★★★ ()

на 16.04 unity (параметры ввода текста) установил переключение одной клавишей alt тоже тормозит

команда в терминале setxkbmap us,ru -option 'grp:alt_shift_toggle,grp_led:scroll'

начинает нормально работать,добавил скрипт в автозагрузку

#!/bin/sh setxkbmap us,ru -option 'grp:alt_shift_toggle,grp_led:scroll'

ncln ()
Ответ на: комментарий от ncln

Пробовал ваш вариант, тоже переключает сразу по нажатию, а не по отпусканию клавиши, так что думаю это немного другое

Umslopogas ()

Используй уже super-space и не мучайся: работает по дефолту и в винде, и в линуксах, и на маке.

kwinto ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.