LINUX.ORG.RU

Проблема с переключением раскладок в gnome3

 , ,


0

3

Всем привет!
есть debian/gnome3.22
стандартное переключение раскладок имеет косяк - при смене раскладок окно теряет фокус. в полях ввода в браузере или в иные моменты это вызвыет массу проблем.
решение - перейти на нормаотне переключение средствами иксов. но не получается.

localectl status
System Locale: LANG=ru_RU.UTF-8
VC Keymap: us-acentos
X11 Layout: us,ru
X11 Model: pc105
X11 Options: grp:ctrl_shift_toggle,grp_led:none

cat ~/.local/share/xorg/Xorg.0.log | grep xkb
[ 28.616] (**) Option «xkb_rules» «evdev»
[ 28.616] (**) Option «xkb_model» «pc105»
[ 28.616] (**) Option «xkb_layout» «us,ru»
[ 28.616] (**) Option «xkb_options» «grp:ctrl_shift_toggle,grp_led:none»

cat /etc/default/keyboard
XKBMODEL=pc105
XKBLAYOUT=us,ru
XKBOPTIONS=grp:ctrl_shift_toggle,grp_led:none
BACKSPACE=guess

в голой консоле все работает, в gdm работает нормально. Но когда стартует гном - работает только то, что поставлено голочкой в gnome-tweak-tool. Если галочек не стоит то и раскладка никак не переключается.

попытался отключить в гноме переключение:
gsettings set org.gnome.settings-daemon.plugins.keyboard active false

gsettings get org.gnome.settings-daemon.plugins.keyboard active
false

что еще надо сделать что бы заработало переключение назначенное иксам????


стандартное переключение раскладок имеет косяк - при смене раскладок окно теряет фокус.

это каким образом такое случается? штатная работает идеально.

PS: у меня капсом переключается. debian 9. в 8ом тоже все ок было.

halturin ★★★★★ ()
Ответ на: комментарий от halturin

я раньше этого тоже не замечал, пока не поставил palemoon.
кратковремененная потеря фокуса есть в любом приложении, но я об это и не знал.
А вот в этом браузере потеря и возвращение фокуса воспринимается как окончание ввода в поле. если при вводе поменял раскладку то выделяется весь введенный ранее в поле текст. и соответвенно следующий введенный символ заменяет все предидущие если перед этим не сбросить выделение. крайне неудобно.
гуглежка показала что такое встречается, хотя и редко. Прямого решения не нашел, хочу попробовать отключить гномовую переключалку - но вот что то не выходит....

griz ()

Ну не знаю, нету у меня никаких косяков в debian 9 c 3.22.2 ни в консоли, ни в иксах, ни в гноме. Так всё и стоит, только gsettings get org.gnome.settings-daemon.plugins.keyboard active в true

Вообще у меня в памятке такое набрано про клавиатуру:

если некорректно работают dbus и окружение: dbus-update-activation-environment --all

Настройка в systemd VC keymap и вообще выбор настроек:

man xkeyboard-config

localectl set-x11-keymap «us,ru» pc105 «» grp:lctrl_lshift_toggle,terminate:ctrl_alt_bksp

Может поможет.

los_nikos ★★★★★ ()
Последнее исправление: los_nikos (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.