LINUX.ORG.RU

Почти включил вяленный на проприетарной невидии

 , , , ,


1

4

Пропатчил mutter, пропатчил weston, после долгого секса с ними они начали работать (mutter --wayland и weston --use-egldevice), но гном на вяленном так и не запустился, gnome-shell --wayland (вообще вроде как gnome-session надо писать, но мне оно просто выдаёт «Завершено» и всё) выдаёт такое: Unable to initialize the Clutter backend: no available drivers found, в gdm-е при выборе гнома на вяленном экран гаснет, а потом снова появляется форма авторизации.

Почти <подставить что угодно> на проприетарной невидии

Вся суть этого драйвера: вот-вот, почти, ещё немного.

anonymous ()
Ответ на: комментарий от anonymous

Вот не надо попыток перефорса. За щвабодкой вместо видеокарт к другим.

anonymous ()

Толку? Xwayland не поддерживается им. Плюс должен быть включён невидиевый KMS и DRI

Sunderland93 ★★★★★ ()

Ещё лет 10 подождите и валеный будет работоспособен, быть может.

Ygor ★★★★★ ()

Так для clutter по идее тоже надо патчь искать

BeerSeller ★★★★ ()

вяленый не нужен и не взлетит

peregrine ★★★★★ ()

Оооо... ты дело делаешь!)

А это все просто - gnome-shell не работает через wayland, он работает через прослойку Xwayland и никак иначе, даже на свободных дровах. Я частично на эту тему статью писал.

Посмотри вывод xlsclients в статье. Эти программы и не должны работать через вейланд, покаместь....

Выложи потом инструкцию как ты запустил вяленный на проприетарной невидии! Мне просто лень браться было - заведома додумал что не просто...

Может быть, будет тебе интересные ресурсы: один. два.

incker ()

Гном с патчами, настроить KMS для блоба и почему-то нужно удалить nvidia-settongs нужно мне. Всё это на Арче.

Там сейчас нечего смотреть. Конкретно гном лагает даже больше в анимациях чем с иксами и не запустить почти ничего. Даже простой glxinfo ругается, что дисплей не находит, и так с играми, разным софтом и так далее. Зато курсор кот окон не отрывается при перетаскивании.

Но даже у меня, как редкий случай, у кого завелось новый mutter 3.22.3 не работает, а только 3.22.2

Necrogrinder ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.