LINUX.ORG.RU

./configure выводит ошибку gtk+3

 ,


0

1

вообщим все так, скачала я gtk+-3.18.0 распаковала, затем сделала ./configure а оно мне вывело что отсутствуют пакеты затем я их установила sudo aptitude install libgtk-3-dev после снова сделала ./configure и выхлоп

configure: error: Package requirements (glib-2.0 >= 2.45.8    atk >= 2.15.1    pango >= 1.37.3    cairo >= 1.14.0    cairo-gobject >= 1.14.0    gdk-pixbuf-2.0 >= 2.30.0) were not met:

Requested 'glib-2.0 >= 2.45.8' but version of GLib is 2.44.1
Requested 'atk >= 2.15.1' but version of Atk is 2.14.0
Requested 'pango >= 1.37.3' but version of Pango is 1.36.8

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.


щито терь делать, как исправить. А то не собирается оно у меня.
sudo make install пишет
make: *** No rule to make target 'install'.  Stop.

★★

затем сделал

палишся.

x0r ★★★★★ ()

Requested 'glib-2.0 >= 2.45.8' but version of GLib is 2.44.1
Requested 'atk >= 2.15.1' but version of Atk is 2.14.0
Requested 'pango >= 1.37.3' but version of Pango is 1.36.8

Написано же, что нужны другие версии пакетов glib, atk и pango.

И зачем ты вообще что-то собираешь, когда ты не в состоянии даже самостоятельно прочитать текст из консоли?

Но решение есть. Ты, конечно, можешь скачать нужные версии пакетов с pkgs.org, а потом установить их из .deb вручную, но я уверен, что для этих пакетов есть свои зависимости, и, если ты захочешь устанавливать их вручную, велик шанс просидеть с этим до завтра, без должного результата. Лучше установи нужную программу из репозиториев, с помощью apt-get. Они для того и созданы, чтобы не думать (или почти не думать) о зависимостях и не собирать из исходников то, что уже собрано.

Дерзай. О результатах сообщи.

otasan ()

sudo apt-get build-dep gtk+

Deleted ()
Ответ на: комментарий от gssomi

Потому я и говорю, что если у тебя нет профессиональной необходимости в том, чтобы работать с исходниками, лучше установить нужную программу из репозиториев.

Cairo и так в репозиториях лежит, пишешь sudo apt-get install cairo и тебе делают хорошо.

otasan ()
Ответ на: комментарий от otasan

Если быть точным, то нужно вписать это:

sudo add-apt-repository ppa:cairo-dock-team/ppa
sudo apt-get update
sudo apt-get install cairo-dock cairo-dock-plug-ins

Собственно, гугл в помощь.

otasan ()
Ответ на: комментарий от otasan

уже почти все, только вот сейчас еще просит epoxy, а я вот не могу найти его.

gssomi ★★ ()
Ответ на: комментарий от gssomi

Потому что Ubuntu - не Windows 7, тут есть официальные и PPA репозитории, в которых всё за тебя собрано и устанавливается одной-тремя командами, с автоматическим подбором зависимостей и установкой нужной тебе версии. Это в высшей степени не разумно, даже если тебе так не кажется.

otasan ()

Но зачем? Какой в этом глубинный смысл? Как только ты сделаешь make install твоя убунта превратится в слаку, и ты запорешь систему следующим же обновлением.

Лучше скажи чего именно ты хочешь добиться, потому что ты явно делаешь что-то не так.

morse ★★★★★ ()
Ответ на: комментарий от otasan

дык я ж с репы и устанавливала мне и выдало об устаревших пакетах. Да и не знала ж что мне так много пакетов нужно будет :(

gssomi ★★ ()
Ответ на: комментарий от gssomi

В треде речь шла только о том, что ты пыталась что-то собрать, и у тебя это не получилось.

Давай лучше разберёмся с репозиториями. Что ты устанавливала, какие ошибки появились?

otasan ()
Ответ на: комментарий от morse

Лучше скажи чего именно ты хочешь добиться, потому что ты явно делаешь что-то не так.

хотела установить gtk+3 для смены темы.

и все началось с того что я насмотрелась галереи :(

gssomi ★★ ()
Ответ на: комментарий от gssomi

я так и думала, скачала, сделал

Как ты ни прикидывайся, а палишься всё равно.

GTK развивается вместе с этими билиблиотеками, и поэтому требует новейшие версии. Собирай и ставь всё это в одну директорию.

proud_anon ★★★★★ ()
Последнее исправление: proud_anon (всего исправлений: 1)
Ответ на: комментарий от proud_anon

Это у школьниц модно сейчас, не обращай внимание.

otasan ()
Ответ на: комментарий от morse

Как только ты сделаешь make install твоя убунта превратится в свалку,

// Поправил, можешь не благодарить
Впредь попрошу не выражаться!

FeyFre ★★★★ ()
Ответ на: комментарий от otasan
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                      Version           Architecture      Description
+++-=========================-=================-=================-========================================================
ii  libgtk-3-0:amd64          3.14.13-0ubuntu1  amd64             GTK+ graphical user interface library
ii  libgtk2.0-0:amd64         2.24.27-0ubuntu1  amd64             GTK+ graphical user interface library

gssomi ★★ ()
Ответ на: комментарий от gssomi

хотела установить gtk+3 для смены темы.

Во-первых, можно подумать что в убунте нет gtk3, а во-вторых, даже если его там нет, мало поставить сам gtk, надо еще и чтобы весь софт был собран с поддержкой этого тулкита. И тут уж либо вообще весь софт пересобирать (и тогда лучше иди на генту или рач) либо ставь дистрибутив где с gtk3 полный порядок (федору).

morse ★★★★★ ()
Ответ на: комментарий от gssomi

libgtk-3-0:amd64 3.14.13-0ubuntu1

А теперь расскажи мне, зачем ты пыталась собрать пакеты GTK3, когда они уже установлены у тебя в системе?

otasan ()
Ответ на: комментарий от morse

у меня был gtk+2 пока я не решила избавиться от юнити и поставить мате, поставила и производительность стало лучше, но сейчас работы стало чуть меньше и захотелось красоты.

gssomi ★★ ()
Ответ на: комментарий от otasan

а оно не появилось после «sudo aptitude install libgtk-3-dev»?

А теперь расскажи мне, зачем ты пыталась собрать пакеты GTK3, когда они уже установлены у тебя в системе?

незнаю

gssomi ★★ ()
Ответ на: комментарий от gssomi

решила избавиться от юнити и поставить мате

мате не поддерживает gtk3. Так что хоть обсобирайся, а красоты не получишь.

http://wiki.mate-desktop.org/status:gtk3

morse ★★★★★ ()
Последнее исправление: morse (всего исправлений: 1)
Ответ на: комментарий от gssomi

libgtk-3-0:amd64 и libgtk-3-dev - разные вещи. И нет, в списках зависимостей libgtk-3-dev нет libgtk-3-0:amd64, поэтому он был в системе изначально.

Ты вообще зря затеяла всю эту историю с GTK, поскольку и тогда, и сейчас можешь установить нужную тебе тему.

otasan ()
Ответ на: комментарий от morse

О, а я и не знал.

В общем, ТСу нужно просто включить композитинг и выбрать тему gtk2 на gnome-look. Собственно, это максимум, что можно с Mate сделать. Собирать ничего не нужно.

otasan ()
Ответ на: комментарий от otasan

Ты вообще зря затеяла всю эту историю с GTK, поскольку и тогда, и сейчас можешь установить нужную тебе тему.

дык я ж сперва попробовала установить тему, после полезла GTK устанавливать. Погуглила, а там все собирают. Думала уже есть в репах сделала sudo aptitude install gtk+-3 но не вышло, потом решила собрать. А сейчас сделала sudo apt-get install gtk+3 скачивается -_-

gssomi ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.