LINUX.ORG.RU
ФорумAdmin

Установка библиотек


0

0

Скачал я "Downloader fo X". При конфигурации (./configure) выдает:


*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: *** GLIB >= 2.2.0 not installed! ***


Скачал Glib 2.36. При конфигурировании выдает:


configure: error: *** pkg-config too old; version 0.14 or better required.


Прочитал в нете что нужно обновить GTK+. Скачал версию 2.36. При конфигурировании выдает:


checking for glib-2.0 >= 2.3.5    atk >= 1.0.1    pango >= 1.3.5... Requested 'glib-2.0 >= 2.3.5' but version
of GLib is 2.0.6

configure: error: Library requirements (glib-2.0 >= 2.3.5    atk >= 1.0.1    pango >= 1.3.5) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.


Что это? Что мне делать, посоветуйте... Какой-то замкнутый круг...
Я тут еще прочитал что тему с pkg-config можно разрешить путем прописывания:


PATH=$PATH:/usr/bin

В /root/.bash_profile. Но результатов это недало.
Плиз, помогите мне...

Ответ на: Re: Установка библиотек от chucha

Re: Re: Установка библиотек

Нет, выход другой - пользоваться бинарными пакетами если не умеешь собирать из исходников.

Или, если так на это пропёрло, взять какой-нибудь Gentoo/FreeBSD

Demetrio ★★★★★ ()
Ответ на: Тру-ля-ля от DARKTUX

Re: Тру-ля-ля

Фишка в удобстве установки программ из исходников, с помощью ports/portage

Только не вздумай пока лезть туда.

> Что мне даст echo $PATH?

Покажет все директории что занесены у тебя в переменную PATH

Demetrio ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.