LINUX.ORG.RU

Линукс (или хром) делает из макбука плиту для жарки яичницы

 , ,


0

2

Привет, ЛОР.

Спустя долгое время пребывания на макоси я таки умудрился соскучиться по линуксу. И таки даже полюбил новый гном после того, как увидел пятые кеды (какие-то они слишком недоделанные). И всё бы хорошо, если не считать отсутствия жестов на тачпаде, странного ускорения на нём и т.д., но это всё мелочи.

Настоящая беда подкралась из необычного места: за несколько минут работы ноут превращается в отличную грелку, плиту или ещё какую-нибудь греющую поверхность. Запущены только хром (который google-chrome, а не chromium) да терминал. Подозреваю, что дело таки в хроме (судя по powertop и htop), но как от него откажешься, когда тут тебе и рабочий флеш без лишних мучений, и сервисы гугла под него оптимизируются, и синхронизация истории с телефоном.

Вот прямо сейчас диспетчер задач хрома постоянно пишет, что процесс самого браузера жрёт 5-10% CPU, а GPU — 3-5%.
Уже и laptop-mode-tools поставил, и thermald — всё равно печка (с выхода из suspend за считанные минуты прогревается до 70 градусов и шумит, как будто взлететь хочет).
Что-то с этим вообще можно сделать, кроме как сменить браузер на совсем другой и кроме варианта терпеть?

Дистрибутив, конечно же, рачик, но не думаю, что это важно.
Железка: Macbook Air 5,1

На макоси хром тоже напрягал систему, но в шумную печку ноут всё-таки не превращался, блин.

Deleted

Ответ на: комментарий от anonymous

> хипстороподелка

> виноват линукс или хром

ды не боись ты так.. щаз выясним кто виноват :-D

user_id_68054 ★★★★★ ()
Последнее исправление: user_id_68054 (всего исправлений: 1)

Тут хром ни причем скорее всего, попробуй без хрома - думаю будет тоже самое. Скорее всего проблема в тюнинге чистот CPU/GPU - насколько я знаю в макбуки в процессе работы очень сильно рулят частотой CPU/GPU (возможно есще и RAM + HDD в слип переодически загоняют). Для начала сделай $ cat /proc/cpuinfo и посмотри модель процессара что у тебя стоит и загугли диопазон частот на которых он работает + сравни с тем какая у тебя в текущий момент частота («cpu MHz» должна менятся в зависимости от потребностей системы). Есть подозрение что у тебя проц работает постоянно на максимальной частоте и не понижает ее при IDLE системы - вот и греется. Тоже самое нужно помониторить для GPU - вот только тут я не помогу - нужно гуглить.

zaz ★★★★ ()
Ответ на: комментарий от user_id_68054

Вот прямо сейчас скачет в пределах 800-1700MHz, иногда до 2300 доходит. Правда, не уверен, lscpu уже можно доверять с этими их интеловскими турбами? Раньше i7z смотрели, но он слегка протух, вроде как.

Deleted ()
Ответ на: комментарий от Deleted

ну я думаю что он должен скакать где-то в пределах: 800~900 ..

думаю доверять можно.

то есть если мы имеем дело с плохой политикой выбора режима cpu — то в линуксах есть какой-то инструмент (демон) для регулирования этого дела (одично он не требуется, так как политика поумолчанию в ядре обычно работает нормально.

user_id_68054 ★★★★★ ()
Последнее исправление: user_id_68054 (всего исправлений: 1)
Ответ на: комментарий от user_id_68054

Посмотрел в lscpu процессор, загуглил на сайте интела модель встроенной видюхи, другого пути, увы, не знаю. dmesg | grep -i intel нужного не пишет.

Deleted ()
Ответ на: комментарий от Deleted

Кстати вопрос - он у вас греется и при этом активно начинает гудеть (вентиляторы на полную), или может просто не включаются вентиляторы (на маках они тоже вроде полностью софтверно рулятся) и он у вас не то чтобы сильно греется а просто плохо охлаждается ?

zaz ★★★★ ()
Ответ на: комментарий от Deleted

а ты подгружаешь — /boot/intel-ucode.img ? (пакет «intel-ucode» )

врядли конечно что проблема с плохой ревизией микрокодов.. но вдруг! :-)

user_id_68054 ★★★★★ ()
Ответ на: комментарий от zaz

Чуть выше как раз этот вариант обсуждали. По-моему, для интелов весьма типичные частоты. Но я могу хром погасить для теста. Или переключить ondemand на что-нибудь другое типа conservative.

Deleted ()
Ответ на: комментарий от user_id_68054

то есть если мы имеем дело с плохой политикой выбора режима cpu — то в линуксах есть какой-то инструмент (демон) для регулирования этого дела (одично он не требуется, так как политика поумолчанию в ядре обычно работает нормально.

Не thermald часом? Мне просто гугл его выдал, я его и поставил, но разницы не вижу, увы.

Deleted ()
Ответ на: комментарий от zaz

Сначала он быстро нагревается, вентиляторы потихоньку разгоняются, сейчас очень шумит (~5000 RPM при максимальных 6500), но таки остыл до начальных 56.

Deleted ()
Ответ на: комментарий от Deleted

А в каком режиме стартует загрузщик? В интернете пишут что если грузить macbook через стандартный MBR (lilo/grub) то у него какраз проблемы наблюдаются с перегревом, а если грузить через EFI загрузщик то он вроде как в более правельные режимы свои контроллеры переводит и греется значительно меньше. Хотя возможно у вас в BIOSe и нету опций по отключению EFI на новом mac-е.

zaz ★★★★ ()
Ответ на: комментарий от user_id_68054

Воу, честно признаться, я думал, в нынешних линуксах оно само подгружает. Поставил по арчевики, судя по всему, никаких изменений:

kevindetry~ dmesg|grep microcode
[    0.000000] CPU0 microcode updated early to revision 0x1b, date = 2014-05-29
[    0.113112] CPU1 microcode updated early to revision 0x1b, date = 2014-05-29
[    0.306896] microcode: CPU0 sig=0x306a9, pf=0x10, revision=0x1b
[    0.306905] microcode: CPU1 sig=0x306a9, pf=0x10, revision=0x1b
[    0.306916] microcode: CPU2 sig=0x306a9, pf=0x10, revision=0x1b
[    0.306927] microcode: CPU3 sig=0x306a9, pf=0x10, revision=0x1b
[    0.306997] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba

Deleted ()
Ответ на: комментарий от user_id_68054

Попробую вырубить турбо, хотя и боюсь, что тогда вместо компиляции (бывает нужно) будет ад :(

Deleted ()
Ответ на: комментарий от zaz

Хотя возможно у вас в BIOSe и нету опций по отключению EFI на новом mac-е.

я один разок видал Мак (какой-то) — там была возможность грузиться и через MBR и через UEFI .

ну и конечно я там проверил что режиме UEFI — файловая система /sys/firmware/efi/ подгружалась норм.

user_id_68054 ★★★★★ ()
Ответ на: комментарий от Deleted

да. тут определенно лучшим вариантом — было бы придумать что-то с частотой.

но отрубить турбо — это же просто проверки ради :-) ... мол в правильном ли направлении мы двигаемся

user_id_68054 ★★★★★ ()
Ответ на: комментарий от zaz

Тут MBR, по-моему, и нет даже. Гружу обычным gummiboot (можно EFISTUB, но совсем не хочется настраивать, он на маках очень специфичный и жуёт только boot/bootx64.efi).

Deleted ()

Макбук слишком проприетарен для линукса, он заточен под свою систему. Вот Thinkpad T- или X-серий - совсем другое дело!

anonymous ()
Ответ на: комментарий от user_id_68054

Ну, наверное, таки перемога: без турбо держится на уровне 800MHz, изредка дёргаясь до 2400, но очень редко. Ноут остыл, но ещё шумит (впрочем, думаю, это временно).

Deleted ()
Ответ на: комментарий от Deleted

понятно.

а «cpupower» — не попробовал ещё?

там есть возможность переключиться в одну из 5 политик (governor):

ondemand 	Dynamically switch between CPU(s) available if at 95% cpu load
performance 	Run the cpu at max frequency
conservative 	Dynamically switch between CPU(s) available if at 75% load
powersave 	Run the cpu at the minimum frequency
userspace 	Run the cpu at user specified frequencies 

(прописать в конфиг файл, или задавать в любой момент времени)

быть может одна из них будет работать правильно? :-)

user_id_68054 ★★★★★ ()
Ответ на: комментарий от user_id_68054

Ради эксперимента можно перевести ЦПУ гановер в юзерспейс режим запретить ему поднимать частоту меньше минимальной - комп станет конечно жутко тормозным но если проблема действительно в ЦПУ (а это и не факт что греется именно он) то макбук будет холодным постоянно. Ну и если поможет то тогда уже можно думать дальше как полутше крутить частоты на проце.

zaz ★★★★ ()
Ответ на: комментарий от user_id_68054

У меня просто что-то уже выставило powersave, мне кажется, более жестокого варианта и не придумать. Так-то про говерноры я знаю, само собой)

Deleted ()
Ответ на: комментарий от Deleted

Самый жосткий это userspace - он подразумевает что будет какойто демон (например cpud) который сам из юзерспейса будет преключать часттоты. У меня была похожая проблема с десктопом (обыкновенный комп) - грелся как печка. Ничего не помогало в результате перевел его в userspace и собрал простенький скрипт который режимы менял в зависи от нагрузки (стандартный cpud както не очень работал) + иногда загонял проц в low/high режим руками из командной строки ...

zaz ★★★★ ()
Ответ на: комментарий от Deleted

А какой драйвер cpufreq, собственно? cpupower -c all frequency-info | grep driver, ну или cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver — должен быть intel_pstate.

Ну и да, поставь powertop. Тулза дико глючная, но частоты вроде бы показывает.

intelfx ★★★★★ ()
Ответ на: комментарий от intelfx

intel_pstate

Он самый.

Ну и да, поставь powertop. Тулза дико глючная, но частоты вроде бы показывает.

Это обязательно, всегда её ставлю.

Сейчас пока ноуту сильно полегчало (правда, я так толком и не понял, отчего), если опять будет перегреваться, отпишусь. Сейчас частоты на уровне 800MHz, температура около 60 (колени слегка греет, но, вроде как, это уже похоже на штатную температуру).

Deleted ()
Ответ на: комментарий от Deleted

intel_pstate. И говернор powersave. И при этом оно у тебя греется. Внезапно, что тут сказать.

В ядре есть такая штука (для интелов), как RAPL: Running Average Power Limit. Умеет показывать потребление энергии различными частями процессора (да-да, именно энергии, той самой, что в Джоулях) и его ограничивать. Попробуй заюзать; вроде бы в thermald есть поддержка powercap/rapl как одного из методов охлаждения.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
Ответ на: комментарий от intelfx

Я вот что подумал. Может, проблема в GPU. Сейчас врубил просто всё, что можно было, что даже советуют не врубать, т.к. может не работать.

options i915 enable_rc6=7 enable_fbc=1 enable_psr=1 lvds_downclock=1

Днём протестирую, если всё останется так же плохо, буду дальше копать.

Deleted ()
Последнее исправление: Kevin_Detry (всего исправлений: 1)

Попробуй ubuntu на флешку запилить и с неё загрузиться, должно быть лучше.

anonymous ()

И таки даже полюбил новый гном
флеш без лишних мучений
рачик

(facepalm)

muted ()
Ответ на: комментарий от Deleted

Это помогает, но на ядрах до 4.0 gpu периодически виснет, при проигрывании видео (rMBP late 2013)

anonymous ()
Ответ на: комментарий от armbox

Это не acpi_cpufreq.

Драйвер intel_pstate умеет только powersave и performance (причём оба похожи на conservative с разной степенью агрессивности).

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)

В GNOME в настройках есть Энергосбережение - выстави половинную производительность CPU. В KDE это делается с помощью значка в системном трее.

ZenitharChampion ★★★★★ ()

Ну как можно доверять макбуку свои данные?

anonymous ()

собстввенно, на правах капитана очевидность заявляю, что ты забыл установить туда МакОС

darkenshvein ★★★★★ ()
Ответ на: комментарий от armbox

Да, есть, и много. Модель энергосбережения современных интелов сильно сложнее, чем можно выразить в табличках ACPI. intel_pstate это учитывает. Считай, «нативный видеодрайвер vs VESA». Тот случай, когда mechanism и policy нельзя разделить.

S775 не умеет intel_pstate

Он то ли с Sandy Bridge, то ли с Nehalem.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.