LINUX.ORG.RU
ФорумAdmin

Не могу сделать ppp0 интерфейсом по-умолчанию при его подключении


0

1

Привет всем! Не могу сделать ppp0 интерфейсом по-умолчанию при его подключении, постоянно по-умолчанию стоит eth0. Сейчас конфиг вот такой:

azq2@zhumarin:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo eth0
iface lo inet loopback

# wifi router
iface eth0 inet static
    address 192.168.1.2
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

# modem
iface ppp0 inet ppp
    post-up route add default dev ppp0
    pre-down route del default dev ppp0

Почему-то ppp0 после поднятия не становится интерфейсом по-умолчанию.

azq2@zhumarin:~$ route -n
Таблица маршутизации ядра протокола IP
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
195.128.182.26  0.0.0.0         255.255.255.255 UH    0      0        0 ppp0

Но если просто выполнить sudo route add default dev ppp0 - Всё ОК!

azq2@zhumarin:~$ route -n
Таблица маршутизации ядра протокола IP
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
195.128.182.26  0.0.0.0         255.255.255.255 UH    0      0        0 ppp0

Что я делаю не так? :(


Подними при поднятии ррр два маршрута к сетям 0.0.0.0/128.0.0.0 и к 128.0.0.0/128.0.0.0

По крайней мере у тебя будут маршруты через ррр с меньшей маской и не будет неопределенности с двумя одинаковыми маршрутами с одинаковой маской и метрикой.

pppd не поднимает второй defaultroute при наличии первого. Это не баг, а фича, которой уже 100 лет в обед. И что-то я не вижу никаких знакомых мне опций pppd из твоего первого поста. С тех пор много изменилось.

ansky ★★★★★ ()

попробуй полностью путь к route указать

xsektorx ★★★ ()

С каких это пор pppd разучился сам это делать ?

man pppd:

defaultroute
Add a default route to the system routing tables, using the peer as the gateway, when IPCP
negotiation is successfully completed. This entry is removed when the PPP connection is bro
ken. This option is privileged if the nodefaultroute option has been specified.

AS ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.