LINUX.ORG.RU
решено ФорумAdmin

При попытке коннекта к sftp ошибка Network error: Connection refused

 , ,


0

1

Добрый день! проблема следующая: пытаюсь коннектиться к sftp (сервер на убунте) через filezilla, выдает ошибку Network error: Connection refused Вот sshd_config

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 2132
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin no
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile	%h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

#Subsystem sftp /usr/lib/openssh/sftp-server
Subsystem sftp internal-sftp
Match user remote
    ChrootDirectory %h
    ForceCommand internal-sftp
    AllowTcpForwarding no
#Match User remote

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes
причем если убрать
Subsystem sftp internal-sftp
Match user remote
    ChrootDirectory %h
    ForceCommand internal-sftp
    AllowTcpForwarding no
и раскомментить
#Subsystem sftp /usr/lib/openssh/sftp-server
то подключается, правда можно зайти в любую директорию на сервере, чего не хотелось бы... Помогите советом


что в логах, какая версия openssh?

xpahos ★★★★★ ()

Покажи конфиг sftp.

dada ★★★★★ ()

connection refused означает что порт никто не слушает или он закрыт файрволом.

Значит, с настройками

Subsystem sftp internal-sftp
Match user remote
    ChrootDirectory %h
    ForceCommand internal-sftp
    AllowTcpForwarding no

ssh не взлетает. Смотри логи на предмет ошибок. Хорошо бы включить

LogLevel DEBUG

router ★★★★★ ()
Ответ на: комментарий от xpahos
# ssh -vvv -p 2132 remote@192.168.1.107
OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.168.1.107 [192.168.1.107] port 2132.
debug1: connect to address 192.168.1.107 port 2132: Connection refused
ssh: connect to host 192.168.1.107 port 2132: Connection refused

а это в логе auth.log (сначала неудачная попытка, потом удачная)

Jun 21 10:01:56 localhost sshd[2130]: Server listening on 0.0.0.0 port 2132.
Jun 21 10:01:56 localhost sshd[2130]: Server listening on :: port 2132.
Jun 21 10:03:06 localhost sshd[2130]: Received signal 15; terminating.
Jun 21 10:03:06 localhost sshd[2137]: Server listening on 0.0.0.0 port 2132.
Jun 21 10:03:06 localhost sshd[2137]: Server listening on :: port 2132.
Jun 21 10:03:22 localhost sshd[2138]: Accepted publickey for remote from 192.168.1.1 port 62343 ssh2
Jun 21 10:03:22 localhost sshd[2138]: pam_unix(sshd:session): session opened for user remote by (uid=0)
Jun 21 10:03:36 localhost sudo:   remote : TTY=pts/3 ; PWD=/home/remote ; USER=root ; COMMAND=/bin/su
Jun 21 10:03:36 localhost sudo: pam_unix(sudo:session): session opened for user root by remote(uid=1000)
Jun 21 10:03:36 localhost su[2337]: Successful su for root by root
Jun 21 10:03:36 localhost su[2337]: + /dev/pts/3 root:root
Jun 21 10:03:36 localhost su[2337]: pam_unix(su:session): session opened for user root by remote(uid=0)

sable ()
Ответ на: комментарий от dada

а где этот конфиг лежит? разве не через /etc/ssh/sshd_config в настраивается?

sable ()
Ответ на: комментарий от sable

а обычным телнетом можно законектится на порт?

xpahos ★★★★★ ()
Ответ на: комментарий от router

поставил LogLevel DEBUG и стал смотреть, действительно при

Subsystem sftp internal-sftp
Match user remote
    ChrootDirectory %h
    ForceCommand internal-sftp
    AllowTcpForwarding no
сервис ssh не работает, причем запускаться не хочет:
# service ssh restart
stop: Unknown instance: 
ssh start/pre-start, process 5224
status ssh
ssh stop/waiting
с настройками
Subsystem sftp /usr/lib/openssh/sftp-server
все поднимается и работает, куда копать дальше, вроде никакого криминала не делал

sable ()
Ответ на: комментарий от xpahos

да, коннект есть, порт открыт, проблема в том, что ssh после изменения sshd_config не поднимается, но почему - не понятно

sable ()
Ответ на: комментарий от sable

проблема в том, что ssh после изменения sshd_config не поднимается, но почему - не понятно

Логи смотри

router ★★★★★ ()
Ответ на: комментарий от sable

да, коннект есть, порт открыт, проблема в том, что ssh после изменения sshd_config не поднимается, но почему - не понятно

версия openssh на сервере такая же, как на том хосте, с которого ты показывал вывод?

xpahos ★★★★★ ()
Ответ на: комментарий от xpahos

Проблема оказалась в том, что параметр UsePAM попадал в блок Match User, из-за этого ssh и не поднимался, убрал вообще UsePAM, все поднялось, коннект пошел) Всем спасибо!

sable ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.