LINUX.ORG.RU
ФорумAdmin

Доступ по SSH ключу без пароля

 


0

1

Подскажите, пожалуйста. Есть ноутбук с ubuntu и однаплатник с fedora. Нужно зайти на однаплатник(192,168,1,25) по ssh ключу без пароля. Перечитал статьи из гугла, перепробовал все методы от туда, всегда просит пароль! Если жать ввод то в конце пишит типа нет доступа ни по ключу ни по паролю. Делаю так:

На убунту:

ssh-keygen - кодовые слова не ввожу, просто везде жму ввод, в папке получаю два ключа всё ок

ssh-copy-id root@192.168.1.25 - сначала отвечаю да, потом ввожу пароль от однаплатника, пишет типа всё ок попробуйте зайти по команде ssh root@192.168.1.25

Далее ssh-add, пишет что всё добавлено. Перезагружаю однаплатник, далее действия на нем:

проверяю файл authorized_keys, всё ок, ключ в нем есть, права дал 777 на всякий.

Проверяю файл sshd_config, в нем вроде со всех статей все сходится, на всякий случай скину его.

Вроде всё отлично, но по команде ssh root@192.168.1.25 или ssh -i ~/.ssh/id_rsa root@192.168.1.25 просит пароль! Помогите исправить

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 1024

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

UseDNS no

RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile	%h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

права дал 777 на всякий

Вот «всякого» не надо.

anc ★★★★★ ()

777

нда, такое себе

anonymous ()
Ответ на: комментарий от sheider

и на будущее: при написании постов используй разметку LORCODE или Markdown.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.