LINUX.ORG.RU
ФорумAdmin

обновление gentoo


0

0

день добрый Всем.

Не хочет обновляться gentoo, вот что пишет:

# emerge -pvuD world
..............
[ebuild U ] x11-libs/qt-4.4.2 [4.3.3] USE="dbus opengl -qt3support* (-accessibility%*) (-cups%*) (-debug%) (-doc%) (-examples%) (-firebird%) (-gif%*) (-glib%) (-jpeg%*) (-mng%) (-mysql%) (-nas%) (-nis%) (-odbc%) (-pch%) (-png%*) (-postgres%) (-sqlite%) (-sqlite3%) (-ssl%*) (-tiff%) (-xinerama%) (-zlib%*)" INPUT_DEVICES="(-wacom%)" 0 kB [0]
[ebuild N ] app-crypt/qca-2.0.0-r2 USE="-debug -doc -examples" 4,987 kB [0]
[blocks B ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-sql-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)

Total: 157 packages (121 upgrades, 2 downgrades, 33 new, 1 in new slot), Size of downloads: 852,855 kB
Fetch Restriction: 1 package (1 unsatisfied)
Conflict: 1 block (1 unsatisfied)
Portage tree and overlays:
[0] /usr/portage
[?] indicates that the source repository could not be determined

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt:4

('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge') pulled in by
>=x11-libs/qt-4.2.0:4 required by ('ebuild', '/', 'app-crypt/qca-2.0.0-r2', 'merge')
x11-libs/qt required by world
x11-libs/qt:4 required by world

('installed', '/', 'x11-libs/qt-4.3.3', 'nomerge') pulled in by
=x11-libs/qt-4.3*:4 required by ('installed', '/', 'net-im/skype-2.0.0.63', 'nomerge')
=x11-libs/qt-4.3*:4 required by ('ebuild', '/', 'x11-libs/qscintilla-2.3.2', 'merge')
(and 3 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

Это уже после того, как сделал unmerge app-crypt/qca, результат не изменился.

Что-то сразу не пойму, кого удалить надо, кого замаскировать/размаскировать?

ps: возможно, запостил толком не разобравшись в проблеме, если так, то заранее извиняюсь. С Gentoo работаю не особо долго, опыта большого нет. Portage и ebuild знаю не особо глубоко, сейчас читаю, разбираюсь...

pps: чета не могу найти режим "preformatted text".

★★

Re: обновление gentoo

qt разных версий установлен? удали 4.3.*, а потом просто обнови world. Я вчера так разрулил.

Incred ()
Ответ на: Re: обновление gentoo от Incred

Re: обновление gentoo

удалил qt-4.3*, без результата:

# equery l qt
/usr/lib/portage/pym/portage_util.py:39: DeprecationWarning: DEPRECATION NOTICE: The portage_util module was replaced by portage.util
/usr/lib/portage/pym/portage_checksum.py:39: DeprecationWarning: DEPRECATION NOTICE: The portage_checksum module was replaced by portage.checksum
/usr/lib/portage/pym/output.py:39: DeprecationWarning: DEPRECATION NOTICE: The output module was replaced by portage.output
[ Searching for package 'qt' in all categories among: ]
 * installed packages
[I--] [  ] x11-libs/qt-3.3.8-r4 (3)


# emerge -pv -uD world
............
Fetch Restriction: 1 package (1 unsatisfied)
Portage tree and overlays:
 [0] /usr/portage
 [?] indicates that the source repository could not be determined

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt:4

  ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge') pulled in by
    >=x11-libs/qt-4.2.0:4 required by ('ebuild', '/', 'app-crypt/qca-2.0.0-r2', 'merge')
    x11-libs/qt required by world

  ('ebuild', '/', 'x11-libs/qt-4.3.5', 'merge') pulled in by
    =x11-libs/qt-4.3*:4 required by ('ebuild', '/', 'x11-libs/qscintilla-2.3.2', 'merge')
    (and 2 more)
..............

qscintilla и qca тоже удалил, но все равно пытается их поставить.
Так понимаю, что хочет поставить x11-libs/qt-4.4.2,
а для qscintilla надо =x11-libs/qt-4.3*:4.

samson ★★ ()
Ответ на: Re: обновление gentoo от samson

Re: обновление gentoo

Он говорит, что app-crypt/qca слинкован с qt-4.4.2, а x11-libs/qscintilla с qt-4.3.5 и не знает, что с этим делать.

1. qt-4.4.2 у тебя уже стоит, как я понимаю (иначе бы писал nomerge). Если б не стоял - сперва надо было б его обновить.

2. Пересобери x11-libs/qscintilla (emerge -auv1 x11-libs/qscintilla)

KRoN73 ★★★★★ ()
Ответ на: Re: обновление gentoo от KRoN73

Re: обновление gentoo

Да я так и понял, только что делать с этим не знаю.

> qt-4.4.2 у тебя уже стоит, как я понимаю


Qt стоял 4.3*, я его удалил, так же удалил qca и qscintilla. Сейчас стоит только qt-3.3*:

# equery l qt
.......ругань всякая............
[ Searching for package 'qt' in all categories among: ]
* installed packages
[I--] [ ] x11-libs/qt-3.3.8-r4 (3)

Пробую поставить qt-4.4.2 и поставить/пересобрать qscintilla.

samson ★★ ()
Ответ на: Re: обновление gentoo от KRoN73

Re: обновление gentoo

Сделал emerge qt, собрался qt-4.4.2, больше не ругается. Качаю пакеты для обновления...

Всем спасибо.

samson ★★ ()
Ответ на: Re: обновление gentoo от samson

Re: обновление gentoo

Собственно, да. Это я и хотел сказать. Ведь надо, чтоб в системе qt остался. Просто у меня само разрулилось by emerge world -uDN

Incred ()
Ответ на: Re: обновление gentoo от Incred

Re: обновление gentoo

это тоже ясно. только вот пока я ему не сделал emerge qt после его удаления , он что то не хотел апдейтиться, хотя qt-4.4.2 выводил в списке пакетов для установки.

samson ★★ ()
Ответ на: Re: обновление gentoo от samson

Re: обновление gentoo

>только вот пока я ему не сделал emerge qt после его удаления , он что то не хотел апдейтиться

По идее подобные конфликты разруливаются целевым обновлением пакета (тот же qt) без его удаления и потом пересборкой того, кто от него зависит (portage 2.2 такое уже сам делает, он в конце предлагает выполнить emerge @preserved-rebuild).

Если же что-то совсем запуталось - проще всего замаскировать более старую версию (echo '<x11-libs/qt-4.4.2' >> /etc/portage/package.mask) и посмотреть, кто потом на это будет ругаться :)

KRoN73 ★★★★★ ()
Ответ на: Re: обновление gentoo от KRoN73

Re: обновление gentoo

может и достаточно было бы сделать просто emerge qt, без удаления...

еще раз всем Спасибо.

samson ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.