LINUX.ORG.RU
ФорумAdmin

OpenWRT две сети через один нетегированный порт

 


0

1

TpLink с прошивкой OpenWRT, Настроена localNet1(с WiFi1)-> WAN. Встроенные порты свитча работают в LocalNet1. Поднята вторая сеть LocalNet2(WiFi2) без WAN. К одному из портов подключены два ПК (через другой свитч, простой ethernet switch), которые в разных сетях (LocalNet1 и LocalNet2). Внешний ПК с LocalNet1 свою сеть видит. Второй ПК с LocalNet2 сети не видит, OpenWRT не пускает вторую сеть через один порт с LocalNet1. OpenWRT не может две не тегированные сети через один порт выпустить?



Последнее исправление: Tester500 (всего исправлений: 1)

Ответ на: комментарий от AVL2

В таких роутерах ETH1 вход в свитч, у которого четыре порта. Порты можно отдельно в VLAN пихать (с тегом или без). На ETH1 можно прорисать алиас руками, но толку ноль.

br-Lan2 -> ../../devices/virtual/net/br-Lan2

br-lan -> ../../devices/virtual/net/br-lan

eth0 -> ../../devices/platform/ag71xx.0/net/eth0

eth1 -> ../../devices/platform/ag71xx.1/net/eth1

ifb0 -> ../../devices/virtual/net/ifb0

lo -> ../../devices/virtual/net/lo

pppoe-wan -> ../../devices/virtual/net/pppoe-wan

teql0 -> ../../devices/virtual/net/teql0

wlan0 -> ../../devices/platform/ar934x_wmac/net/wlan0

wlan0-1 -> ../../devices/platform/ar934x_wmac/net/wlan0-1

Tester500
() автор топика
Ответ на: комментарий от AVL2

На их сайте и так можно:
config interface ‘lan’
option device ‘eth0’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’

config interface ‘lan1’
option device ‘@lan’
option proto ‘dhcp’

config interface ‘lan2’
option device ‘@lan’
option proto ‘static’
option ipaddr ‘10.0.0.1’
option netmask ‘255.255.255.0’

Тока не шиша не работает. В поисках на одном буржуйском форуме мелькнуло - не могет OpenWRT два ип на одном интерфейсе. Чета искать причину нет пока времени, найду обходняк, хотя чуйка говорит - проблема на поверхности.

Tester500
() автор топика
Ответ на: комментарий от Tester500

Во всем этом нет никакой специфика опенврт.

Только так и можно, если создан бридж. В линуксовом бридже (не vwitch, а стандартный) нельзя задать адрес интерфейсу, входящему в бридж. вместо этого адрес присваивается самому бриджу.

Зайди по ssh и сделай

ip addr

ip addr
...
5: adm@enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 84:47:09:0b:22:eb brd ff:ff:ff:ff:ff:ff
    inet 172.64.16.27/24 brd 172.64.16.1 scope global dynamic noprefixroute adm

затем, на том интерфейсе, который с первым адрес, добавь второй

ip addr add 192.168.0.1/24 dev adm

ip addr add 192.168.0.1/24 dev adm

ip addr 
...
5: adm@enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 84:47:09:0b:22:eb brd ff:ff:ff:ff:ff:ff
    inet 172.17.24.93/24 brd 172.64.17.1 scope global dynamic noprefixroute adm
    inet 192.168.0.1/24 scope global adm
....

и все.

AVL2 ★★★★★
()
Ответ на: комментарий от Tester500

Ну значит чего-то не договариваешь.

Добавлять адрес нужно тому же интерфейсу, на котором уже стоит и первый адрес. Если это бридж лан с вайфаем, то к нему и добавлять. Контролировать через ifconfig/ip.

Адрес добавлять с правильной подсетью. И должно работать. Там нечему не работать.

Попробуй для проверки поменять первый адрес штатными средствами на второй. Первая сеть отвалится, но вторая должна заработать. Если заработала, тогда добавь еще и первый адрес.

AVL2 ★★★★★
()
Последнее исправление: AVL2 (всего исправлений: 1)