LINUX.ORG.RU
решено ФорумAdmin

PPTP говорит досвидания

 , ,


2

2

По форуму и гуглу уже пошарил, была такая проблема, но решения я так и не нашел.
Предыстория: поставил я себе как-то полгода назад pptp на один свой компик, пользовался впнкой, да стала никчему и выключил. И вот в прекрасный осенний день меня осенило и захотел я поставить на другой компик впнку.Вроде ставлю как и раньше, да вот появляются траблы. Собственно, выдает следующее:

/usr/sbin/pppd: The remote system (PPTP) is required to authenticate itself
/usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.
Ну, естественно залез смореть, где накосячил с паролем, да ничего сверхъестественного не увидал, вот что chap-secrets
# client	server	secret			IP addresses
user pptpd 55555300 *
Ну, пошел я сравнивать что стоит на первом компе, сравнил все настройки - никаких изменений. Думаю, ладно, запущу на нем впнку. И ни с того ни с сего тоже не запускается. Ничего не менял, лишь disabнул его и забыл.

Собсвенно конфиги:
pptpd-options
/etc/ppp/pptpd-options | grep -v "^$"
name pptpd
refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
require-mppe-128
proxyarp
nodefaultroute
lock
nobsdcomp
novj
novjccomp
nologfd
ms-dns 8.8.8.8
ms-dns 8.8.4.4
options.pptp
grep -v "#" /etc/ppp/options.pptp | grep -v "^$"
lock
noauth
refuse-pap
refuse-eap
refuse-chap
refuse-mschap
nobsdcomp
nodeflate
/etc/ppp/peers/pptpserver
cat /etc/ppp/peers/pptpserver 
pty "pptp май_айпушник_ни_скажу --nolaunchpppd"
name user
password 55555300
remotename PPTP
require-mppe-128
tail -f /var/log/messages
Oct 27 14:05:19 lenovo pppd[2399]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.
Oct 27 14:05:19 lenovo pppd[2399]: pptpd-logwtmp: $Version$
Oct 27 14:05:19 lenovo pppd[2399]: pppd 2.4.7 started by root, uid 0
Oct 27 14:05:19 lenovo NetworkManager[358]: <info>  [1572177919.5660] manager: (ppp0): new Ppp device (/org/freedesktop/NetworkManager/Devices/16)
Oct 27 14:05:19 lenovo pppd[2399]: Using interface ppp0
Oct 27 14:05:19 lenovo pppd[2399]: Connect: ppp0 <--> /dev/pts/3
Oct 27 14:05:49 lenovo pppd[2399]: LCP: timeout sending Config-Requests
Oct 27 14:05:49 lenovo pppd[2399]: Connection terminated.
Oct 27 14:05:49 lenovo pppd[2399]: Modem hangup
Oct 27 14:05:49 lenovo pppd[2399]: Exit.
P.s.с noauth пробовал ниже в конфиге дописать, да, он убирает те две строки
...couldn't find any suitable secret...
но толку нет

Deleted

Ответ на: комментарий от Infra_HDC

У дебиана с PPTP все стало плохо с поздними обновлениями ядер под седьмой версией (Wheezy)

На 8 и 9 Debian pptp работает. Не думаю, что проблема в дистрибутиве.

Serge10 ★★★★★ ()
Ответ на: комментарий от Serge10

На 8 и 9 Debian pptp работает. Не думаю, что проблема в дистрибутиве.

Последний раз, если память не изменяет, то подымал на testing buster,все нормально работало, потом уже до stable обновился.
Ну,так-то да,навряд ли тут дистрибутив замешан, попробую конечно на виртуалочке поднять, но скорее в конфигах где-то засада осталась.

Deleted ()

Может тут скрытое послание?

├─7137 /usr/sbin/pptpd --fg
           ├─7138 pptpd [1.1.1.1:702C - 0000]
           └─7139 /usr/sbin/pppd local file /etc/ppp/pptpd-options 115200 192.168.2.103:192.168.2.115 ipparam 1.1.1.1

Oct 27 13:53:19 ubuntu systemd[1]: Started PoPToP Point to Point Tunneling Server.
Oct 27 13:53:19 ubuntu pptpd[7137]: MGR: Maximum of 100 connections reduced to 16, not enough IP addresses given
Oct 27 13:53:19 ubuntu pptpd[7137]: MGR: Manager process started
Oct 27 13:53:19 ubuntu pptpd[7137]: MGR: Maximum of 16 connections available
Oct 27 13:53:27 ubuntu pptpd[7138]: CTRL: Client 1.1.1.1 control connection started
Oct 27 13:53:27 ubuntu pptpd[7138]: CTRL: Starting call (launching pppd, opening GRE)
Oct 27 13:53:27 ubuntu pppd[7139]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.
Oct 27 13:53:27 ubuntu pppd[7139]: pppd 2.4.7 started by root, uid 0
Oct 27 13:53:27 ubuntu pppd[7139]: Using interface ppp0
Oct 27 13:53:27 ubuntu pppd[7139]: Connect: ppp0 <--> /dev/pts/1
lines 1-23/23 (END)

Deleted ()
Ответ на: комментарий от anc

/var/log/debug

Oct 28 02:25:37 lenovo pppd[5812]: using channel 18
Oct 28 02:25:37 lenovo pppd[5812]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x492f7df3> <pcomp> <accomp>]
Oct 28 02:25:40 lenovo pppd[5812]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x492f7df3> <pcomp> <accomp>]
Oct 28 02:26:04 lenovo pppd[5812]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0x492f7df3> <pcomp> <accomp>]
Oct 28 02:26:07 lenovo pptpd[5811]: CTRL: Reaping child PPP[5812]

Deleted ()

Update: не знаю почему сразу этого не сделал, но локально все работает. Порты естественно проброшены, но что-то препятствует соединению по неизвестным мне причинам.

Deleted ()
Ответ на: комментарий от Deleted

Не моё дело, но зачем там много конфигов когда можно всё уложить в один? Ладно, раз раньше работало то ничего страшного. Предполагаю что где-то посередине проблема.

anc ★★★★★ ()
Ответ на: комментарий от anc

А прикол то в том, что айпишник лишь менять приходится, с одного на другой если перекидываешь, а выбранная секция по дефолту стоит "--Select-One--", если ее сменишь на выбранную PPTP, то при перезаходе все равно дефолтная "--Select-One--" будет

Deleted ()
Ответ на: комментарий от anc

Согласен. Помню D-link был, так там даже назад не вернутся, чтобы какие конфиги доделать, приходилось даже перезаходить иногда в веб интерфейс.
Спасибо за помощь!

Deleted ()