LINUX.ORG.RU
ФорумAdmin

установка принтера HP LaserJet M1005 через CUPS

 , , ,


0

1

Добрый день! Возник вопрос. Установил на серверную машину Ubuntu Linux 14.04.5 и соответственно из под неё поднять возможность печатать (основная машина на вин 10). Установил панель webmin, отдельно установил cups (через неё установил драйвер на данный принтер из списка доступных HP LaserJet m1005 hpijs, 3.14.3, requires proprietary plugin), но статус его в панели написано: Idle - «Filter failed». Также есть такие строки Неизвестное Приостановлено пользователем 7k Неизвестно Остановлено «Filter failed»

Подскажите пожалуйста, в какую сторону мне плясать. Пробую напечатать пробную страницу, но ничего не происходит( такое чувство, что не подходит драйвер. Может быть задача и легко решаема, но в экосистеме linux я новичок, поэтому сильно не пинайте, много ещё не знаю. Читал про hplip, но вроде как в cups всё есть.

Надеюсь на Вашу помощь и Ваши подсказки.

тут все прекрасно

ubuntu 14.04.5 вышла в 2014 году и больше не поддерживается.

по поводу всего остального. вы криво поствили дрова и вам надо смотреть логи cup /var/log/cups.log он там напишет, что не может найти фильтр, который представляет из себя файл, которого нет, потому что вы криво установили дрова.

но для начала снесите все и поставьте либо ubuntu 16.04 либо ubuntu 18.04

а еще webmin вам не нужен, у cups есть веб интерфейс, если консоль пугает.

чувствую, вас ждет увлекательное путешествие.

constin ★★★★ ()
Последнее исправление: constin (всего исправлений: 1)

вообще я тут погуглил, и с ним как-то весело. ккча каких-то проблем 5 летней давности. очень может быть, что свежий cups его и так подхватит. да и hplips( я даже не знал, что это такое 5 минут назад) тоже может можно поставить, оно не не вместо cups, а вместе.

нл все же план такой. сносим старую убунту. ставим что-то новое. ищем ppd файл для принтера, ну или драйвер.

constin ★★★★ ()
Ответ на: комментарий от constin

Согласен с товарищем. Поставят, понимаешь, какое-то протухшее говно, а топом срут на форумах, что у них что-то не работает.

anonymous ()
Ответ на: комментарий от constin

Вообще-то до 17 апреля 2019 ещё есть поддержка. Да, и версия 14.04.5 вышла в 2016.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от constin

прежде чем начать работа с ubuntu я зашёл на офф сайт и скачал самую свежую 18 версию. После пары дней мучений (из-за нехватки знаний), я принял решение поставить более раннюю версию и установил 14 версию. На ней всё вроде как завелось сразу и даже список драйверов в CUPS (через веб интерфейс, да у меня отдельно ещё стоит такой web-интерфейс) значительно больше оказался в версии 14, нежели в 18 версии, хотя рискну предположить что нужно было просто где-то и что-то обновить, а webmin вообще не хотел устанавливаться, всегда ругался на какие-то пакеты python, то бишь недостаёт каких-то. Сейчас попробовал обновиться до 16.04, но и здесь потерпел фиаско, думаю буду обновлять через флешку, либо сносить с нуля

ridvik ()
Ответ на: комментарий от constin

Есть вопрос. В общем всё настроил, теперь всё по кайфу, с основного компьютера всё печатает без проблем. Теперь столкнулся с такой задачей, данный принтер считается МФУ(но зараза подключается по юсб) и периодически необходимо отсканировать некоторые документы в электронный вид. Вопрос: можно ли что-то сделать (придумать), чтобы он также был подключен к машине с сервером, а сканировать можно было на основном компьютере?

ridvik ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.