LINUX.ORG.RU
ФорумAdmin

Centos6 и Letsencrypt и Python 2.7

 , ,


0

1

Здравствуйте! Прошу помощи в следующем вопросе: Имеется: centos-release-6-8.el6.centos.12.3.x86_64

Установил Letsencrypt, получил сертификат для домена, все завелось. Затем подошло время обновления сертификата, команда «letsencrypt-auto renew». При выполнении обновления сертификата происходит ошибка:

letsencrypt/letsencrypt-auto: line 143: [: error: integer expression expected python2.7: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory WARNING: unable to check for updates. /root/.local/share/letsencrypt/lib/python2.6/site-packages/cryptography/__init__.py:26: DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of cryptography will drop support for Python 2.6 DeprecationWarning

Как я понял, для выполнения этого действия необходимо установить Python 2.7. Установил, но Letsencrypt его не видит, и все так-же ругается на его отсутствие.

Что пробовал: Добавлял bin нового питона в переменные окружения, установил свежий Letsencrypt, удалял папку «/root/.local/share/letsencrypt/» и:

https://firstvds.ru/blog/ustanovka_python_2_73_3_v_centos_6_x https://community.letsencrypt.org/t/redhat-centos-6-x-users-need-python-2-7/2190 http://stackoverflow.com/questions/20842732/libpython2-7-so-1-0-cannot-open-shared-object-file-no-such-file-or-directory

Ты как питон ставил? У меня есть подозрения что он не из дистрибутива. Если да то это была фатальная ошибка.

true_admin ★★★★★ ()

Сделай чтобы у тебя Python 2.7 был в системе по умолчанию, или юзай venv с питоном 2.7 при запуске энкрипта, или поставь центос 7

Siado ★★★★★ ()

Передавай адрес скрипта как аргумент к бинарю python2.7.

falafel ()
Ответ на: комментарий от Siado

По поводу сделать по умолчанию вродь читал что в центе что-то перестанет работать, т.к. все заточено под 2.6. Попробуем. Не хотелось бы переустанавливать, это будет крайний вариант.

iskanderix ()
Ответ на: комментарий от Siado

Установил по новой питон 2.7, перестал работать yum. Затем, все вроде стало как надо, yum заработал, энкрипт видит питон 2.7, но все равно не взлетает.

Лог:

./letsencrypt/letsencrypt-auto --version
Bootstrapping dependencies for RedHat-based OSes...
yum is /usr/bin/yum
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.corbina.net
 * epel: fedora-mirror01.rbc.ru
 * extras: centos-mirror.rbc.ru
 * updates: mirror.corbina.net
Package gcc-4.4.7-17.el6.x86_64 already installed and latest version
Package dialog-1.1-9.20080819.1.el6.x86_64 already installed and latest version
Package augeas-libs-1.0.0-10.el6.x86_64 already installed and latest version
Package openssl-1.0.1e-48.el6_8.1.x86_64 already installed and latest version
Package openssl-devel-1.0.1e-48.el6_8.1.x86_64 already installed and latest version
Package libffi-devel-3.0.5-3.2.el6.x86_64 already installed and latest version
Package redhat-rpm-config-9.0.3-51.el6.centos.noarch already installed and latest version
Package ca-certificates-2015.2.6-65.0.1.el6_7.noarch already installed and latest version
Package python-2.6.6-64.el6.x86_64 already installed and latest version
Package python-devel-2.6.6-64.el6.x86_64 already installed and latest version
Package python-virtualenv-1.10.1-1.el6.noarch already installed and latest version
Package python-tools-2.6.6-64.el6.x86_64 already installed and latest version
Package python-pip-7.1.0-1.el6.noarch already installed and latest version
Package 1:mod_ssl-2.2.15-53.el6.centos.x86_64 already installed and latest version
Nothing to do
Creating virtual environment...
Installing Python packages...
Had a problem while installing Python packages:
Collecting argparse==1.4.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 5))
  Downloading argparse-1.4.0-py2.py3-none-any.whl
Collecting pycparser==2.14 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 11))
  Downloading pycparser-2.14.tar.gz (223kB)
Collecting cffi==1.4.2 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 14))
  Downloading cffi-1.4.2.tar.gz (365kB)
Collecting ConfigArgParse==0.10.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 31))
  Downloading ConfigArgParse-0.10.0.tar.gz
Collecting configobj==5.0.6 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 33))
  Downloading configobj-5.0.6.tar.gz
Collecting cryptography==1.2.3 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 35))
  Downloading cryptography-1.2.3.tar.gz (373kB)
Collecting enum34==1.1.2 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 57))
  Downloading enum34-1.1.2.tar.gz (46kB)
Collecting funcsigs==0.4 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 60))
  Downloading funcsigs-0.4-py2.py3-none-any.whl
Collecting idna==2.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 63))
  Downloading idna-2.0-py2.py3-none-any.whl (61kB)
Collecting ipaddress==1.0.16 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 66))
  Downloading ipaddress-1.0.16-py27-none-any.whl
Collecting linecache2==1.0.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 69))
  Downloading linecache2-1.0.0-py2.py3-none-any.whl
Collecting ndg-httpsclient==0.4.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 72))
  Downloading ndg_httpsclient-0.4.0.tar.gz
Collecting ordereddict==1.1 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 74))
  Downloading ordereddict-1.1.tar.gz
Collecting parsedatetime==2.1 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 76))
  Downloading parsedatetime-2.1-py2-none-any.whl
Collecting pbr==1.8.1 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 79))
  Downloading pbr-1.8.1-py2.py3-none-any.whl (89kB)
Collecting psutil==3.3.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 82))
  Downloading psutil-3.3.0.tar.gz (261kB)
Collecting pyasn1==0.1.9 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 104))
  Downloading pyasn1-0.1.9-py2.py3-none-any.whl
Collecting pyOpenSSL==0.15.1 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 116))
  Downloading pyOpenSSL-0.15.1-py2.py3-none-any.whl (102kB)
Collecting pyRFC3339==1.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 119))
  Downloading pyRFC3339-1.0-py2.py3-none-any.whl
Collecting python-augeas==0.5.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 122))
  Downloading python-augeas-0.5.0.tar.gz (90kB)
Collecting python2.7-pythondialog==3.3.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 124))
  Could not find a version that satisfies the requirement python2.7-pythondialog==3.3.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 124)) (from versions: )
No matching distribution found for python2.7-pythondialog==3.3.0 (from -r /tmp/tmp.jg1BPHh5U9/letsencrypt-auto-requirements.txt (line 124))
You are using pip version 8.0.3, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

Версия pip - 8.1.2

# pip -V
pip 8.1.2 from /usr/local/lib/python2.7/site-packages (python 2.7)
iskanderix ()
Ответ на: комментарий от Deleted

Все получилось! Видимо подсознательно не хотелось заморачиваться со сторонними клиентами когда оригинальный уже был настроен и раньше работал. Этот клиент проще и понятнее оригинального. Спасибо!

iskanderix ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.