LINUX.ORG.RU
ФорумAdmin

qemu-kvm нереалистично работает ne2k под windows xp

 , , ,


1

1

Короче, я сегодня обраружил, что ne2k под windows xp на kvm работает как то странно. В свойствах подключение показывает 10Мбит/c, а iperf3 показывает аш 30Мбит/c. Кстати, 30mbps у меня потому, что на сигмент я поставил шейпер и скорость в 30mbps. Я так понимаю, скорость должна быть порядка 10mbps, так как это показывает в свойствах подключения.

★★★★★

Запусти в соседней виртуалке с аналогичным параметрами любой линуксовый livecd и протести скорость в нём. Если картина повторится, надо смотреть на хост и kvm. Если нет, все вопросы к гостевому оффтопику.

shell-script ★★★★★ ()
Последнее исправление: shell-script (всего исправлений: 1)

Ну вы еще вспомните 115200 на диалап модеме (в винде отображалась скорость залочки ком порта а не соединения), мало ли что там винда пишет.

anc ★★★★★ ()
Ответ на: комментарий от ne-vlezay

Я такого бага не видел пока ни на одной из используемых версий. Локализуй проблему сперва.

shell-script ★★★★★ ()

А кто тебе сказал, что оно должно работать со скоростью 10мбит ? Там и 100мбитные карты чисто условные.

Сколько может процессор, столько и будет выдавать.

У тебя есть шейпер. Нужно ограничить - ограничь сам.

vel ★★★★★ ()

tun/tap драйвер под винду такую же отсебятину пишет

daemonpnz ★★★★★ ()

1. e1000 не стоит использовать, это эмуляция а virtio_net - паравирт

2. скорость которую показывает драйвер вбита железно, и не отражает реальной linespeed

dyasny ★★★★★ ()

Я так понимаю, скорость должна быть порядка 10mbps, так как это показывает в свойствах подключения.

да это просто значение в регистрах, как модель напишешь, такую скорость и получишь(ну ещё конечно драйвер должен успевать).

хинт: попробуй на пакетах 64 байта и udp. посмотри загрузку проца хоста, где qemu крутится

dimon555 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.