LINUX.ORG.RU
ФорумAdmin

3G-модем: меняется номер устройства в /dev

 , ,


0

1

Всем привет! Такая проблемка: имеется 3G-модем Билайн, определяемый системой как /dev/ttyACM. Подключение происходит через wvdial. При подключении модема, в /dev появляются два устройства: ttyACM0 и ttyACM1. В конфиге wvdial прописан путь к /dev/ttyACM0, всё работает и подключается. Но если извлечь модем (он иногда глючит и его приходится перетыкать) и вставить обратно, то номера устройств будут уже ttyACM5 и ttyACM6, и соответственно, wvdial не работает пока не перезагрузишся, несколько раз перетыкаешь модем или не изменишь значение в конфиге wvdial. Подскажите пожалуйста, как закрепить за ttyACM постоянный номер (0 и 1), чтобы подобной проблемы больше не было? Пробовал чё-то делать через udev, но не сработало. Может кто сталкивался? ОС Debian 8.

Вывод udevadm

  looking at device '/devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2:1.0/tty/ttyACM0':
    KERNEL=="ttyACM0"
    SUBSYSTEM=="tty"
    DRIVER==""

  looking at parent device '/devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2:1.0':
    KERNELS=="2-2:1.0"
    SUBSYSTEMS=="usb"
    DRIVERS=="cdc_acm"
    ATTRS{bInterfaceClass}=="02"
    ATTRS{iad_bFunctionClass}=="02"
    ATTRS{bmCapabilities}=="7"
    ATTRS{iad_bFirstInterface}=="00"
    ATTRS{bInterfaceSubClass}=="02"
    ATTRS{bInterfaceProtocol}=="01"
    ATTRS{bNumEndpoints}=="01"
    ATTRS{iad_bFunctionSubClass}=="00"
    ATTRS{iad_bFunctionProtocol}=="00"
    ATTRS{supports_autosuspend}=="1"
    ATTRS{iad_bInterfaceCount}=="02"
    ATTRS{bAlternateSetting}==" 0"
    ATTRS{bInterfaceNumber}=="00"

  looking at parent device '/devices/pci0000:00/0000:00:14.0/usb2/2-2':
    KERNELS=="2-2"
    SUBSYSTEMS=="usb"
    DRIVERS=="usb"
    ATTRS{bDeviceSubClass}=="02"
    ATTRS{bDeviceProtocol}=="01"
    ATTRS{devpath}=="2"
    ATTRS{idVendor}=="19d2"
    ATTRS{speed}=="480"
    ATTRS{bNumInterfaces}==" 4"
    ATTRS{bConfigurationValue}=="1"
    ATTRS{bMaxPacketSize0}=="64"
    ATTRS{busnum}=="2"
    ATTRS{devnum}=="2"
    ATTRS{configuration}==""
    ATTRS{bMaxPower}=="500mA"
    ATTRS{authorized}=="1"
    ATTRS{bmAttributes}=="80"
    ATTRS{bNumConfigurations}=="1"
    ATTRS{maxchild}=="0"
    ATTRS{bcdDevice}=="0001"
    ATTRS{avoid_reset_quirk}=="0"
    ATTRS{quirks}=="0x0"
    ATTRS{serial}=="25545001D3C8C2640EEB42052EDDC15F30714613"
    ATTRS{version}==" 2.00"
    ATTRS{urbnum}=="6067"
    ATTRS{ltm_capable}=="no"
    ATTRS{manufacturer}=="ZTE"
    ATTRS{removable}=="unknown"
    ATTRS{idProduct}=="1515"
    ATTRS{bDeviceClass}=="ef"
    ATTRS{product}=="MF192"

  looking at parent device '/devices/pci0000:00/0000:00:14.0/usb2':
    KERNELS=="usb2"
    SUBSYSTEMS=="usb"
    DRIVERS=="usb"
    ATTRS{bDeviceSubClass}=="00"
    ATTRS{bDeviceProtocol}=="01"
    ATTRS{devpath}=="0"
    ATTRS{idVendor}=="1d6b"
    ATTRS{speed}=="480"
    ATTRS{bNumInterfaces}==" 1"
    ATTRS{bConfigurationValue}=="1"
    ATTRS{bMaxPacketSize0}=="64"
    ATTRS{authorized_default}=="1"
    ATTRS{busnum}=="2"
    ATTRS{devnum}=="1"
    ATTRS{configuration}==""
    ATTRS{bMaxPower}=="0mA"
    ATTRS{authorized}=="1"
    ATTRS{bmAttributes}=="e0"
    ATTRS{bNumConfigurations}=="1"
    ATTRS{maxchild}=="4"
    ATTRS{bcdDevice}=="0401"
    ATTRS{avoid_reset_quirk}=="0"
    ATTRS{quirks}=="0x0"
    ATTRS{serial}=="0000:00:14.0"
    ATTRS{version}==" 2.00"
    ATTRS{urbnum}=="2077"
    ATTRS{ltm_capable}=="no"
    ATTRS{manufacturer}=="Linux 4.1.0-0.bpo.2-rt-amd64 xhci-hcd"
    ATTRS{removable}=="unknown"
    ATTRS{idProduct}=="0002"
    ATTRS{bDeviceClass}=="09"
    ATTRS{product}=="xHCI Host Controller"

  looking at parent device '/devices/pci0000:00/0000:00:14.0':
    KERNELS=="0000:00:14.0"
    SUBSYSTEMS=="pci"
    DRIVERS=="xhci_hcd"
    ATTRS{irq}=="25"
    ATTRS{subsystem_vendor}=="0x1558"
    ATTRS{broken_parity_status}=="0"
    ATTRS{class}=="0x0c0330"
    ATTRS{driver_override}=="(null)"
    ATTRS{consistent_dma_mask_bits}=="64"
    ATTRS{dma_mask_bits}=="64"
    ATTRS{local_cpus}=="3"
    ATTRS{device}=="0x1e31"
    ATTRS{enable}=="1"
    ATTRS{msi_bus}=="1"
    ATTRS{local_cpulist}=="0-1"
    ATTRS{vendor}=="0x8086"
    ATTRS{subsystem_device}=="0x0240"
    ATTRS{numa_node}=="-1"
    ATTRS{d3cold_allowed}=="1"

  looking at parent device '/devices/pci0000:00':
    KERNELS=="pci0000:00"
    SUBSYSTEMS==""
    DRIVERS==""

Sunderland93 ★★★★★ ()

Попробуй в конфиге wvdial заменить /dev/ttyACM0 на /dev/serial/by-id/*ID модема*.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.