LINUX.ORG.RU

Сообщения tm4

 

Как настроить Intel GMA 3150 ?

Есть нетбук Lenovo s100c.

Внутри Intel GMA 3150.

В линуксе определяется так:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller (rev 02)

«Тормозит» страшно, но жить можно. В FF на youtube видео смотреть невозможно (ЦП на 100 почти грузит). В винде намного меньше «тормозит».

DE: Xfce 4.12. Эффекты отключены.

Стоит:

xserver-xorg-video-intel.
Оно работает. Но Debian говорит о данном драйвере следующее (пруф_1, пруф_2):
Не рекомендуется использование данного драйвера с видеокартами, 
выпущенными позднее 2007 года: вместо этого удалите его, 
и графический сервер будет использовать встроенный драйвер установки режимов.
Если удалить его — иксы не стартуют.

Насколько я понял нужно настроить KMS.

Как это сделать? Какой будет профит? Чем оно лучше того драйвера?

P.S.

Ставил Debian где-то в 2013 тогда еще 7-мой, работает с этим драйвером по сей день, только уже на Deb9.

P.P.S.

Судя по логам иксов:

intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
KMS работает и использует драйвер i915.

Правильно ли я понимаю, что если при удалении xserver-xorg-video-intel иксы не стартуют то KMS не может найти замену xserver-xorg-video-intel и без него моя видеокарта работать не будет? То есть в моем случае рекомендация удалить xserver-xorg-video-intel и использовать modesetting не работает ? Или нужно что-то настраивать в /etc/modprobe.d/ ?

Некоторые интересные на мой взгляд строки из /var/log/Xorg.0.log:
modesetting: Driver for Modesetting Kernel Drivers: kms
(II) FBDEV: driver for framebuffer: fbdev
(II) VESA: driver for VESA chipsets: vesa
(II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
(II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.917+git20161206-1
(II) intel(0): SNA compiled for use with valgrind
(WW) Falling back to old probe method for modesetting
(WW) Falling back to old probe method for fbdev
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib/xorg/modules/libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
compiled for 1.19.2, module version = 0.0.2
ABI class: X.Org Video Driver, version 23.0
(WW) Falling back to old probe method for vesa
(--) intel(0): Integrated Graphics Chipset: Intel(R) Pineview GM
RandR 1.2 enabled, ignore the following RandR disabled message.
(==) intel(0): DPMS enabled
(==) intel(0): Display hotplug detection enabled
(II) intel(0): [XvMC] i915_xvmc driver initialized.
(II) intel(0): [DRI2] Setup complete
(II) intel(0): [DRI2]   DRI driver: i915
(II) intel(0): [DRI2]   VDPAU driver: va_gl
(II) intel(0): direct rendering: DRI2 enabled
(II) intel(0): hardware support for Present enabled
glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Pineview M x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 13.0.6
OpenGL shading language version string: 1.20
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 13.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
OpenGL ES profile extensions:
glxinfo | grep direct
direct rendering: Yes

Xorg.0.log без xserver-xorg-video-intel

dmesg без xserver-xorg-video-intel

Xorg.0.log с xserver-xorg-video-intel

dmesg с xserver-xorg-video-intel

Перемещено beastie из general

 , , , ,

tm4 ()

Slim жив?

Начиная с Debian 7 и по сей день(deb 9) использую Slim. Он меня всем устраивает. Но вот читаю ArchWiki: проект SliM заброшен; SLIM не полностью совместим с systemd; рекомендуется использовать другой экранный менеджер.

Стоит ли переходить на LightDM?(или что там лучше для Xfce?) Если и дальше использовать Slim не грозит ли это подводными багами?

DE: Xfce.

 , , , ,

tm4 ()

Русские буквы в консоли(TTY) на Debian 9

Раньше все работало после установки пакета console-cyrillic. Так получилось, что с появлением systemd в дебиане я как-то не обращал на это внимание. Сейчас квадратики в TTY. Практически все перепробовал из нагугленного, помогает только setupcon. Совать в автозапуск его это костыль, хочется правильно. systemd-vconsole-setup насколько я понял в дебиане нет. В иксах все нормально с локалью. dpkg-reconfigure console-setup - настраивал.

Как правильно настроить русские буквы в TTY?

 , , , ,

tm4 ()

Что с packages.debian.org ?

При поиске показывает только sid. Вот например: https://packages.debian.org/search?keywords=xfce. Вчера все было норм.

 , , , ,

tm4 ()

Только у меня Jabber.ru не работает?

При конекте с пси+ пишет «сервер не поддерживает шифрование tls», с пиджина тоже не заходит(пишет: Вы запросили шифрование, но оно недоступно на сервере).

В чем может быть проблема? Перед этим долго подбирал пароль ибо забыл, потом сбросил - поставил новый.

 , , , ,

tm4 ()

Slaxlive

Кому не безразличен сей дистр - вот опрос от автора.

 , , , ,

tm4 ()

Opera всё?

 ,

tm4 ()

TuxGuitar 1.3 вышел

После более чем 6 лет ожидания. Наконец вышел . УРААА. Я уж был похоронил, на не православный Guitar Pro посматривал.

запилите новость кто-нибудь, тс неграмотен.

 

tm4 ()

Планшет_муки выбора

Доброго времени суток.

Выбираю планшет в основном для чтения тех. лит(pdf, djvu). Вроде уже и выбрал был... но тут епта начитался про эти PPI etc. Хотел брать 9.7-10.1 но там вроде как даже меньше PPI чем на 7-8. Бюджет не большой до 15т. Разрешение там не очень 1024x768-1280x800. Хотелось бы услышать отзывы тех кто уже читал на таких характеристиках. Как лучше 9.7-10.1 PPI 132-149 или 7-8 PPI 150-170 ?

 , , , ,

tm4 ()

hdparm автозапуск

Доброго времени суток. Подскажите, пожалуйста, как правильно добавить «hdparm -B 255 /dev/sda» в автозапуск при включении и выходе из ждущего режима.

в hdparm.conf дописал:

/dev/sda {
   apm = 255
   apm_battery = 255 
}

от батареи работает(только при включении), от сети - нет...

 , , ,

tm4 ()

RSS подписка на новые темы