LINUX.ORG.RU

Сообщения Spank

 

Большое количество GRE IPIP туннелей в линуксе и падение скорости в инет?

Форум — Admin

Здравствуйте!

Столкнулся тут с таким траблом. Есть centos7 там штук 50 ipip/gre туннелей и из за этого падает скорость во внешку. Отрубаю туннели, скорость отличная... Кто нибудь может помочь? Уже всю голову сломал. На самом деле такая же штука была и на джунипере. Скорость меряю между двумя линух машинами минуя туннель...

 , ,

Spank ()

iptables ipset или ...

Форум — Security

Добрый день!

Переношу тут конфиг и джунипера на линукс, вот и у меня там есть правило

source-address [ penza penza2 penza3 kuzneck ];
destination-address [ penza penza2 penza3 kuzneck ];

по сути эти названия, это подсети филиалов и мне надо что бы между ними работала связь. То есть по тупому сделать я могу, 2 правила в форвардинг на каждую пару филиалов. Чуть по умнее можно попробовать через ipset но там не ясно как для iptables правило указать, то бы и для src и dst было можно разные списки указать. В данном случае списки подсетей одинаковые в обоих концах, но есть где они и отличаются...

Подскажите как грамотно поступить в моем случае?

 ,

Spank ()

Zabbix 2.0.6 показать все графики

Форум — Admin

Доброе время суток. Хотелось бы как то в заббиксе реализовать вывод всех графиков определенного хоста. Есть хост, там куча интерфейсов, туннелей, которые динамически добавляются удаляются и с комплексным экраном не охота заморачиваться. Это постоянно его надо редактировать, что совсем не есть хорошо... Нашел патчи для более ранних версий, но вот по 2.0.6 тишина. Вроде нужная вещь, странно что она не реализована по умолчанию...

Spank ()

ubuntu 11.10 compiz

Форум — Desktop

Купил тут железку се получше, поставил новый дистр, решил понаслаждаться эффектами от компиза и на тебе, виснет ;-). Видяшка встроенная VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) . Компиз запускаю вроде как все работает, начинаю конфигурить, при включении или например отключении эфектов плавающих окон, да и многих других вырубается декоратор окон. После перестартую иксы и вроде гуд, с грехом пополам настроил я все это дело но на это все не закончилось. Компиз теперь иногда виснет когда работаешь например пол часика и нужно запустить какое то новое приложение, вот тоды все подвисает. Мыша ездит, остальное висит. Захожу в консольку, убиваю через -9 компиз, декорация окон слетает, запускаю этот же компиз через консоль, все красиво... Но вот от этих перезапусков очень хотелось бы избавиться и от компиза не хотца отказываться...

Spank ()

Asterisk fxo gxw4104

Форум — Admin

Настроил fxo шлюз, прикрутил к астериску, он по sip регистрируется. Если клиент звонит с городской линии он попадает на астериск и идет гудок далее до набор номера, а вот как бы так сделать, что бы он в голосовое меню попал(IVR)? Или этот гудок все же не от астериска, а от модема? Использую freepbx.

Spank ()

Nvidia wine cs 1.6

Форум — Linux-hardware

Не знаю в тот ли форум но по моему трабл какой то именно с железом...
Имею ноутбук lenovo y430, на нем GeForce 9300M GS (GPU 0) (данные из nvidia-settings, то есть вроде как дрова работают намано). Версия дров нвидиа 260.19.21 . uname -a
Linux zenwalk 2.6.33.4 #1 SMP PREEMPT Fri May 14 13:02:33 CEST 2010 i686 Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz GenuineIntel GNU/Linux
Дело все в том когда запуская cs 1.6 под вайном(1.3.8) да и предыдущий стоял, этот я уже сам скомпилил, то игра жутко тормозит, 1 кадр в секунду, то есть ну не поиграть. В настройках использовать opengl.
glxinfo показывает

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
.

Опять же раньше был трабл с композитом, который тормозил и грузил проц и от которого в последствии пришлось отказаться.

В конфиге иксов никаких параметров для карточки не указывал, единственный это драйвер nvidia и nologo :).
Что то мне кажется у меня либо ноут как не так под линухом пашет, ибо под виндой все гуд, либо еще. Но с теми же настройками на других системах с нвидиа все пашет отлично ....
Ах да еще раньше был глюк под линухом, зачастую грузишься и система стартует с экономией заряда батареи и все жутко тормозит и самое главное после того как загрузилось все скорость работы не увеличить. Приходилось бутаться. Сейчас уже давно такого не замечал, просто думаю может у мну функционал видяхи как то под урезан для экономии. Даж не знаю что и думать...

Spank ()

ipset

Форум — Admin

Чет я никак не пойму. Есть список ip и подсеток. Я его пытаюсь занести в ipset но дело в том, что для для них используются разные типы. Я так полагаю мне нужно парсить файл с подсетями, выявлять подсеть это или ip адрес, добавлять в нужный список, а потом эти списки объединять? По моему это изврат полный... Может есть что по умнее?

Spank ()

Asterisk и донабор номера

Форум — Admin

Есть астериск подключенный к офисной атске через длинковский шлюз. Есть номер для выхода sip клиентов на атс, при его наборе, далее можно набрать либо по цифрам 1..9 нужное меню, либо набрать внутренний номер и попасть на абонента. Так вот работает только первый тон, то есть, если быстро набираю номер 123, то попадаю в меню под цифрой 1. Если звонить с офисной атс через обычный телефон, сначала на асетриск, а потом выходить обратно в офис, то все работает. Трабл именно с сип софтварными звонилками. Кодек используем ulaw dtmfmode=auto. Куда копнут можно?

Spank ()

asterisk sip => h323

Форум — Admin

Подскажите плиз как лучше осуществить звонки sip клиентов на удаленный провайдер через h323. Скомпилял астериск с модулем chan_h323.so но при запуске перестает работать sip. Если в модулях делаю noload то все в порядке. asterisk-1.4.25_3 .

Spank ()

asterisk и несколько ип

Форум — Admin

Ситуация такая, есть астериск с внутренним IP адресом, куда уже завязано много клиентов из корп сети. Пытаюсь подключится к провайдеру сип, но там жалуются, что в информации о пакете приходит мой внутрений ипишник и соответственно ихняя программка отправляет на него и ничего не работает. Сейчас притянул на машинку с астериском внешку, но вот вопрос как ее указать для определенного провайдера, что бы астериск с нее слал?

Spank ()

isc-dhcp + radius

Форум — Admin

Есть ли возможность заставить dhcp брать данные о клиентах через радиус?
Знаю делают с помощью скрипта, считывают инфо о клиентах и записывают в конфигурацию dhpc, но тут нужно бутать сервис. Про релоад ничего не нашел.
Так же нашел патчик http://www.netpatch.ru/dhcp2radius.html .

Может есть еще какие варианты?

Spank ()

Lenovo Y430

Форум — Linux-hardware

OS SuSe 11.1
Проблеммы:
1. Если включить наушники, то звук продолжает звучать из динамиков и наушников. В винде все ок.

2. Не работает мутинг звука, хотя PCM и Front работают нармально.

3. Бывает при перезагрузке, система загружается так, как будто она слабее раз в 10. Помогает перезагрузка. Такое ощущение, что ноут по каким то причинам переводится в энергосберегающий режим.

4. Не в тему вопрос но все же, если включать эфекты рабочего стола kde4, то они дают максимум 30 фпс, и все довольно сильно тормозит, хотя тот же compiz работает довольно шустро.

Spank ()

Quagga mpd

Форум — Admin

Есть трабла при использовании quagga, то что если я делаю какие то изменения на интерфейсах, например создание удаление, то она теряет соседей. Проблему решил перезапуском сервиса при изменении на интерфейсе. А вот сейчас встала задача поднять mpd и как бы интерфейсы будут постоянно создаваться и разрушаться. Что бы такое придумать что бы квага таки не теряла соседей?

Spank ()

asterisk sip

Форум — Admin

Нужно сделать, что бы астериск цеплялся к сип провайдеру и через 8ку можно было делать звонки. Пишу в конфиг:

register => user:pass@ipaddr
[lanserv]
type=peer
host=ipaddr
username=user
fromusername=user
secret=pass
usereqphone=yes

exten => _8.,1,Dial(SIP/${EXTEN:1}@lanserv,30,r)

Регистрация проходит успешно, а вот при попытке позвонить куда то ругается вот так:

[Dec 22 09:24:33] WARNING[45068]: chan_sip.c:12369 handle_response_invite: Received response: "Forbidden" from '"Office" <sip:115@169.255.1.19>;tag=as243baddc'

Подскажие плиз куда рыть?

Spank ()

quagga and windows

Форум — Admin

Опять я с очерендным траблом. В локалке соединены 2 кваги и одна виндовс машина по ospf. Все работает, но одна квага шлет в логи ошибку когда приходит пакет от виндоус машины, или когда сама отправляет точно не понятно. В дебаге ничего не нашел, что бы подробнее было. Настройки на квагах идентичные...

interface rl0
description LAN Office
ip ospf authentication
ip ospf authentication-key 28985456
ipv6 nd suppress-ra
multicast

Ошибка:
interface rl0:169.255.0.2: ospf_read authentication failed.

Что такое может быть?

Spank ()

quagga openvpn

Форум — Admin

Конфигурю квагу через туннель tun и вот появилась странная ситуация, как будто один из серваков отказывается быть мастером, а другой упорно не хочет им становится.
Вот кусок лога:

2008/11/24 17:49:16 OSPF: Packet[DD]: Neighbor 169.255.0.1: Initial DBD from Slave, ignoring.
2008/11/24 17:49:21 OSPF: Packet[DD]: Neighbor 169.255.0.1: Initial DBD from Slave, ignoring.
2008/11/24 17:49:26 OSPF: Packet[DD]: Neighbor 169.255.0.1: Initial DBD from Slave, ignoring.
2008/11/24 17:49:31 OSPF: Packet[DD]: Neighbor 169.255.0.1: Initial DBD from Slave, ignoring.

Но стоит перезапустить квагу как все начинает работать:

2008/11/24 17:49:32 OSPF: OSPFd 0.99.10 starting: vty@2604
2008/11/24 17:49:32 OSPF: interface 169.255.100.2 [7] join AllSPFRouters Multicast group.
2008/11/24 17:49:32 OSPF: Packet[DD]: Neighbor 169.255.0.1: Initial DBD from Slave, ignoring.
2008/11/24 17:49:32 OSPF: Packet[DD]: Neighbor 169.255.0.1 Negotiation done (Master).
2008/11/24 17:49:32 OSPF: nsm_change_state(169.255.0.1, Loading -> Full): scheduling new router-LSA origination

Тип инетрфейса указан точка точка.

Вот конфиг:

interface tun0
description Office
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 my_key
ipv6 nd suppress-ra

router ospf
ospf router-id 169.255.30.1
passive-interface fxp0
passive-interface fxp1
passive-interface fxp2
network 169.255.30.0/24 area 169.255.30.0
network 169.255.100.0/30 area 169.255.30.0
area 169.255.30.0 authentication message-digest
area 169.255.30.0 range 169.255.100.0/30 cost 1

Конфиг бэкбона:

interface tun8
description Dzer
ip ospf authentication message-digest
ip ospf cost 1
ip ospf message-digest-key 1 md5 my_key
ipv6 nd suppress-ra

router ospf
ospf router-id 169.255.0.1
redistribute kernel
passive-interface em0
network 169.255.0.0/23 area 0.0.0.0
network 169.255.100.0/30 area 169.255.30.0
area 0.0.0.0 authentication message-digest
area 0.0.0.0 range 169.255.0.0/23
area 169.255.30.0 authentication message-digest
area 169.255.30.0 range 169.255.100.0/30 cost 1

С фаерволом вроде все впоряде...

Spank ()

asterisk voicemail

Форум — Admin

Появилась трабла когда сделал всем кодеки 723, заместо gsm и *law, что не работает голосовая почта. 
Ругается вот так:

[Oct 27 16:47:57] WARNING[88463]: channel.c:2779 set_format: Unable to find a codec translation path from g723 to gsm
[Oct 27 16:47:57] WARNING[88463]: file.c:912 ast_streamfile: Unable to open vm-intro (format 0x1 (g723)): No such file or directory

Как такое можно победить?
Spank ()

exim и фильтрация спама

Форум — Admin

Фильтрую письма через блэк листы, но вот хотелось бы не удалять письма, а добавлять в начало поля "тема" пометку о спаме. Как такое можно сделать?
  deny    message       = "you in blacklist - $dnslist_domain \n $dnslist_text"
          dnslists      = cbl.abuseat.org : bl.spamcop.net : www.sorbs.net : psbl.surriel.com

>>>

Spank ()

asterisk and fax

Форум — Admin

Система FreeBSD. 
Софт asterisk-1.4.20.1_1, asterisk-agx-1.4.2(rxfax и txfax), spandsp-devel-0.0.4.p15.
Железка подключенная к телефонной станции для связи обычной телефонии с астериксом: DVG-5402SP, в настройках факса стоит T.30 Only , иначе не работает...

sip.conf

disallow=all
allow=ulaw
allow=alaw

[100]
type=friend
callerid="DLink IP Office" <100>
host=dynamic
username=100
secret=secret
context=office

extensions.conf

;Факсовый номер.
exten => 444,1,Answer()
exten => 444,2,Set(FAXFILE=/var/spool/asterisk/fax/${STRFTIME(${EPOCH},,%d.%m.%Y-%H:%M:%
S)}-${CALLERID(num)}-${EXTEN})
exten => 444,3,rxfax(${FAXFILE}.tif|debug)
exten => 444,4,Hangup

Звонок проходит, факс отправляется, только файл факса создается 8 байт, очень редко непонятно по каким причинам создается наманый tif но изображение все кривое и как правило не до конца. 
Астериск ругается так:
[Aug 12 11:06:31] WARNING[24890]: /tmp/ports/usr/ports/net/asterisk-agx/work/agx-ast-addons/app_rxfax.c:80 span_message: WARNING T.30 Non-ECM carrier not found
С факсом все в порядке так как на другой факс все проходит без проблем.

Есть возможность как то нормально заставить принимать факсы?

>>>

Spank ()

asterisk и voicemail

Форум — Admin

Есть проблема при попытке попасть на свой аккаунт voicemail, ввожу номер и пароль но система говорит, что логина не существует такого :(.
app_voicemail.c:6368 vm_authenticate: Couldn't read userna

extensions.conf:
exten => 500,1,VoicemailMain

voicemail.conf:
[office]
666 => 2222,Spank,spank@localhost
555 => 9855,Andrey,andrey@localhost

В sip.conf dtmfmode = inband.

Если сделать например так 
exten => 111,1,VoiceMailMain(s666@office)
то по менюшке там намано с помощью цифер перемещаюсь....

>>>

Spank ()

RSS подписка на новые темы