LINUX.ORG.RU

Сообщения Proxerboss

 

aclocal error

Форум — General

не могу скомпилить приложение, в чем дело? либы поставил, но какая то херня.

 root@kali:~/brainflayer# make
git submodule init
git submodule update
cd secp256k1; make distclean || true
make[1]: вход в каталог «/root/brainflayer/secp256k1»
make[1]: *** Нет правила для сборки цели «distclean».  Останов.
make[1]: выход из каталога «/root/brainflayer/secp256k1»
cd secp256k1; ./autogen.sh
Makefile.am:3: error: Libtool library used but 'LIBTOOL' is undefined
Makefile.am:3:   The usual way to define 'LIBTOOL' is to add 'LT_INIT'
Makefile.am:3:   to 'configure.ac' and run 'aclocal' and 'autoconf' again.
Makefile.am:3:   If 'LT_INIT' is in 'configure.ac', make sure
Makefile.am:3:   its definition is in aclocal's search path.
autoreconf: automake failed with exit status: 1
Makefile:21: ошибка выполнения рецепта для цели «secp256k1/.libs/libsecp256k1.a»
make: *** [secp256k1/.libs/libsecp256k1.a] Ошибка 1

 

Proxerboss ()

Как преобразовать диапазоны ip в список?

Форум — General

Есть диапазоны ip адресов, допустим от 1.1.1.1 до 255.255.255.255, как можно преобразовать его в список ip адресов? То есть все возможные варианты из этого промежутка.

Ну либо от 1.1.1.1 до 1.255.255.255.

нашел тему на форуме, вот нужно именно то о чем пишет автор Подскажите генератор диапазона IP

кто сможет помочь, закину $10 на биткоин)

 

Proxerboss ()

Cargo

Форум — General

установил все библиотеки, но все равно не работает команда cargo, просят сделать вот это Be sure to add ~/.cargo/bin to your PATH. как это сделать?

пытаюсь поставить вот это - https://github.com/gcarq/rusty-blockparser

установил https://github.com/rust-lang/cargo

поставил

    python
    curl (on Unix)
    cmake
    OpenSSL headers (only for Unix, this is the libssl-dev package on ubuntu)
    cargo and rustc
но все равно неработает команда cargo build --release, точнее её как будто нет в системе

 

Proxerboss ()

Пакеты, имеющие неудовлетворённые зависимости

Форум — General

Установил стим по этому видео https://www.youtube.com/watch?v=0x47DBnhVe4 но так как у меня версия x64, ничего запустить не получилось, а теперь вообще все поломалось, пробую удалить либо установить какой нибудь пакет, и получаю такую ошибку.

root@kali:~# apt-get remove steam-launcher 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 gcc-7-multilib : Зависит: libc6-dev-i386 (>= 2.11) но он не будет установлен
 libc6-dev-x32 : Зависит: libc6-dev-i386 (= 2.24-17) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
root@kali:~#

А при попытке запуска Steam - Error: You are missing the following 32-bit libraries, and Steam may not run: libGL.so.1

Скачивал с офф сайта и устанавливал через gdebi, а потом ставил обновления из видео.

Как пофиксить?

 

Proxerboss ()

Ищу специалиста по CUDA

Форум — Job

Нужен специалист который разбирается в CUDA, требуется переписать проект под вычисление через GPU. Бюджет до $500, за работу.

жаба: «king-of-gods@exploit.im», почта: king-of-gods@yandex.ua

 

Proxerboss ()

Требуется специалист по OpenCL

Форум — Job

Нужно сделать чтобы софт работал через GPU, переписать его под OpenCL.

Требуется специалист, сумма договорная... Пишите свои контактные данные в теме.

 

Proxerboss ()

Скрипт для генерации предложений

Форум — Job

Нужно написать скрипт, который должен генерировать все возможные предложения из предоставленных ему слов.

Допустим я загружаю ему текстовой документ со словами:

did
been
now
look
back
my
no
your
which
about
time
down
into
who
can
know
if
just
their
get
over

А на выходе получаю все возможные комбинации предложений из слов, в отдельном текстовом документе с результатом.

Обязательно нужно чтобы на этапе запуска скрипта я мог выбрать минимальное и максимальное количество слов которое может присутствовать в одной строке. То есть допустим все возможные комбинации от 2-ух слов до 6 слов в одной строке. Из списка слов предоставленного ему.

Пример:

just time get
into get
look my get know just
get over if know

И так далее.

Плачу: $10 за такой скриптик вам на битки. (не знаю расценки работы тут) Готов оплатить больше если работа сложна.

 

Proxerboss ()

Как замутить генерацию предложений из слов?

Форум — Development

У меня есть база состоящая из определенных слов. Если проще то мне нужна утилита которая сможет составлять мне предложения, из предоставленных мною слов. Рандомные, даже если они не существуют.

Допустим:

did
been
now
look
back
my
no
your
which
about
time
down
into
who
can
know
if
just
their
get
over

Как или с помощью чего можно сделать чтобы все слова сгенерировались во все возможные комбинации?

Примерно вот так:

over know into
time if now
get over
their whoknow time did
и так далее? и все возможные комбинации. тому кто поможет готов выслать $ вознаграждение!

 

Proxerboss ()

MakeFile Ошибка Компиляции

Форум — General

Как пофиксить? При компиляции через makefile идет установка файлов, все устанавливается, и в конце такая ошибка.

gcc -O3 -flto -funsigned-char -falign-functions=16 -falign-loops=16 -falign-jumps=16 -Wall -Wextra -Wno-pointer-sign -Wno-sign-compare -pedantic -std=gnu99 -c algo/sha3.c -o algo/sha3.o
gcc -O3 -flto -funsigned-char -falign-functions=16 -falign-loops=16 -falign-jumps=16 -Wall -Wextra -Wno-pointer-sign -Wno-sign-compare -pedantic -std=gnu99 -c algo/brainv2.c -o algo/brainv2.o
cd scrypt-jane; gcc -O3 -DSCRYPT_SALSA -DSCRYPT_SHA256 -c scrypt-jane.c -o scrypt-jane.o
gcc -O3 -flto -funsigned-char -falign-functions=16 -falign-loops=16 -falign-jumps=16 -Wall -Wextra -Wno-pointer-sign -Wno-sign-compare -pedantic -std=gnu99 -static brainflayer.o hex.o bloom.o mmapf.o hsearchf.o ec_pubkey_fast.o ripemd160_256.o dldummy.o algo/brainwalletio.o algo/warpwallet.o algo/keccak.o algo/sha3.o algo/brainv2.o secp256k1/.libs/libsecp256k1.a scrypt-jane/scrypt-jane.o -lssl -lrt -lcrypto -lz -lgmp -o brainflayer
/usr/bin/ld: cannot find -lz
/usr/lib/gcc/x86_64-linux-gnu/6/../../../x86_64-linux-gnu/libcrypto.a(b_addr.o): In function `BIO_lookup':
(.text+0xdc6): warning: Using 'getaddrinfo' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/gcc/x86_64-linux-gnu/6/../../../x86_64-linux-gnu/libcrypto.a(b_sock.o): In function `BIO_gethostbyname':
(.text+0x71): warning: Using 'gethostbyname' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
collect2: error: ld returned 1 exit status

Буду благодарен за любую помощь.

 

Proxerboss ()

BrainFlayer Error Make

Форум — General

При попытке скомпилить проект через makefile, получаю вот это. Сам проект: https://github.com/ryancdotorg/brainflayer/

root@kali:~/brainflayer# make

git submodule init
git submodule update
cd secp256k1; make distclean || true
make[1]: вход в каталог «/root/brainflayer/secp256k1»
make[1]: *** Нет правила для сборки цели «distclean».  Останов.
make[1]: выход из каталога «/root/brainflayer/secp256k1»
cd secp256k1; ./autogen.sh
./autogen.sh: 3: ./autogen.sh: autoreconf: not found
Makefile:21: ошибка выполнения рецепта для цели «secp256k1/.libs/libsecp256k1.a»
make: *** [secp256k1/.libs/libsecp256k1.a] Ошибка 127

Само содержимое makefile:

HEADERS = bloom.h crack.h hash160.h warpwallet.h
OBJ_MAIN = brainflayer.o hex2blf.o blfchk.o ecmtabgen.o hexln.o filehex.o
OBJ_UTIL = hex.o bloom.o mmapf.o hsearchf.o ec_pubkey_fast.o ripemd160_256.o dldummy.o
OBJ_ALGO = $(patsubst %.c,%.o,$(wildcard algo/*.c))
OBJECTS = $(OBJ_MAIN) $(OBJ_UTIL) $(OBJ_ALGO)
BINARIES = brainflayer hexln hex2blf blfchk ecmtabgen filehex
LIBS = -lssl -lrt -lcrypto -lz -lgmp
CFLAGS = -O3 \
         -flto -funsigned-char -falign-functions=16 -falign-loops=16 -falign-jumps=16 \
         -Wall -Wextra -Wno-pointer-sign -Wno-sign-compare \
         -pedantic -std=gnu99
COMPILE = gcc $(CFLAGS)

all: $(BINARIES)

.git:
	@echo 'This does not look like a cloned git repo. Unable to fetch submodules.'
	@false

secp256k1/.libs/libsecp256k1.a: .git
	git submodule init
	git submodule update
	cd secp256k1; make distclean || true
	cd secp256k1; ./autogen.sh
	cd secp256k1; ./configure
	cd secp256k1; make

secp256k1/include/secp256k1.h: secp256k1/.libs/libsecp256k1.a

scrypt-jane/scrypt-jane.h: .git
	git submodule init
	git submodule update

scrypt-jane/scrypt-jane.o: scrypt-jane/scrypt-jane.h scrypt-jane/scrypt-jane.c
	cd scrypt-jane; gcc -O3 -DSCRYPT_SALSA -DSCRYPT_SHA256 -c scrypt-jane.c -o scrypt-jane.o

brainflayer.o: brainflayer.c secp256k1/include/secp256k1.h

algo/warpwallet.o: algo/warpwallet.c scrypt-jane/scrypt-jane.h

algo/brainwalletio.o: algo/brainwalletio.c scrypt-jane/scrypt-jane.h

algo/brainv2.o: algo/brainv2.c scrypt-jane/scrypt-jane.h

ec_pubkey_fast.o: ec_pubkey_fast.c secp256k1/include/secp256k1.h
	$(COMPILE) -Wno-unused-function -c $< -o $@

%.o: %.c
	$(COMPILE) -c $< -o $@

hexln: hexln.o hex.o
	$(COMPILE) -static $^ $(LIBS) -o $@

blfchk: blfchk.o hex.o bloom.o mmapf.o hsearchf.o
	$(COMPILE) -static $^ $(LIBS) -o $@

hex2blf: hex2blf.o hex.o bloom.o mmapf.o
	$(COMPILE) -static $^ $(LIBS) -lm -o $@

ecmtabgen: ecmtabgen.o mmapf.o ec_pubkey_fast.o
	$(COMPILE) -static $^ $(LIBS) -o $@

filehex: filehex.o hex.o
	$(COMPILE) -static $^ $(LIBS) -o $@

brainflayer: brainflayer.o $(OBJ_UTIL) $(OBJ_ALGO) \
             secp256k1/.libs/libsecp256k1.a scrypt-jane/scrypt-jane.o
	$(COMPILE) -static $^ $(LIBS) -o $@

clean:
	rm -f $(BINARIES) $(OBJECTS)

Пробовал много чего, ничего не помогает, и обновления ставил и т.д.

Кто сможет помочь, буду очень признателен.

 , ,

Proxerboss ()

RSS подписка на новые темы