LINUX.ORG.RU

Сообщения Niks

 

Не работает Direct Rendering

Кто может помочь с проблемой? Перешел на Mandriva 2007.1 Spring и теперь не работает 3D ускорение. glxinfo выдает

[niks@Linux ~]$ glxinfo name of display: :1.0 Xlib: extension "GLX" missing on display ":1.0". Xlib: extension "GLX" missing on display ":1.0". Xlib: extension "GLX" missing on display ":1.0". Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat ---------------------------------------------------------------------- Xlib: extension "GLX" missing on display ":1.0". Xlib: extension "GLX" missing on display ":1.0". 0x21 16 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None

Пробовал установить свободние драйвера dri - ошибка сборки

/install/radeon/drm/linux-core/ati_pcigart.c: In function ‘drm_ati_free_pcigart_table’: /install/radeon/drm/linux-core/ati_pcigart.c:87: error: ‘struct page’ has no member named ‘count’ make[2]: *** [/install/radeon/drm/linux-core/ati_pcigart.o] Ошибка 1 make[1]: *** [_module_/install/radeon/drm/linux-core] Ошибка 2 make[1]: Leaving directory `/usr/src/linux-2.6.17-15mdv' make: *** [modules] Ошибка 2

В логах xorg при запуске не нашел ошибок - все запускается как надо, но не работает. При запуске OpenArena

Calling SDL_Init(SDL_INIT_VIDEO)... SDL_Init(SDL_INIT_VIDEO) passed. Initializing OpenGL display ...setting mode 3: 640 480 SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual SDL_SetVideoMode failed: Couldn't find matching GLX visual Couldn't get a visual ...WARNING: could not set the given mode (3) ----- CL_Shutdown ----- RE_Shutdown( 1 ) ----------------------- Sys_Error: GLimp_Init() - could not load OpenGL subsystem

Что можно с этим сделать?

>>>

Niks ()

OpenSuSE 10.2/3 нет звука. Ошибка микшера.

Не работает звук, т.к. Kmix не может найти микшер. Микшер не загружается, т.к. в ядре 2.6.20 что-то глюкнутое с модулем моей звуковой платы Ali 5451 - на ядре 2.6.16 все работало. Через Yast настраиваю - тествый звук есть, но ВСЕ программы сообщают об ошибке микшера ALSA. linux-suse:/home/niks # modprobe ac97_codec linux-suse:/home/niks # modprobe snd-ali5451 linux-suse:/home/niks # modprobe snd-mixer-oss linux-suse:/home/niks #

а звука как не было так и нет. при попытке регулировки громкости вылезает окно Kmix, и сообщение "Программа kmix не запущена". В kmix, в графе "текущий микшер" - пустое место. Из журнала запуска /var/log/messages

Feb 19 21:06:55 linux-suse kernel: ACPI: PCI interrupt for device 0000:00:06.0 disabled Feb 19 21:07:26 linux-suse kernel: ACPI: PCI Interrupt 0000:00:06.0[A] -> Link [LNK7] -> GSI 5 (level, low) -> IRQ 5 Feb 19 21:07:29 linux-suse kernel: ALSA sound/pci/ac97/ac97_codec.c:2032: AC'97 1 does not respond - RESET Feb 19 21:07:29 linux-suse kernel: ALSA sound/pci/ac97/ac97_codec.c:2041: AC'97 1 access is not valid [0xffffffff], removing mixer. Feb 19 21:07:29 linux-suse kernel: ALSA sound/pci/ali5451/ali5451.c:1975: ali mixer 1 creating error.

Что с этим можно сделать? Пробовал перейти обратно на 2.6.16 - не получается - kernel panic при монтировании корневого раздела, наверно не нравится что ext3 вместо reiserfs

Niks ()

Хочу доступ к NTFS разделу под юзером

Помогите, не знаю что делать. Купился на возможность нормальной работы с NTFS через ntfs-3g , конертнул раздел, но примонтированный он работает только под рутом. Иначе нет доступа - что мне сделать чтобы все работало под юзером - или это невозможно? Напрямую изменить права доступа не получается.

Niks ()

Как сделать RPM из TAR.GZ

У меня дистрибутив SuSE 10.1 основанный на rpm пакетах. Скачал программу которая есть только в ter.gz. Программой KRPMBUILDER попытался сделать из этого файла rpm, программа отработала компиляцию без ошибок, но я так и не нашел файл результата. Или эта программа не предназначена для создания RPM или я чтото не так сделал?

Niks ()

Можно ли заставить Линукс менять частоту процессора?

У меня на ноутбуке HP Pavilion ze 5600 установлен процессор Celeron 2,6GHz flags: fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr

Могу ли я заставить Линукс уменьшить частоту процессора для энергосбережения? И как это сделать? Какие еще фичи процессора Линукс может использовать? Ну например sse2 или еще что.

Niks ()

DRI и SuSE 10.1

Помогите пожалуйста - никак не могу запустить прямой рендеринг. Видеокарта ATI IGP 345 - проприетарные дрова с ней не работают, поэтому дрова ставил с dri.sf.net . Работает все нормально но прямого рендеринга нет. linux:/home/niks # glxinfo name of display: :0.0 display: :0 screen: 0 direct rendering: No server glx vendor string: SGI server glx version string: 1.2 server glx extensions: GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig client glx vendor string: ATI client glx version string: 1.3 client glx extensions: GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float, GLX_ATI_render_texture GLX extensions: GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_ARB_multisample OpenGL vendor string: Mesa project: www.mesa3d.org OpenGL renderer string: Mesa GLX Indirect OpenGL version string: 1.2 (1.5 Mesa 6.4.1) OpenGL extensions: GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map, GL_ARB_texture_env_add, GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3, GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add, GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat ---------------------------------------------------------------------- 0x23 16 tc 0 16 0 r . . 5 6 5 0 0 16 0 0 0 0 0 1 0 None 0x24 16 tc 0 16 0 r . . 5 6 5 0 0 16 8 0 0 0 0 1 0 Slow 0x25 16 tc 0 16 0 r . . 5 6 5 0 0 16 0 16 16 16 0 1 0 Slow 0x26 16 tc 0 16 0 r . . 5 6 5 0 0 16 8 16 16 16 0 1 0 Slow 0x27 16 tc 0 16 0 r y . 5 6 5 0 0 16 0 0 0 0 0 1 0 None 0x28 16 tc 0 16 0 r y . 5 6 5 0 0 16 8 0 0 0 0 1 0 Slow 0x29 16 tc 0 16 0 r y . 5 6 5 0 0 16 0 16 16 16 0 1 0 Slow 0x2a 16 tc 0 16 0 r y . 5 6 5 0 0 16 8 16 16 16 0 1 0 Slow 0x2b 16 dc 0 16 0 r . . 5 6 5 0 0 16 0 0 0 0 0 1 0 None 0x2c 16 dc 0 16 0 r . . 5 6 5 0 0 16 8 0 0 0 0 1 0 Slow 0x2d 16 dc 0 16 0 r . . 5 6 5 0 0 16 0 16 16 16 0 1 0 Slow 0x2e 16 dc 0 16 0 r . . 5 6 5 0 0 16 8 16 16 16 0 1 0 Slow 0x2f 16 dc 0 16 0 r y . 5 6 5 0 0 16 0 0 0 0 0 1 0 None 0x30 16 dc 0 16 0 r y . 5 6 5 0 0 16 8 0 0 0 0 1 0 Slow 0x31 16 dc 0 16 0 r y . 5 6 5 0 0 16 0 16 16 16 0 1 0 Slow 0x32 16 dc 0 16 0 r y . 5 6 5 0 0 16 8 16 16 16 0 1 0 Slow

что можно предпринять?

Niks ()

Не устанавливаются драйвера для ATI Radeon IGP 340M

Система SuSE 10.1. X11 6.9.0 Со штатным драйвером radeon работает, но как я понимаю нет 3D и криво работает SAX, нельзя запустить Xgl. пытаюсь ставить проприетарный свежий драйвер, но при попытке выполнения xinit система выдает ошибку:

(II) Primary Device is: PCI 01:05:0 (II) ATI Proprietary Linux Driver Version Identifier:8.25.18 (II) ATI Proprietary Linux Driver Release Identifier: LGDr8.25g1 (II) ATI Proprietary Linux Driver Build Date: May 18 2006 09:54:44 (II) ATI Proprietary Linux Driver Build Information: autobuild-rel-r6-8.25.1-driver-lnx-268237 (EE) No devices detected.

Fatal server error: no screens found

Please consult the The X.Org Foundation support at http://wiki.X.Org for help. Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Что можно сделать? пока ковырянье в xorg.conf , переустановки, исследование инструкций и выполнение всех шагов по ним - не помогло. Может ATI не поддерживает мой видеокарту? Но в драйвере же она есть!

Niks ()

Linux поедает пространство на винте! Спасенья нет?

После установки полгода назад SuSE 10 занимал всего 2,5 Гб, теперь уже 6 Гб и это при том что все данные у меня на другом разделе. Растет постепенно как раковая опухоль. Что делать? может какие то логи или архивные копии файлов он сохранияет? где их найти и постирать нафиг? Софта лишнего не устанавливал, оболочка только KDE - даже доки устанавливать не стал! Помогите - у меня на ноуте винт маленький - раздел не могу расширять дальше!

Niks ()

Непонятная ошибка при запуске LinuxDCPP

Программа нормально компилируется но при запуске выводит symbol lookup error: /opt/gnome/lib/libglade-2.0.so.0: undefined symbol: gtk_about_dialog_get_type

Что можно с этим сделать - поискал в инете - везде этот вопрос оставался без ответа. Система suSE 10.1. - libglade2-2.5.1-24

Niks ()

Нет звука в презентациях OpenOffice 2.0

Нет звука в презентациях Ppt в чем может быть проблема? Лазал по сайту OO видел жалобы на подобные глюки, но не нашел решения. Все остальные программы музыку играют, а OpenOffice 2 не хочет. Может кто -нибудь подсказать в чем дело?

Niks ()

Обновился через Yast на SuSE 10.1 теперь не запускается KDE!

Обновился через Yast с ftp.chg.ru и теперь система после загрузки выводит приглашение в консоли и не запускает KDE - что делать? Пробовал команды kde, kdm, init 3, init 5 - но в X не выходит. помогите - что поправить или переустановить! Обратно на SuSE 10 не хочу - столько мегабайт обновлений выкачал уже что жалко!

Niks ()

RSS подписка на новые темы