LINUX.ORG.RU

Сообщения Allakka

 

День Радио

Форум — Talks

Всех причастных и непричастных с праздником!

Всем 73!

 , , , ,

Allakka ()

SimJacker - критическая уязвимость в SIM-картах

Форум — Security

Уязвимость, получившая название SimJacker, находится в программном обеспечении SIMalliance Toolbox Browser (S@T Browser), встроенном в большинство SIM-карт, которые используются мобильными операторами как минимум в 30 странах мира. Злоумышленники могут прибегнуть к ней независимо от марки устройства жертвы. По словам специалистов, этот эксплойт успешно используется хакерами последние несколько лет.

S@T Browser представляет собой приложение, которое устанавливается на SIM-карты, в том числе и на eSIM, как часть SIM Tool Kit (STK), и предназначено для того, чтобы мобильные операторы могли предоставлять своим клиентам разные базовые услуги. S@T Browser содержит ряд инструкций STK, таких как отправка сообщений, настройка звонков, запуск браузера, предоставление локальных данных, запуск по команде и отправка настроек, которые могут быть активированы сообщением.

Используя GSM-модем за 10 долларов, злоумышленники могут отправить на аппарат жертвы поддельное сообщение, содержащее вредоносный код. Это позволяет им:

  • Получить местоположение целевого устройства и его IMEI
  • Распространять любую информацию путём отправки поддельных сообщений от имени жертв
  • Совершать звонки на платные номера
  • Шпионить, приказав устройству позвонить по номеру телефона злоумышленника
  • Загружать вредоносные программы, заставляя браузер устройства открывать вредоносные веб-страницы
  • Отключать SIM-карту
  • Получать информацию о языке на устройстве, заряде аккумулятора и т. д.

 , , , ,

Allakka ()

Нужен шрифт типа Times New Roman

Форум — General

Есть некая контора, из которой периодически присылают pdf-файлы со шрифтом Times New Roman, причём «не встраивают» его в файл. Я просил их встраивать шрифты в файл, но бесполезно. При просмотре в okular вижу абракадабру.

fc-match "Times New Roman"
  • Tinos-Regular.ttf: «Tinos» «Regular» - смещение на одну букву, К превращается в Л и т.д.
  • LiberationSerif-Regular.ttf: «Liberation Serif» «Regular» - буквы превращаются в псевдографику
  • FreeSerif.ttf: «FreeSerif» «Обычный» - буквы превращаются в спецсимволы
  • n021003l.pfb: «Nimbus Roman No9 L» «Regular» - пустота
  • PTF55F.ttf: «PT Serif» «Regular» - смесь кириллицы с греческим и всё с умлаутами
  • DejaVuSerif.ttf: «DejaVu Serif» «Book» - похоже одинаково с FreeSerif
  • DroidSerif-Regular.ttf: «Droid Serif» «Regular» - похоже на PT Serif, только кириллицы больше

Если установить Times New Roman, то он заменяет собой fc-match serif и становится плохо со шрифтами в других приложениях.

Нужен шрифт полностью идентичный Times New Roman. Есть такой?

 ,

Allakka ()

С Днём Радио!

Форум — Talks

Поздравляю всех причастных, а также слушателей с Днём Радио!

Всем 73!

Кстати Linux и данный праздник объединяет фамилия Попов. Удивительное рядом.

 ,

Allakka ()

Один / для ноутбука и стационарника

Форум — General

Надоело иметь 2 немного разных системы на 2 компах. Хочу одну систему на 2 компа. Т.е. запустил ноутбук, настроил, например, cron, потом запустил другой комп, а там cron уже настроенный выполняет свою задачу.

Можно ли, если да, то как?

В гугол не могу, не знаю как это извращение называется, а он меня не понимает, трезвый наверное.

 , , ,

Allakka ()

Полосы на экране

Форум — Linux-hardware

Купил на ebay видеокарту на ноутбук Toshiba Satellite A100. Поменял, но на экране это http://pic4a.ru/75/gD.JPG. На внешнем мониторе такая же картинка. Написал продавцу про то, что карта не работает, но он уверяет, что проверил её и она хорошая.

Вопрос: Продавец врёт или дело не в видеокарте?

Inshallah, Dimez

 , ,

Allakka ()

Включить русский в BasKet Note Pads

Форум — General

В BasKet Note Pads интерфейс не на русском.

~$  basket -v
basket 2.49-alpha

~$  rpm -ql basket5-lang
/usr/share/locale/cs/LC_MESSAGES/basket.mo
/usr/share/locale/da/LC_MESSAGES/basket.mo
/usr/share/locale/de/LC_MESSAGES/basket.mo
/usr/share/locale/es/LC_MESSAGES/basket.mo
/usr/share/locale/fr/LC_MESSAGES/basket.mo
/usr/share/locale/it/LC_MESSAGES/basket.mo
/usr/share/locale/ja/LC_MESSAGES/basket.mo
/usr/share/locale/nl/LC_MESSAGES/basket.mo
/usr/share/locale/nn/LC_MESSAGES/basket.mo
/usr/share/locale/pl_PL/LC_MESSAGES/basket.mo
/usr/share/locale/pt/LC_MESSAGES/basket.mo
/usr/share/locale/ru/LC_MESSAGES/basket.mo
/usr/share/locale/tr/LC_MESSAGES/basket.mo
/usr/share/locale/zh_CN/LC_MESSAGES/basket.mo
/usr/share/locale/zh_TW/LC_MESSAGES/basket.mo

~$  locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8
LC_COLLATE=ru_RU.UTF-8
LC_MONETARY=ru_RU.UTF-8
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=

 , , ,

Allakka ()

Куплю видеокарту на ноутбук Toshiba Satellite A100

Форум — Talks

Стояла видеокарта NVIDIA GeForce Go 7600, но приказала долго жить.

Хотелось бы поставить Ati Mobility Radeon X1600, т.к. она должна завестись под линуксом, а насчёт NVIDIA есть сомнения, что будет работать без хлопот. Но в инете нашёл инфу, что менять видеокарту в ноутбуках - плохая идея.

 , , , ,

Allakka ()

Где купить Raspberry Pi 3?

Форум — Linux-hardware

Хочу к телевизору прицепить Raspberry Pi + OpenELEC + HDD + пульт ДУ от ТВ для просмотра мультимедиа (фото, видео до 1080p).

Собственно несколько вопросов:

1. Где принято покупать Raspberry Pi 3?

2. Пульт от телевизора можно будет прицепить к OpenELEC?

 , ,

Allakka ()

Объединить 2 строки в одну

Форум — General

Есть 2 строчки:

ssh root@192.168.1.1 cat /tmp/dhcp.leases | awk '{print $3"\t"$4"\t"$2}'
date +%R --date=@`ssh root@192.168.1.1 cat /tmp/dhcp.leases | awk '{print $1-43200}'`
Хотелось бы сделать всё с одним ssh и одним awk.

 , , ,

Allakka ()

Куда делся /var/log/boot.log?

Форум — General

Собственно, что-то в системе сбоит на этапе загрузки. Прочитать ошибку не успел, решил в логах посмотреть, а /var/log/boot.log нет нигде.

В dmesg и /var/log/messages ошибок нет.

grub2 linux /boot/vmlinuz-3.16.7-35-desktop root=UUID=4fb031c0-399b-4e53-9c3e-86a74c492f95 quiet plymouth.enable=0 nosplash showopts dpm.radeon=1

Как вернуть назад /var/log/boot.log или оно теперь в другом месте?

 , ,

Allakka ()

Вспомнить фильм

Форум — Talks

Даже не один, а целых два.

1. Кажется чёрно-белый фильм годов 70-х, скорее всего американский. Три девушки в кожаной одежде и кажется с цепями (байкерши или рокерши) катались на машине, пока у них что-то с этой машиной не случилось. Остановились они на ферме, а хозяину этой фермы они не понравились и он решил их убить или изнасиловать, точно не помню. Помню только, что девушки были очень «суровые» в начале, до того как фермер начал их убивать. Ещё самая главная из них была тираном и отрывалась на своих подружках.

2. Тоже вроде бы американский фильм, только уже цветной и годов 80-90. Муж решил убить жену, приготовив курицу (индейку, какую-то птицу) с инъекцией яда (вроде мышьяк) в один из боков этой дичи. Но в гости к ним пришла какая-то женщина (возможно подружка жены) и муж запаниковав вызвал скорую раньше, чем кому-то стало плохо.

 , ,

Allakka ()

man zsh для самых маленьких

Форум — General
$ cat /etc/zsh_command_not_found
function preexec() {
    command="${1%% *}"
}

function precmd() {
    (($?)) && [ -n "$command" ] && [ -x /usr/bin/python ] && [ -x /usr/bin/command-not-found ] && {
        whence -- "$command" >& /dev/null ||
            /usr/bin/python /usr/bin/command-not-found "$command" zypp
        unset command
    }
}
$

Объясните, что означает command="${1%% *}"?

 , ,

Allakka ()

Поломался Terminus

Форум — General

После очередного zupper up (среди обновлений были libfreetype6, libXfont1, ft2demos) сломался Terminus и похоже большинство bitmap шрифтов, т.е. вместо Terminus отображается какой-то совсем не похожий на него шрифт. Гугл ни чем не смог мне помочь, либо я не правильно формулирую запрос.

$ fc-cache -vf && fc-list | grep Term
/usr/share/fonts: caching, new cache contents: 0 fonts, 10 dirs
/usr/share/fonts/100dpi: caching, new cache contents: 350 fonts, 0 dirs
/usr/share/fonts/75dpi: caching, new cache contents: 350 fonts, 0 dirs
/usr/share/fonts/Speedo: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/Type1: caching, new cache contents: 29 fonts, 0 dirs
/usr/share/fonts/cyrillic: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/encodings: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/encodings/large: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/ghostscript: caching, new cache contents: 52 fonts, 0 dirs
/usr/share/fonts/misc: caching, new cache contents: 172 fonts, 0 dirs
/usr/share/fonts/truetype: caching, new cache contents: 170 fonts, 0 dirs
/usr/share/fonts/uni: caching, new cache contents: 2 fonts, 0 dirs
/usr/X11R6/lib/X11/fonts: skipping, no such directory
/opt/kde3/share/fonts: skipping, no such directory
/usr/local/share/fonts: skipping, no such directory
/home/wl/.local/share/fonts: skipping, no such directory
/home/wl/.fonts: caching, new cache contents: 0 fonts, 8 dirs
/home/wl/.fonts/d: caching, new cache contents: 1 fonts, 0 dirs
/home/wl/.fonts/g: caching, new cache contents: 2 fonts, 0 dirs
/home/wl/.fonts/m: caching, new cache contents: 1 fonts, 0 dirs
/home/wl/.fonts/o: caching, new cache contents: 1 fonts, 0 dirs
/home/wl/.fonts/p: caching, new cache contents: 14 fonts, 0 dirs
/home/wl/.fonts/s: caching, new cache contents: 2 fonts, 0 dirs
/home/wl/.fonts/t: caching, new cache contents: 24 fonts, 0 dirs
/home/wl/.fonts/z: caching, new cache contents: 1 fonts, 0 dirs
Re-scanning /usr/share/fonts: caching, new cache contents: 0 fonts, 10 dirs
Re-scanning /usr/share/fonts/encodings: caching, new cache contents: 0 fonts, 1 dirs
Re-scanning /home/wl/.fonts: caching, new cache contents: 0 fonts, 8 dirs
/var/cache/fontconfig: not cleaning unwritable cache directory
/home/wl/.cache/fontconfig: cleaning cache directory
/home/wl/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
/usr/share/fonts/100dpi/termB14.pcf.gz: Bitstream Terminal:style=Bold
/usr/share/fonts/75dpi/term14.pcf.gz: DEC Terminal:style=Regular
/usr/share/fonts/100dpi/term14.pcf.gz: Bitstream Terminal:style=Regular
/usr/share/fonts/75dpi/termB14.pcf.gz: DEC Terminal:style=Bold

~$ cat /etc/fonts/conf.d/70-yes-bitmaps.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!-- Accept bitmap fonts -->
 <selectfont>
  <acceptfont>
   <pattern>
     <patelt name="scalable"><bool>false</bool></patelt>
   </pattern>
  </acceptfont>
 </selectfont>
</fontconfig>

~$

 , ,

Allakka ()

Подключить openwrt к интернету через 3g модем

Форум — Admin

Прошил TP-Link TL-MR3020 на openwrt, теперь для настройки его нужно подключить к инету. В качестве доступа в инет выступает 3g модем Е1550. Нашёл скрипт для NAT ppp0 to eth0

#!/bin/bash
#NAT script from www.debian-administration.org, modified by CRImier
# Exit status 0 if operation is correct
# Exit status 1 if trying to use last interface used when running for the first time
# Exit status 2 if interface doesn't exist
EIF=''
IIF='enp2s0'
PATH=/usr/sbin:/sbin:/bin:/usr/bin
LOGFILE=/etc/nat-if.conf
touch $LOGFILE

#
#Checking command-line arguments and setting $EIF variable according to them
#

if [[ $1 == "" ]] #If there's no arguments, just use previous settings.
then
    EIF=`cat $LOGFILE`
    if [[ $EIF == "" ]] #Just check for an empty file!
    then
        echo "Please, specify interface name for first usage using 'firewall interface', e.g. 'firewall eth0'"
        exit 1
    fi
elif [ $1 == "help" ] #Output help message
then
    echo "NAT script"
    echo "(c) www.debian-administration.org, modified by CRImier"
    echo "Usage: 'firewall interface', 'firewall info' or simply 'firewall' to use last interface firewall was set on."
    echo "Argument is external interface name, internal interface name is hard-coded in the script"
    exit 0
elif [ $1 == "info" ] #Print interface firewall is set on
then 
    cat $LOGFILE
    exit 0
else
    ifconfig $1 &>/dev/null
    if [ $? == 0 ]
    then #Interface name must be correct as ifconfig gives 0 exit code
        EIF=$1
        echo $EIF > $LOGFILE 
    else 
        echo "Incorrect interface name"
        exit 2
    fi
fi

#
#$EIF is set correctly, let's apply the rules:
#

iptables -F 
iptables -t nat -F
iptables -t mangle -F
iptables -X
iptables -A INPUT -i lo -j ACCEPT
iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i $EIF -o $IIF -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i $IIF -o $EIF -j ACCEPT
iptables -t nat -A POSTROUTING -o $EIF -j MASQUERADE
iptables -A FORWARD -i $EIF -o $IIF -j REJECT
echo 1 > /proc/sys/net/ipv4/ip_forward
echo "Firewall started."
Но он мне не помог. Openwrt инета не видит
root@OpenWrt:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network is unreachable
root@OpenWrt:~# 
Вывод ifconfig
$  ifconfig 
enp2s0    Link encap:Ethernet  HWaddr 54:04:A6:0C:96:7D  
          inet addr:192.168.1.106  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2357 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3468 errors:0 dropped:0 overruns:0 carrier:5
          collisions:0 txqueuelen:1000 
          RX bytes:507952 (496.0 Kb)  TX bytes:293028 (286.1 Kb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3797 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3797 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:182862 (178.5 Kb)  TX bytes:182862 (178.5 Kb)

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:10.62.247.48  P-t-P:10.64.64.64  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:1728 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1706 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:1265129 (1.2 Mb)  TX bytes:205882 (201.0 Kb)

~$

P.S. Забыл настройки openwrt

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf1:4ec1:693e::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '8.8.8.8'

root@OpenWrt:~#

 , , ,

Allakka ()

Замена связному банку

Форум — Talks

У связного банка поменялись тарифы, теперь при снятии любой суммы наличных берут комиссию 75 рублей. Ищу замену.

Итак, что требуется от банка:

  • рабовладелец кидает з/п на карту
  • я могу снять наличку в любом банкомате (сбербанк, газпром, сельхоз и др) без комиссии
  • могу оплатить покупку в ашане
  • интернетбанк

Что не нужно:

  • кредит в любом его проявлении

Гугл говорит, что мне нужна карта Тинькофф, но там же и подозрение к нему. Я профан в финансовых вопросах, потому и прошу помощи у лоровцев.

 , , ,

Allakka ()

Локализация zypper-a

Форум — General

После очередного zypper up zypper стал на английском.

$  zypper -v ref
Verbosity: 1
Root privileges are required for refreshing system repositories.
$
Совет из гугла

Откройте файл /etc/sysconfig/language в любимом текстовом редакторе. Например:

$ kdesu kwrite /etc/sysconfig/language

Найдите строку:

ROOT_USES_LANG=«ctype»

Замените её на:

ROOT_USES_LANG=«yes»

Но у меня и так

$  cat /etc/sysconfig/language | grep ROOT_USES_LANG
# Root uses this variable only if ROOT_USES_LANG is set to "yes".
# Again, ROOT_USES_LANG must be set to "yes", if an effect on the superuser
ROOT_USES_LANG="yes"
$
Как вернуть великий и могучий?

 , ,

Allakka ()

Баланс телефона из личного кабинета

Форум — General

Необходимо получить баланс телефона из личного кабинета my.beeline.ru для conky. Нашёл скрипт на php, но что-то баланс с его помощью получить не удаётся. Можно и не php.

 , , ,

Allakka ()

Asus 1215B барахлит железо

Форум — General

Переодически (в последнее время всё чаще) стали проявляться какие-то сбои. При включении ноутбука, происходит загрузка BIOS, но не передаётся в GRUB, то есть после сообщений BIOS появляется мигающий курсор и больше ничего. Помогает отключение всей периферии и вытаскивание батареи (обычной, не CMOS).

Пару лет назад была немного другая фигня. Перестали определятся загрузочные устройства: ЖД, liveUSB, причём даже BIOS их не видел. Помог сброс настроек BIOS на дефолт. И вот вроде с тех пор началась такая ерунда.

Собственно вопрос: «Кто виноват и что делать?»

 , ,

Allakka ()

Японские кроссворды

Форум — General

Расклад такой. Есть программа picmi, с помощью которой можно решать японские кроссворды, но база у программы небольшая.

Это можно исправить с помощью многочисленных сайтов японских кроссвордов, например.

Для этого нужно получить изображение xpm типа https://github.com/schuay/picmi/blob/master/levels/default/camera.xpm.

Но я не могу разобрать, где на том сайте забиты данные на кроссворд. Похоже, что здесь

<script type="text/javascript">
var d=[[32,77,140,83],[35,30,56,62],[28,41,60,64],[10,24,33,34],[18,45,24,60],[45,18,60,25],[51,37,104,7],[11,14,31,28],[20,15,32,33],[16,15,32,33],[13,21,32,31],[14,19,32,30],[14,17,32,37],[12,15,32,33],[18,15,32,33],[16,15,32,34],[16,15,32,35],[16,15,32,36],[14,15,32,36],[12,23,32,32],[14,15,32,33],[16,15,32,29],[22,23,40,16],[51,26,11,52],[57,27,21,53],[52,27,16,60],[58,27,22,59],[59,27,23,59],[54,31,13,55],[59,27,23,58],[54,27,18,60],[57,27,21,58],[59,27,23,61],[53,27,17,61],[52,27,16,55],[57,27,21,59],[59,27,23,60],[52,27,16,54],[56,27,12,54],[59,27,23,54],[52,27,16,59],[60,27,24,53],[55,27,19,53],[60,27,24,61],[52,27,16,58],[56,27,20,61],[54,27,18,53],[53,27,17,54],[58,27,22,60],[58,27,22,53],[53,27,17,59],[55,27,19,54],[60,27,24,54],[57,27,21,61],[58,27,26,58],[52,35,14,56],[54,27,25,54],[54,28,26,58],[52,27,16,53],[59,27,23,55],[56,27,20,53],[52,35,15,57],[54,28,29,61],[53,27,17,60],[57,27,21,54],[53,27,17,58],[60,27,24,58],[52,27,16,61],[60,27,24,59],[60,27,24,60],[56,27,20,58],[56,27,20,60],[59,27,23,53],[58,27,22,61],[54,28,27,59],[55,27,28,60],[53,27,17,53],[57,27,21,60],[60,27,24,55],[53,27,17,55],[56,27,20,59],[58,27,25,54]];
</script>
Но связать этот массив с кроссвордом у меня не получается, нужна помощь знатоков javascript.

Может я не туда смотрю, ткните пальцем, пожалуйста.

 , ,

Allakka ()

RSS подписка на новые темы