LINUX.ORG.RU

Для Ubuntu Linux представлен сервис обновления ядра без перезагрузки

 , ,


0

0

Ubuntu Linux стал первым дистрибутивом, не требующим перезагрузки после установки обновления ядра Linux. Компания Ksplice анонсировала начало функционирования нового бесплатного сервиса Ksplice Uptrack для пользователей Ubuntu Linux, поддерживающего установку критических обновлений Linux ядра в дистрибутиве Ubuntu 9.04 без необходимости перезагрузки и временной остановки работы системы.

После установки специального пакета (модуль ядра и интерфейс для управления) установка обновлений с исправлением проблем безопасности для базовых 32- и 64-разрядных сборок Linux ядра будут производится "на лету". Метод получения обновлений не изменяется - они по-прежнему загружаются из стандартных репозиториев Ubuntu, а затем транслируются в представление подходящее для использования в Ksplice. В настоящий момент технология поддерживает обновление трёх базовых сборок ядра: для настольных систем, для серверов и для виртуальных окружений.

Ksplice универсален и не требует какой-либо модификации работающего ядра, требуется лишь подгрузить два модуля ядра для внесения предварительных и фиксирующих изменений, а также специальным образом оформить файл изменений, который будет применён к работающему ядру. Тем не менее, Ksplice невозможно использовать, когда изменения затрагивают структуры данных, но подавляющие большинство исправлений ошибок безопасности не производят подобных модификаций. При оценке уязвимостей, исправленных за прошедшие несколько лет, 87% всех исправлений были пригодными для исправления без остановки работы.

=== новость с сайта opennet.ru ===

>>> Подробности



Проверено: Shaman007 ()

Re: Для Ubuntu Linux представлен сервис обновления ядра без перезагрузки

Не думаю что это актуально для обновлений версий ядра

Lomaster ()

Re: Для Ubuntu Linux представлен сервис обновления ядра без перезагрузки

Вспоминаю боян с БОРа: "Поставил на Убунту патч, позволяющий применять изменения ядра без перезагрузки. Пришлось перезагрузиться..."

QUANTUM ()

Re: Для Ubuntu Linux представлен сервис обновления ядра без перезагрузки

>>А среднестатистический пользователь убунты не знает про команду diff :)

>Ну так там пользователь генту писал...


У среднестатистического пользователя генту зашкаливает ЧВС

krizz ()

Re: Для Ubuntu Linux представлен сервис обновления ядра без перезагрузки

Вот так:

root@fqc:/root# dpkg -i ksplice-uptrack.deb
dpkg: относительно ksplice-uptrack.deb, содержащего ksplice-uptrack:
ksplice-uptrack конфликтует с ksplice
ksplice (версия 0.9.4-1) существует и установлен.
dpkg: не удалось обработать параметр ksplice-uptrack.deb (--install):
конфликт пакетов -- ksplice-uptrack не будет установлен
При обработке следующих пакетов произошли ошибки:
ksplice-uptrack.deb
root@fqc:/root# apt-get remove ksplice
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Пакеты, которые будут УДАЛЕНЫ:
ksplice
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 0 пакетов не обн
овлено.
После данной операции, объём занятого дискового пространства уменьшится на 868kB.
Хотите продолжить [Д/н]?
(Чтение базы данных... на данный момент установлено 158727 файлов и каталогов.)
Удаляется пакет ksplice...
Обрабатываются триггеры для man-db ...
root@fqc:/root# dpkg -i ksplice-uptrack.deb
(Чтение базы данных... на данный момент установлено 158676 файлов и каталогов.)
Распаковывается пакет ksplice-uptrack (из файла ksplice-uptrack.deb)...
(идёт установка)
dpkg: зависимости пакетов не позволяют настроить пакет ksplice-uptrack:
ksplice-uptrack зависит от python-yaml, однако:
Пакет python-yaml не установлен.
ksplice-uptrack зависит от python-decoratortools, однако:
Пакет python-decoratortools не установлен.
ksplice-uptrack зависит от python-pycurl, однако:
Пакет python-pycurl не установлен.
ksplice-uptrack зависит от python-gtk2 (>= 2.10), однако:
Пакет python-gtk2 не установлен.
ksplice-uptrack зависит от python-glade2, однако:
Пакет python-glade2 не установлен.
ksplice-uptrack зависит от gksu, однако:
Пакет gksu не установлен.
ksplice-uptrack зависит от librsvg2-common, однако:
Пакет librsvg2-common не установлен.
ksplice-uptrack зависит от kerneloops, однако:
Пакет kerneloops не установлен.
dpkg: не удалось обработать параметр ksplice-uptrack (--install):
проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для man-db ...
При обработке следующих пакетов произошли ошибки:
ksplice-uptrack
root@fqc:/root# apt-get install python-yaml python-decoratortools python-pycurl python-gtk2 python-glade2 gksu librsvg2-common kerneloops
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
gksu: Зависит: libgksu2-0 (>= 2.0.8) но он не будет установлен
Зависит: libstartup-notification0 (>= 0.8-1) но он не будет установлен
librsvg2-common: Зависит: librsvg2-2 (= 2.26.0-0ubuntu1) но он не будет установлен
python-glade2: Зависит: libglade2-0 (>= 1:2.6.1) но он не будет установлен
python-gtk2: Зависит: python-cairo (>= 1.0.2-1.1) но он не будет установлен
Зависит: python2.5-cairo
Зависит: python2.6-cairo
python-yaml: Зависит: libyaml-0-1 но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).
(какой ужас с зависимостями, однако...)
root@fqc:/root# apt-get -f install Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Исправление зависимостей... Готово
Будут установлены следующие дополнительные пакеты:
gksu kerneloops libgksu2-0 libglade2-0 librsvg2-2 librsvg2-common
libstartup-notification0 libyaml-0-1 python-cairo python-decoratortools
python-glade2 python-gtk2 python-pycurl python-yaml xauth
Предлагаемые пакеты:
librsvg2-bin python-gtk2-doc python-numpy libcurl4-gnutls-dev python-pycurl-dbg
НОВЫЕ пакеты, которые будут установлены:
gksu kerneloops libgksu2-0 libglade2-0 librsvg2-2 librsvg2-common
libstartup-notification0 libyaml-0-1 python-cairo python-decoratortools
python-glade2 python-gtk2 python-pycurl python-yaml xauth
обновлено 0, установлено 15 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 2169kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 8278kB.
Хотите продолжить [Д/н]?
(ставится всё что нужно)
Ну и наконец, то, для чего всё это затевалось:
root@fqc:/root# uptrack-upgrade
The following steps will be taken:
Install [c8ueseae] Symbolic link filenames under eCryptfs can produce alarming warnings in dm
esg.
Install [pdfrn6qa] Denial of service by evading CPU time limits.
Install [xgqc9vy4] VGA console corrupts non-ASCII characters.
Install [uzolzfa2] CVE-2009-1337: kill the wrong capable(CAP_KILL) check.
Install [hrxbvh0e] CVE-2009-1265: Integer overflow in the af_rose maximum user frame size.
Install [ovniqwxh] CVE-2009-1192: Information leak in the agp subsystem.
Install [ll9q1ymc] Multiple bugs in filesystem core.
Install [9xoc5qmo] Possible erroneous memory overcommit in program start.
Install [cdoprpi1] Performance regression in filesystem buffer code.

Go ahead [y/N]? y
Installing [c8ueseae] Symbolic link filenames under eCryptfs can produce alarming warnings in dmesg.
Installing [pdfrn6qa] Denial of service by evading CPU time limits.
Installing [xgqc9vy4] VGA console corrupts non-ASCII characters.
Installing [uzolzfa2] CVE-2009-1337: kill the wrong capable(CAP_KILL) check.
Installing [hrxbvh0e] CVE-2009-1265: Integer overflow in the af_rose maximum user frame size.
Installing [ovniqwxh] CVE-2009-1192: Information leak in the agp subsystem.
Installing [ll9q1ymc] Multiple bugs in filesystem core.
Installing [9xoc5qmo] Possible erroneous memory overcommit in program start.
Installing [cdoprpi1] Performance regression in filesystem buffer code.
Всё. При желании, можно откатить сделанные патчи, все или по выбору.

Frank ()

Re: Для Ubuntu Linux представлен сервис обновления ядра без перезагрузки

val-amart@io:~$ sudo aptitude remove foo2zjs
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях
Инициализация состояний пакетов... Готово
Запись информации расширенных состояний... Готово
Следующие пакеты будут УДАЛЕНЫ:
foo2zjs
0 пакетов обновлено, 0 установлено новых, 1 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0Б архивов. После распаковки освободится 5849kБ.
Запись информации расширенных состояний... Готово
(Чтение базы данных... на данный момент установлено 387221 файлов и каталогов.)
Удаляется пакет foo2zjs...
Обрабатываются триггеры для man-db ...
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях
Инициализация состояний пакетов... Готово
Запись информации расширенных состояний... Готово
val-amart@io:~$

val-amart ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.