LINUX.ORG.RU

В Ubuntu 15.10 будет прекращена поставка Python 2 по умолчанию

 , ,


1

1

Разработчики Ubuntu в грядущем релизе 15.10 решили отказаться от поставки Python 2.X в составе дистрибутива по умолчанию. В результате множество приложений требуют изменений чтобы работать в новой версии дистрибутива, а от некоторых было решено отказаться полностью.

>>> Подробности



Проверено: maxcom ()

Ждём баттхёрт убунтойдов, когда что-то сломается..

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

а как обстоят дела в дебиане? что там по умолчанию идет.

msgxx ()

Before leaving for PyCon and with 15.04 beta2 released, I had a look at removing Python2 from the desktop images.

В Ubuntu 15.10 будет прекращена поддержка Python 2.X

Чего так слабо? Пиши «Canonical закрылась».

aidan ★★★★ ()

И как теперь с mercurial работать? Никак?

RevenantX ★★★ ()
Ответ на: комментарий от aidan

А тоесть таки просто по дефолту стоять не будет... Я думал они там совсем с ума посходили.

RevenantX ★★★ ()

Чую жопой, это как-о связано с перепилом всего и вся на третий пистон в Fedora 22...

И да, слишком жёлто. Фу.

nexfwall ★★★★ ()
Последнее исправление: nexfwall (всего исправлений: 1)

Before leaving for PyCon and with 15.04 beta2 released, I had a look at removing Python2 from the desktop images.

Ubuntu 15.10 to Finally Drop Python 2.X Support

В Ubuntu 15.10 будет прекращена поддержка Python 2.X

Регистранты окончательно деградировали.

anonymous ()
Ответ на: комментарий от msgxx

Идиотам, неспособным даже прочитать одно предложение на английском языке?

anonymous ()
Ответ на: комментарий от anonymous

Before leaving for PyCon and with 15.04 beta2 released, I had a look at removing Python2 from the desktop images.

Спасибо, желтизну из новости надо убрать.

unfo ★★★★★ ()
Ответ на: комментарий от unfo

Тогда в дело пойдёт знаменитое «ждём релиза».

anonymous ()

Арчик давно перешёл и нормально

GblGbl ★★★★★ ()

В репах-то останется, надеюсь?

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от sT331h0rs3

наверняка, просто устанавливать надо будет отдельно.

msgxx ()
Ответ на: комментарий от msgxx

Вчера поставил мартовский тестинг - в системе 2.7.9

yoghurt ★★★★★ ()

а от некоторых было решено отказаться полностью.

Почему я открыл рассылку и ничего про это не увидел в источнике?

anonymous ()
Ответ на: комментарий от anonymous

меня это тоже удивило, я был уверен что где-то это прочитал.

msgxx ()
Ответ на: комментарий от msgxx

я был уверен что где-то это прочитал.

Новости уровня Лора. Не хватает только пачки грамматических ошибок.

anonymous ()
Ответ на: комментарий от RevenantX

для работы mercurial НЕОБХОДИМ питон???
ффффууууууууууууу!!!
+100 в карму git только за то что это НОРМАЛЬНЫЙ софт, а не набор скриптятины

q11q11 ★★★★★ ()
Ответ на: комментарий от RevenantX

Написали про по-умолчанию. А так - ставь 2.x и крути hg. Мне тоже исключительно важно чтобы hg остался. Уверен, проблем не будет.

I-Love-Microsoft ★★★★★ ()
Ответ на: комментарий от q11q11

Ой вей... какой могучий интеллект. Типа mercurial не юзнает Си в критичных для скорости участках.

I-Love-Microsoft ★★★★★ ()
Ответ на: комментарий от msgxx

Вот это кстати интересный вопрос, ибо в последний раз мне пришлось ставить python ручками и там было 2 пакета на выбор python и python3. Но логически, если представить себе ситуацию в стиле «тэк, мне нужен питон значит: apt-get install python» по умолчанию будет python 2.7.

t500s ★★ ()
Последнее исправление: t500s (всего исправлений: 1)

пыхтонопроблемы. хоть 2, хоть 3 — одинаково ненужно.

anonymous ()
Ответ на: комментарий от GblGbl

Арчик давно перешёл и нормально

В то время, как всякие «слоупоки» из Федоры и Арча занимаются портированием софта на третий питон, в деревне Вилариба просто поменяли симлинк с python2 на python3 и радуются как дети.

anonymous ()

Вангую выкидывание в 16.04 GTK2, а в 16.10 — X.Org. Ачо, это ж бубунта.

MiniRoboDancer ★☆ ()
Ответ на: комментарий от anonymous

в деревне Вилариба просто поменяли симлинк с python2 на python3 и радуются как дети.

аха щаззз, непрокатывает твой финт ушами. В вашей деревне просто обкурились все, вот и радуются.

irton ★★★★ ()
Ответ на: комментарий от anonymous

На этом ненужно на гню больше десктопного софта, чем на прочем ненужно. Причём выглядит это ненужно абсолютно нативно за счёт нормальных биндингов к тулкитам, от сишко/плюсо/валесофта не отличить. Всякие лазари/гамбасы/моно с этим слегка косячат, про жабу/винапи и говорить нечего, на рубях/лиспах/жабоскрипте десктопного софта вообще не встречал, у тикля свой православный тулкит. Кого забыл ещё?

MiniRoboDancer ★☆ ()

Вот и накрылась Убунта RIP'цом. Тихо и незаметно.

dexpl ★★★★★ ()

множество приложений требуют изменений чтобы работать

Так это же просто решается, перекомпилировать под Python3 да и всё.

queen3 ★★★★★ ()
Последнее исправление: queen3 (всего исправлений: 1)
Ответ на: комментарий от msgxx

С чего бы это?

Традиционный комментарий к новости об удалении чего-либо откуда-либо.

dexpl ★★★★★ ()
Ответ на: комментарий от queen3

Так это же просто решается

Да, переломать руки разработчикам, которые пишут приложения, что работают только под python2.

anonymous ()
Ответ на: комментарий от q11q11

+100 в карму git только за то что это НОРМАЛЬНЫЙ софт, а не набор скриптятины

А про килограммы перлоскриптов ты тактично решил не упоминать?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.