LINUX.ORG.RU

Обнаружена новая уязвимость в Adobe Flash и Adobe Reader

 , , , , ,


0

0

Во всех версия Adobe Flash 9.x и 10.x, а так же в Reader и Acrobat версии 9.x обнаружена уязвимость, приводящая к падению плагина и, потенциально, к получению контроля над системой.

Всем пользователям Flash рекомендуется обновиться до последнего пререлиза версии 10.1.

>>> Подробности

★★★★★

Ответ на: комментарий от pevzi

Правда в ff не работает (:

У вас какой-то неправильный ff. УМВР.

libfun ()

где-то читал, что photoshop изначально был программой для создания матовых текстур, было давно и неправда... лучше бы они этим и ограничились

n01r ★★ ()
Ответ на: комментарий от anonymous

> а все прогрессивное человечество давно на Опере.

До сих пор прогрессируете? Насколько оно прогрессивнее более прогрессивных Chrome 6 и Safari 5? :-)

pythonist ()
Ответ на: комментарий от pevzi

я использую - как основной браузер - оперу. Про флеш блок знаю.

male66 ()
Ответ на: комментарий от male66

я использую - как основной браузер - оперу

Сочувствую? По работе заставляют или вы из идейных?

RealSiberianMan ()
Ответ на: комментарий от RealSiberianMan

Сочувствую? По работе заставляют или вы из идейных?

да как то не сложилось у меня с огнелисом - несколько раз пытался перейти - все в нем мне не так - карма короче :)

male66 ()
Ответ на: комментарий от mipt_student

> У меня этот плеер жрет не меньше, чем флэш.

Давно можно было бы съэкономить на школьных завтраках и слезть с 386-го.

slaka ()

Хотел было обновиться... где фикс для x86-64?! Уроды.

Jayrome ★★★★★ ()
Ответ на: комментарий от laraspil

Говорят в IE не тормозит благодаря ActiveX... Сам не проверял.

Yareg ★★★ ()

Многие сайты используют Flash для воспроизведения музыки. Думаю, все хоть раз видели, как реализовано воспроизведение музыки В Контакте (минимум flash - большая часть функционала плеера на JavaScript).

Поэтому хочу задать вопрос знающим: а Java аплеты могли бы заменить Flash В Контакте (для аудиозаписей)? И есть ли в этом смысл (как там с ресурсами)? Какие вообще технологии для прослушивания музыки были доступны человечеству до прихода HTML5 кроме flash?

inst ()

Ну реально задолбали уже, всё время какие-то дыры. Такое чувство, что все хорошие программисты из Адоба разбежались лет семь-десять назад и они теперь нанимают индусов за сдельщину, потом кидают их и нанимают новых.

А ведь когда-то разрабатывали полезные и качественные вещи, PostScript, например.

Vudod ★★★★★ ()
Ответ на: комментарий от inst

Его сможет заменить <audio> когда оно будет…

Deleted ()
Ответ на: комментарий от bbk123

>Он вообще работает?

Нет. Он придумал для того, чтобы хвастаться на LOR-е.

Sociopsih ★☆ ()
Ответ на: комментарий от Sociopsih

>Нет. Он придуман для того, чтобы хвастаться на LOR-е.

fixed

Sociopsih ★☆ ()
Ответ на: комментарий от solid

>Мне больше интересно, в чём заключается проблема компиляции 64битной версии из тех же сорцов. Ассемблерные вставки?

Судя по скорости работы, там ассемблерными вставками и не пахнет.

anonymous ()

У меня такое ощущение, что не так ценен фикс бага, как шумиха вокруг него. Ведь если это просто «улучшение работы», кто это заметит? А так - «уязвимость», «дыра», «вирусы» - бац, уже в трамвае разговоры: «Маньк, слышь, ты абоде реадер обновила? Грят, хвирус нашли - он, окаянный, пенсию поедает!». Так и держится на плаву позорная фирма - плодитель монстров.
А у меня Foxit Reader (3.2) - работает как молния и не жужжит. Под оффтопик, конечно.

matumba ★★★★★ ()
Ответ на: комментарий от anonymous

> Судя по скорости работы, там ассемблерными вставками и не пахнет.

Просто эти вставки в окне About. :)

matumba ★★★★★ ()
Ответ на: комментарий от male66

> у меня огнелис с флешем, а опера без - вот использую в основном оперу - только если нужно чтобы флеш работал - запускаю огнелис..

+1. Только вместо фокса - SRWare Iron. :)

matumba ★★★★★ ()
Ответ на: комментарий от anonymous

А если серьезно, то действительно возникает такой вопрос.
Я вижу только две причины, по которым может существовать версия для x86 и отсутствовать для amd64:
1) Платформозависимые вещи, такие как ассемблерные вставки, быдлокод или генерация исполняемого кода
2) Лень или синдром вахтёра.

solid ()

Судя по треду...

...школота негодуэ и извергает лучи. :)


Ну в принцыпе чего от нее еще ждать :)

yaws ()

Ох уж эти проприетарщики, всё им новое и новое, да насильно. Мы ещё старыми уязвимостями не наигрались, а нас уже пересаживают на новые.

anonymous ()

>уязвимость в Adobe Flash и Adobe Reader

через сколько месяцев будут обновления?

anonymous ()

>рекомендуется обновиться до последного пререлиза версии 10.1

пререлиза


Это такое тонкое издевательство? Типо или стабильная версия с дырой, или нестабильная, где нету известных дыр, но есть известные баги

goingUp ★★★★★ ()
Ответ на: комментарий от plm

>А кто знает, заяву на загранпаспорт уже можно заполнить каким-нибудь открытым pdf-ридером?

У меня с помощью evince получилось ^^

Lucky1 ★★★ ()

Ну собственно это был лишь вопрос времени.
Закрытый софт непредсказуем.

Эксплойта на сайте не нашел, вдруг они просто хотят втроянить новую версию с улучшеным спаймодулем?

anonymous ()
Ответ на: комментарий от plm

>>А кто знает, заяву на загранпаспорт уже можно заполнить каким-нибудь открытым pdf-ридером?

отмените лучше этот бред - загранпаспорта, тогда ничего заполнять не надо ;)

По теме - последние Okular и evince умеют заполнять формы

alex_custov ★★★★★ ()
Ответ на: комментарий от mipt_student

Странно. Запустил и с удивлением обнаружил, что html5 не жрёт вообще. Даже при прокрутке страницы с играющим видео.

А вот gnash тормозит изо всех сил.

Соответственно x86_64, Chromium nightly, свежий adobe flash и свежий gnash.

ifred ()
Ответ на: комментарий от pevzi

>Прогрессивное человечество — это 5% от всего населения земли? Улыбнуло.

ПРОГРЕССИВНОЕ. В состоянии от 100% отнять 95% ?

anonymous ()

>Всем пользователям Flash рекомендуется обновиться до последного пререлиза версии 10.1

Это такое очередное FUCK YOU пользователям amd64. 10.1 была выпущена в ноябре 2009-го, а 64-битой версии всё ещё нет.

Gary ★★★★★ ()
Ответ на: комментарий от inst

> Думаю, все хоть раз видели, как реализовано воспроизведение музыки В Контакте

Ваши убеждения меня поражают

laraspil ()

Столько времени PDF с Flash'ем пилят, а все равно пилить не умеют. Позорище.

P.S. Не думал, что их обоих пишут одни и те же люди (имеются в виду группы программистов).

Rezo ()
Ответ на: комментарий от laraspil

При чём тут убеждения? Я спрашиваю, на Java аплетах можно написать плеер для музыки, как это делают на Flash'е или нет? Сколько на это надо памяти? Мне кажется, без html5 flash всё-таки нужен.

inst ()
Ответ на: комментарий от inst

>плеер для музыки
Не проще ли старый добрый <embed>?

x3al ★★★★★ ()
Ответ на: комментарий от inst

При помощи JavaScript и <video>/<audio> можно даже интерфейс вроде audacious'а нарисовать :)

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от xscrew

>Линупсоиды такие линупсоиды. Всем линупс на десктопы!

Тролли такие тролли... затроллить весь лор!

anonymous ()
Ответ на: комментарий от Eddy_Em

audacious не нужен.

Сотый раз повторяю: <video>/<audio> - HTML5. Его ещё не все поддерживают.

inst ()
Ответ на: комментарий от inst

Даже в быдлоконтакте давно в хтмл5 вещают. Внезапно!

Lordwind ★★★★★ ()
Ответ на: комментарий от inst

Его ещё не все поддерживают.

Кто не поддерживает? Неужели, в опере до сих пор нет поддержки html5? Что-то не верится. А в наиболее популярных браузерах она уже давно есть (правда, не на 100%, но <video> и <audio> есть).

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от inst

И как им потом рулить из скриптов?

Функции play/pause для проигрывания/приостановки; свойство currentTime - для перемотки :)

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от inst

>И как им потом рулить из скриптов?
Зачем рулить плеером из скриптов если аудио уже передалось полноценному плееру?
Ненавижу веб2.0щиков за попытки изобрести велосипед с треугольными колёсами.

x3al ★★★★★ ()
Ответ на: комментарий от Eddy_Em

Ну, и на том спасибо =) А для громкости нету свойства?

inst ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.