LINUX.ORG.RU

Alma Linux 8.6

 , ,


0

1

Вышел релиз Alma Linux 8.6 — дистрибутива, полностью бинарно совместимого с RHEL 8.6, вышедшим вчера. Дистрибутив доступен для архитектур x86_64, aarch64, ppc64le, s390x. Дистрибутив c помощью соответствующих скриптов для миграции может использоваться для замены CentOS 8.5, сопровождение которого было прекращено в конце 2021 года.

Дистрибутив распространяется бесплатно, в том числе и на различных зеркалах, а также имеет собственную коммерческую поддержку. Список изменений аналогичен списку изменений RHEL 8.6.

>>> Пруфлинк

Не вышел релиз Cocucka Linux 8.6 – дистрибутива, вообще не совместимого с RHEL 8.6, вышедшим вчера. По заявлениям основателя и основного разработчика дистрибутива, релиз не состоялся потому, что cocucka вертел RedHat и все его клоны и осью вращения был его детородный орган.

cocucka ★★★★★ ()
Ответ на: комментарий от apt_install_lrzsz

И так не нужно. Но выполнение ваших, тоже ненужных желаний, зависит не от авторов дистрибутива. Сейчас последняя версия Rust - 1.60.0. Значит, вы угрожаете, что не будете программировать , пока не появится Rust 2? Ну, не программируйте, что ли.

Partisan ★★★ ()
Ответ на: комментарий от Partisan

Я говорю конкретно о невышедшем релизе Cocucka Linux.

Значит, вы угрожаете, что не будете программировать , пока не появится Rust 2?

Ничего подобного в моём сообщении нет.

Уверен ли ты, что не находился в состоянии изменённого сознания, когда писал свой пост?

apt_install_lrzsz ()
Ответ на: комментарий от papin-aziat

Как там на альме? А то у меня что-то ихний скрипт для перехода с Centos Stream 8 не работает ни в какую, сразу вылетает с руганью.

Впрочем, всё равно 2024 года буду ждать :)

Mamluk ()
Ответ на: комментарий от Mamluk

Как там на альме?

Все ровно, никакой отсебятины там нет.

А то у меня что-то ихний скрипт для перехода с Centos Stream 8 не работает ни в какую, сразу вылетает с руганью.

Я поэкспериментировал немного с этими скриптами, да и поставил с нуля: кажись чисто они не работают.

papin-aziat ★★★★★ ()
Ответ на: комментарий от papin-aziat

Вариант не прокатит с нуля. Ибо придётся много перенастраивать и доустанавливать. А я сейчас не смогу физически. Увы.

Mamluk ()
Ответ на: комментарий от Mamluk

Да ладно. Флешку воткнул или в облако и потихоньку, не торопясь, закидываешь туда всякие файлы настроек, не так уж много окажется. А важные данные, они же где-то бекапятся, тут и думать не надо.

papin-aziat ★★★★★ ()

У меня складывается впечатление, что в борьбе клонов побеждает Rocky. Недавно была новость о поддержке со стороны Autodesk Maya, про альму ни слова. Датапоинтов конечно немного, но оно ведь ведь как лавина всегда

Midael ★★★★★ ()
Ответ на: комментарий от Midael

У меня складывается впечатление, что в борьбе клонов побеждает Rocky.

Я не смог этот рокки поставить в уефи режиме, вот тебе и bug-to-bug rhel. Альма же, как я понял, всё делает оперативнее всех: опыт клонирования рхел больше 10-ти лет (CloudLinux) и миллион бакинских ежегодно на альму.

papin-aziat ★★★★★ ()
Ответ на: комментарий от papin-aziat

Именно стрим. Но есть ещё и много субъективных причин. Которые выходят за рамки этого форума, да и просто я не хочу о них говорить…

Кто долго сидел в комнате fedora, тот поймёт. Ник то у меня тот же.

Mamluk ()

Вышли первыми, а исходники (src.rpm) до сих пор не выложили :(
Rocky и Oracle вышли сразу с исходниками.

arson ★★★★★ ()
Ответ на: комментарий от arson

а исходники (src.rpm) до сих пор не выложили

Нашел! Если в 8.5 и 9-beta лежат в общей репе, то для 8.6 только отдельно:
rsync://rsync.repo.almalinux.org/almalinux-vault/8.6/ или http://repo.almalinux.org/vault/8.6/

Туда же перенесли debug, а таж же там есть i686 !
Без ядра и iso-шников, но много. Похоже можно сделать i686-дистр с x86_64 (или своим) ядром.

arson ★★★★★ ()
Ответ на: комментарий от arson

Похоже можно сделать i686-дистр с x86_64 (или своим) ядром.

Можно! Подсунул установщику i686-репы (ссылки выше) и x86_64-ядро, и поставил (пока minimal в виртуалку).

Похоже Alma решила выпустить 32-битный «RHEL»

Пакеты собраны почти все (пары сотен позиций не хватает). Не хватает:

  • ядра и grub-efi (syslinux-efi64 - тоже нет, grub2-pc - есть)
  • некоторых вроде и не обязательных утилит, но их тащит установщик: kexec-tools, podman, cockpit …
  • приложений: firefox, thunderbird, qemu
  • development: dotnet/aspnetcore, eclipse, golang, java-17-openjdk, python38/python39 (только python36)
  • чисто 64-битных либ: blas64, lapack64, openblas-*64, metis64
  • прочее, по мелочи.

Проблемы:

  • grub2-pc (не efi) ставить пришлось вручную.
  • В anaconda-е (установщике) нет опции игнорирования несуществующих пакетов, так что или ставить с помощью kickstart.cfg, или править группы пакетов (файл *comps*.xml в repodata)
  • Пока не разобрался с dnf-модулями, информация о модулях где-то затерялась (ошибка при установке: No available modular metadata…)
arson ★★★★★ ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей