LINUX.ORG.RU

Редактор Unity теперь официально поддерживает Linux

 , ,


2

1

Представлен официальный билд редактора Unity под Linux. Дистрибутив поставляется в виде .deb-пакета или скрипта «все-в-одном», который работает независимо от типа операционной системы. Рекомендуемая конфигурация:

  1. Ubuntu 16.04, 18.04 или CentOS 7;
  2. архитектура x86/64;
  3. рабочая среда gnome с X Window System;
  4. графические драйверы Nvidia или AMD Mesa.

>>> Подробности

★★★★★

Проверено: Shaman007 ()

Вы хоть уточняйте, что это за редактор. Это видео-редактор?

Windows ()

Кстати, а как в свете ОП deb пакет накатить на центось?

bvn13 ★★★★★ ()

не прошло и 10 лет, что не может не радовать

slackwarrior ★★★★★ ()
Ответ на: комментарий от ozz_is_here_again

Это не он, а разработчики. Она столько лет была в статусе беты.

te111011010 ()

Ну... ок.

К сожалению, Linux не поддерживает Epic Games Store, из-за чего начавший было развиваться пингвиногейминг скатывается обратно к тукс рейсерам (проекты бегут из Steam).

duott ★★★★★ ()

Вангую массовую миграцию unity разрабов на онтопик.

Призрак вендекапца ходит по индустрии!

Mamin_simpotyaga ()
Ответ на: комментарий от duott

Linux не поддерживает Epic Games Store

Может, это Epic Games Store не поддерживает Linux?

проекты бегут из Steam

Кто-то ещё убежал, кроме последнего Метро?

hobbit ★★★★★ ()

или скрипта «все-в-одном», который работает независимо от типа операционной системы.

Это что за скрипт такой? Типа как флатпак?

Odalist ★★★★★ ()
Ответ на: комментарий от Odalist

Линуксовую проприетарщину в таких скриптах распространяли задолго до флатпака. Вначале идёт скрипт, потом бинарник.

hobbit ★★★★★ ()

А в целом новость позитивная. Следующий шаг — кто-нибудь этой проприетарщиной попользуется, да и напишет свободный аналог.

hobbit ★★★★★ ()
Ответ на: комментарий от duott

Может все наоборот? Лицензия проприетарная, как сторонний разработчик напишет клиент для задрипанного магазинчика в котором даже сортировки по жанрам нету поскольку игорь всего пара десятков штук.

A-234 ★★★★★ ()
Последнее исправление: A-234 (всего исправлений: 1)
Ответ на: комментарий от bvn13

А зачем? Юнити хаб на флатхабе есть. Через него и поставить.

turtle_bazon ★★★ ()
Ответ на: комментарий от hobbit

Зачем, простите, нужен свободный аналог редактора для несвободной платформы?

Не хотите же вы сказать, что кто-то будет сам юнити опенсорсно переписывать, не?

YogSagot ★★ ()
Ответ на: комментарий от hobbit

Кто-то ещё убежал, кроме последнего Метро?

Что там с краудфандовым Phoenix Point?

question4 ★★★★★ ()
Ответ на: комментарий от YogSagot

свободный аналог редактора для несвободной платформы

Нет, конечно.

Я, конечно, имел в виду «свободный движок со своим свободным редактором, по возможностям аналогичный сабжу».

Вроде бы, Urho3D и Godot на что-то такое претендовали...

hobbit ★★★★★ ()

еще бы сабстансы были бы под онтопик, и всё, вендекапец тогда бы

sid350 ★★★★★ ()
Ответ на: комментарий от question4

эти вообще всех кинули, и стим, и линукс. принципиально буду только с торрентов качать. хотя в стиме обещали через год после эпиков

daminatorus ()
Последнее исправление: daminatorus (всего исправлений: 1)
Ответ на: комментарий от question4

Что там с краудфандовым Phoenix Point?

Это которые обманули своих бэкеров? Интересно, неужели в их поступке нет состава преступления? Ведь они обещали релиз в Стиме, а вышли в помойке. Они отмазываются только тем, что в помойке временная эксклюзивность?

Ну и да, один клон X-Com – это не «все бегут». Это «несколько инди побоялись затеряется на фоне сотен аналогов и решили попиарится на скандале вокруг фортнайт лаунчера».

anonymous ()

поставил глянуть. это какой-то ужас в плане интерфейса. я пожалуй на годоте останусь

daminatorus ()

В чем новость? Unity со статусом preview уже давно, в новой версии оно из preview так и не вышло.

anonymous ()

Прочитал в их блоге, теперь под юнити будет физический движок хавок! Это что, нормальные игры под юнити появятся?

koshmar ★★★ ()
Ответ на: комментарий от daminatorus

эти вообще всех кинули, и стим, и линукс. принципиально буду только с торрентов качать. хотя в стиме обещали через год после эпиков

Ахаха, принципиальный. Принципиально — это игнор. А так клиент в виде пирата, лучше чем вообще отсутствие его.

fornlr ★★★★★ ()
Ответ на: комментарий от sid350

еще бы сабстансы были бы под онтопик

Ну они ещё пока вроде есть, пейнтер и дизайнер. И даже алхимик. Или уже всё, прикрыли лавочку?

MageasteR ★★★★★ ()
Последнее исправление: MageasteR (всего исправлений: 1)
Ответ на: комментарий от hobbit

Может, это Epic Games Store не поддерживает Linux?

Я это и имел в виду. С дополнениями в винительном падеже одинаково звучит :)

Кто-то ещё убежал, кроме последнего Метро?

Ну, не с такой громкой историей, что прям перебегают в последний момент. Но выходят или анонсируются там, а не на Стим. За последнее время очень много проектов, лучше погуглить.

duott ★★★★★ ()
Ответ на: комментарий от A-234

Оба варианта в русском языке с двумя несклоняемыми существительными одинаково звучат :) Магазин не поддерживает операционную систему

duott ★★★★★ ()
Ответ на: комментарий от hobbit

Кто-то ещё убежал, кроме последнего Метро?

Rocket League.

MageasteR ★★★★★ ()
Ответ на: комментарий от hobbit

Urho3D

Мертв.

Godot

Ждем! А вообще мне эти движки все ненравятся, сделали бы аналог Leadwerks Game Engine, чтоб с подобием Hammer Editor, ух...

VarfolomeyKote4ka ()

Функционал такой же как и под Windows? И шарп можно полноценно использовать, там нет кор или моно? Или жс придется?

cr0 ()
Ответ на: комментарий от cr0

Функционал такой же как и под Windows?

Scriptable Render Pipeline через одно место сделан был, может что-то улучшилось уже.

MageasteR ★★★★★ ()
Ответ на: комментарий от daminatorus

принципиально буду только с торрентов качать

Может, тогда вообще не качать?

hobbit ★★★★★ ()
Ответ на: комментарий от cr0

Хз, я под оффтопиком его толком не пользовал, не могу детально сравнивать. Но SRP на онтопике работает только на одну треть: LWRP практически нерабочий, HDRP требует только Vulkan и работает только на невидиях с проприетарными дровами.

MageasteR ★★★★★ ()
Ответ на: комментарий от bvn13

Это менеджер версий юнити и кое-что ещё. Просто ставишь, жмёшь кнопку рядом с нужной версией и всё. Никакого пердолинга с репами и пакетами.

ozz_is_here_again ★★ ()
Ответ на: комментарий от duott

Магазин не поддерживает операционную систему

Ну у тебя тогда получилось «операционную систему не поддерживает магазин». Для магистра Йоды нормальная формулировка, в устах гуманоидов с толку сбивает же.

hobbit ★★★★★ ()
Ответ на: комментарий от VarfolomeyKote4ka

Мертв.

Последний коммит May 22, 2019. Если это «мёртв», то я не знаю.

Ждем!

А чего там ещё не дождались?

hobbit ★★★★★ ()

Как же собирались десятки игр на движке Unity в Ubuntu 12.04, если минимально поддерживается 16.04?

anonymous ()

теперь я могу захерачить свою циву на юнити?

darkenshvein ★★★★★ ()
Ответ на: комментарий от hobbit

Последний коммит May 22, 2019. Если это «мёртв», то я не знаю.

Лол...

А чего там ещё не дождались?

Сыренько по отзывам чужим.

VarfolomeyKote4ka ()
Ответ на: комментарий от anonymous

Как же собирались десятки игр на движке Unity в Ubuntu 12.04, если минимально поддерживается 16.04?

Ты разницу между «игры собирались васянами на свой страх и риск» и «официально поддерживается разработчиками движка» вообще не ощущаешь?

MageasteR ★★★★★ ()
Ответ на: комментарий от anonymous

один клон X-Com – это не «все бегут».

Это не просто клон, а самый многообещающий клон, написанный автором оригинала. Мне он был куда интереснее нового Метро.

question4 ★★★★★ ()
Ответ на: комментарий от hobbit

Не развивается движок уже, это скорее мелкие фиксы от сообщества, основные люди на него забили, а там надо заменять мультиплеерную часть всю к примеру, там какая то дичь, а было в планах вставить RakNet, но уже все...

VarfolomeyKote4ka ()
Ответ на: комментарий от duott

К сожалению, Linux не поддерживает Epic Games Store

Наоборот, Epic Games Store не умеет в Linux

проекты бегут из Steam

Целых один! Не драматизируй никто не бежит. А те кто уходят тупо продаются, ну буквально им за уход деньги платят.

LINUX-ORG-RU ()
Ответ на: комментарий от LINUX-ORG-RU

Наоборот, Epic Games Store не умеет в Linux

Чому, этож линукс должен программы запускать %)

VarfolomeyKote4ka ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.