LINUX.ORG.RU

Debian 9.7

 , ,


1

3

Вышла новая версия дистрибутива Debian 9.7.

Изменения:

  • Внесены исправления в пакет base-files.
  • Устранена опасная уязвимость CVE-2019-3462 в apt, благодаря которой злоумышленник мог подменить оригинальный пакет через http redirect.

>>> Подробности

★★★★

Проверено: jollheef ()

Debian 9.7

Никогда такого не было и вот опять:

# apt-get install nginx
...
...
...
Setting up nginx-full (1.10.3-1+deb9u2) ...
Job for nginx.service failed because the control process exited with error code.
...
...
...
  Package nginx-full is not configured yet.
  Package nginx-light is not installed.
  Package nginx-extras is not installed.

# apt-get install nginx-light nginx-extras
...
...
...
The following packages have unmet dependencies:
 nginx-extras : Conflicts: nginx-light but 1.10.3-1+deb9u2 is to be installed
 nginx-light : Conflicts: nginx-extras but 1.10.3-1+deb9u2 is to be installed
E: Unable to correct problems, you have held broken packages.

deep-purple ★★★★★ ()
Ответ на: комментарий от deep-purple

nginx-full, nginx-light, nginx-extras — это три разных варианта установки nginx. Вместе их ставить не имеет никакого смысла, поэтому их сделали конфликтующими друг с другом. По умоллчанию ставится nginx-full. Почему он не запустился, надо разбираться (может у тебя другой сервер занял порты, мало ли).

TeopeTuK ★★ ()
Ответ на: комментарий от TeopeTuK

Нет, я просто запустил инсталл нжинкс, а не нжинкс-чтототамещё. А оно мне выдало это говнецо. На то что он не стартанул не обращай внимания, проблема в конфликтах пакетов.

deep-purple ★★★★★ ()
Ответ на: комментарий от deep-purple

Ты просто не понял, что тебе выдали. Пакет nginx это метапакет, который по зависимости устанавливает один из трех — nginx-full, nginx-light или nginx-extras. По умолчанию это nginx-full. Он и устанавливался. И не смог, так как что-то помешало демону запуститься. И вместо того, чтобы понять, что происходит, и настроить-таки этот пакет, ты начал паниковать и устанавливать nginx-light и nginx-extras, да еще и одновременно. Не делай так, и всё будет хорошо.

TeopeTuK ★★ ()
Ответ на: комментарий от anonymous

Можно было и матрёшкой, когда больший набор включает меньший. Но раз так не сделали, то значит не получается матрешкой — что-то конфликтует, например набор включенных модулей ил чё то тама, не суть важно именно что (у апача так бывает, особенно в связке со всяким говном типа isp).

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)

Кстати, про изменения в base-files в новостях никогда писать не следует. Там изменяется номер версии Debian. Это несущественное изменение.

TeopeTuK ★★ ()