LINUX.ORG.RU

Релиз универсального установщика Calamares 3.2

 ,


0

2

Состоялся релиз Calamares 3.2 - универсального и независящего от дистрибутива инструментария для построения установщиков системы. Calamares состоит из различных модулей, каждый из которых можно гибко настроить, или же написать свой на Python или C++. Calamares уже применяется в таких дистрибутивах как Manjaro, OpenMandriva, KDE Neon Unstable, KaOS, Chakra, Netrunner и Sabayon. Код проекта написан на языке C++ с использованием Qt5/QML, и распространяется по лицензии GPLv3. В новом выпуске:

  • Реализована поддержка повторяемых сборок;
  • Добавлен модуль Plasma LNF (Look-n-Feel), позволяющий интегрировать внешний вид установщика с общим оформлением в KDE Plasma;
  • Добавлен модуль shellprocess, позволяющий запускать на различных этапах работы установщика последовательность shell-команд;
  • Добавлен модуль contextualprocess, расширяющий модуль shellprocess набором масок, согласно которым будет запущена та или иная shell-последовательность. В настоящее время модуль имеет три маски - efi, bios и "", на основании которых устанавливается соответствующий загрузчик (grub-efi или grub-pc), либо производится очистка предустановочного пула (preinstalled-pool);
  • Улучшено определение раскладки клавиатуры на основании выбранного языка системы;
  • Убрана привязка к Bash;
  • Добавлен модуль openrcdmcryptcfg, применяющийся для установки на шифрованный раздел при использовании системы инициализации OpenRC;
  • В модуль bootloader добавлена настройка installEFIFallback, позволяющая управлять режимом установки при использовании UEFI;
  • Множество различных мелких улучшений.

>>> Подробности

Ответ на: комментарий от Einstok_Fair

Manjaro, OpenMandriva, KDE Neon Unstable, KaOS, Chakra, Netrunner и Sabayon

Вообще не вижу нужно в списке.

P.S. Хотя чья б корова мычала, сам на очередном болгеносе щас сижу и качаю свежую лису тар-архивом.

mandala ★★★ ()
Ответ на: комментарий от mandala

качаю свежую лису тар-архивом

Я также на дебиане делаю, ибо mozilla backports можно сказать RIP

Sunderland93 ★★★★★ ()
Ответ на: комментарий от Sunderland93

ну и отлично ! скачал распаковал нажал на «запускатор» чем ждать ебилды )) я тоже так делаю ,получается дебиан не протухший можно любую программу с сайта разработчика архивом качать и пользоваться.

zoloz ()
Ответ на: комментарий от Sunderland93

оказывается это все зеркала MX сломаны кроме корневого, прилетали обновы только с дебиана. Починил, прилетело родное.

mandala ★★★ ()
Ответ на: комментарий от upcFrost

На десктопчике MX_Linux, что лютая смесь AntiX, Debian stable, и собственно MX, приправленное deb-multimedia (опционально, но репа прописана, хоть и деактивирована из коробки). А на сервачках фряха, да.

mandala ★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от mandala

То есть свежий Firefox прилетает с репов MX? Круто, надо будет заюзать его с Pin-Priority

Sunderland93 ★★★★★ ()
Ответ на: комментарий от Sunderland93

Как я понимаю они просто пакетят офф.билд, но тоже намного удобнее чем тар-архивом таскать.

mandala ★★★ ()
Ответ на: комментарий от Sunderland93

Забыл рабочую репу дать:

cat /etc/apt/sources.list.d/mx.list

# MX Community Main and Test Repos
deb http://mxrepo.com/mx/repo/ stretch main non-free
deb http://mxrepo.com/mx/testrepo/ stretch test

mandala ★★★ ()
Ответ на: комментарий от Sunderland93

Так можно ж убунтовскую репу прямо от Мозиллы подключить. У меня в jessie работает.

anonymous ()
Ответ на: комментарий от anonymous

Так можно ж убунтовскую репу прямо от Мозиллы подключить. У меня в jessie работает.

Только потом по форумам не плачьте, что что-то поломалось.

Odalist ★★★★★ ()
Ответ на: комментарий от zoloz

получается дебиан не протухший frankendebian
можно любую программу с сайта разработчика архивом качать и пользоваться.

Fixed. Не благодари.

Odalist ★★★★★ ()
Ответ на: комментарий от Odalist

Можно вообще любой дистр превратить в слаку.

mandala ★★★ ()
Ответ на: комментарий от Odalist

нет ,так должно быть ,а не фапать на версии пакетиков ,совместимость ,зависимости. Это так сказать хороший тон - без мазохизма присутствующего в большинстве линуксов и прочего васянского поделия.

zoloz ()
Ответ на: комментарий от mandala

А что, MX уже с jessie на stretch переехал? К слову, у меня к stretch прикручен репозиторий от MX 15, но со сниженным приоритетом. Я оттуда только ядро liquorix ставил.

PVOzerski ★★ ()
Последнее исправление: PVOzerski (всего исправлений: 1)
Ответ на: комментарий от Odalist

А что поломается-то? На убунтузилле лежат пакеты с браузерами и почтовыми клиентами, не тянущие за собой никаких дополнительных зависимостей из своего репозитория. Т.е. максимум что может случиться — не заработает сам файрфокс. Но на самом деле всё работает.

PVOzerski ★★ ()
Ответ на: комментарий от PVOzerski

К чему такие сложности? Фаерфокс можно и с официального сайта скачать, еще подключать сторонние репы

anonymous ()
Ответ на: комментарий от PVOzerski

Да, переехал, не очень давно, пару месяцев может.

mandala ★★★ ()
Ответ на: комментарий от anonymous

Качать еще, фи. А тут пм сам качает, распаковывает, кладет куда надо.

mandala ★★★ ()
Ответ на: комментарий от PVOzerski

А что поломается-то?

Читай тут.

Т.е. максимум что может случиться — не заработает сам файрфокс. Но на самом деле всё работает.

До поры, до времени. Но это ваша система. Что хотите, то делайте. Вы такой не первый. Каждый Дебиановский новичок должен пройти через это...

Odalist ★★★★★ ()
Ответ на: комментарий от Odalist

Да резонно это все, конечно - только ведь голова-то на плечах быть как бы тоже может... Что мешает перед тем, как согласиться с каким-нибудь apt install, посмотреть, какие ещё пакеты этот менеджер собирается подтянуть? Тянет либы - отказываемся от установки, не тянет - ставим. Считаем, что это разовое везение - дык для предотвращения последующих подозрительных обновлений есть apt-mark hold. А если конкретно - то, например, у меня стоят zip и unzip из фроловского ppa, а ещё файрфокс и симанки от убунтузиллы. Поставил именно потому, что пакеты при установке ничего системного, замещающего собой родное дебиановское, за собой не тянули. Зато вот когда попробовал обновить gimp до последней версии из стороннего репозитория на software.opensuse.org... Вот вроде же написано, что для stretch - а тянет за собой кучу замещающих либ и чуть ли не другую версию иксов. Посмотрел я и сказал: а оно мне надо? И решил, что не очень:)

PVOzerski ★★ ()
Последнее исправление: PVOzerski (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.