LINUX.ORG.RU

ReactOS 0.4.5

 , ,


1

2

18 мая 2017 года в свет вышел новый релиз ReactOS под номером 0.4.5, и за 5 дней его скачали почти 30 000 раз с официальных зеркал.

За три месяца с прошедшего релиза было исправлено 179 ошибок. Главным нововведением стала поддержка Microsoft Office 2010. Для экспериментов с ним нужно поставить специальную версию Samba из менеджера приложений.

Большое внимание уделено усовершенствованию интерфейса системы, значительно улучшена обработка кириллических и азиатских шрифтов, устранены почти все ранее присутствовавшие недоработки в движке тем оформления. Кроме того, активирована функция выбора используемого бэкенда OpenGL, а в менеджер загрузок добавлена актуальная версия Mesa 3D.

Известные проблемы

Для наиболее продуктивных экспериментов в виртуальных средах не используйте более 90 Мб видеопамяти, а на реальных компьютерах полностью отключайте многоканальные звуковые карты. ReactOS также пока не переваривает конфигурации с более чем одной звуковой картой, по возможности старайтесь их избегать.

Разработчик Вадим Галянт подготовил специальную версию дистрибутива, которая поддерживает загрузку через USB.

Официальная новость

Список изменений

Альтернативный список изменений

>>> Страница загрузки

Ответ на: комментарий от anonymous

по-твоему, лучше наоборот, в линукс <= винду

Некоторым это позволит жить без виртуалок. Лично я думаю что лучше иметь легковесный контейнер чем виртуалку.

NextGenenration ★★ ()
Ответ на: комментарий от xmikex

на usb кидать правильно

USB?

ну ты приколист!

по старинке пиши образ на СД и загружайся с сидюка! :)

anonymous ()
Ответ на: комментарий от Quasar

Не понимаю в чём проблема. Здесь много кто постит новости о том проекте, к которому имеет отношение. И это гораздо лучше, чем новость о каком-то проекте какого-нибудь рандомного наркомана, который ни строчки исходников оттуда не видел и вовсе не разбирается.

a1batross ★★★★★ ()
Ответ на: комментарий от Jedi-to-be

загрузка за 7 минут тогда будет же. это очень долго.

xmikex ★★★ ()

для кого пилится это говно? шоб офис запускать? так офис надо покупать. старье поддерживать? для этого есть виртуалки со старыми версиями шинды.

anonymous ()
Ответ на: комментарий от NextGenenration

Хоть вызов компилятора найдёшь?

Склероз лечи. В сообщениях выше названия компиляторов присутствовали.

Napilnik ★★★★★ ()
Ответ на: комментарий от NextGenenration

Как это поможет если повредить grub?

Элементарно, Ватсон. Прописываешь в груб линукса Б запуск линукса А пока А таким грубом не запустится. После чего загружаешь линукс А и переустанавливаешь его груб. ПК для этого должен иметь больше одного винта.

Napilnik ★★★★★ ()
Ответ на: комментарий от anonymous

так офис надо покупать.

зачем? тебя на рутрекере забанили?

anonymous ()
Ответ на: комментарий от xmikex

С чего вдруг 7 минут? Ты не попробовал, а говоришь. Это абсолютно индивидуально зависит от железки.

Jedi-to-be ★★★ ()
Ответ на: комментарий от anonymous

для кого пилится это говно?



Чтобы продавать кирпичи и веспен-газ, которым начинают срать анонимы после каждой новости о РеактОС.

Jedi-to-be ★★★ ()
Ответ на: комментарий от Jedi-to-be

говно

срать

О, великолепно! Коротко и по теме

Вся суть реактоси в двух словах :)

anonymous ()
Ответ на: комментарий от anonymous

Проблема в том, что я не боюсь высказываться от своего имени, а ты лишь отзвук взрыва болотной кочки.

Jedi-to-be ★★★ ()
Ответ на: комментарий от anonymous

У меня рутрекер редиректит на сайт провайдера.
Или такая ошибка:

Resource is blocked

Sorry, but requested content was blocked.

ne-vlezay ★★★★★ ()
Последнее исправление: ne-vlezay (всего исправлений: 1)
Ответ на: комментарий от Napilnik

Тем более если у тебя больше одного винта. Поставь не в виртуалку а на второй винт. И наслаждайся перезагрузкой ради сканнирования. Хотя стоп, там же тоже дров нет

NextGenenration ★★ ()
Ответ на: комментарий от NextGenenration

Хорошо. Ты вроде говорил что в fpc можешь в статическую компиляцию?

Могу, если не использую звуковую подсистему, гэтэкашные гуёвины, графические движки и подобные прибамбасы. Как ты можешь догадаться, не всегда без прибамбасов можно обойтись, и вот они что-то тянут динамически, хотя и в ограниченном объёме. Такого ужаса как в С++, когда в системе есть libc.so.6 но программе нужна не она а libc.so.6 версии 2_14, в fpc не замечал.

Napilnik ★★★★★ ()
Ответ на: комментарий от NextGenenration

То есть не можешь.

То есть в ряде случаев могу. Приложения без гытыка морды тоже нужны.

Napilnik ★★★★★ ()
Ответ на: комментарий от NextGenenration

-Fl<x> Add <x> to library path
-Fo<x> Add <x> to object path
-Fu<x> Add <x> to unit path

Napilnik ★★★★★ ()
Ответ на: комментарий от Napilnik

Тепрь осталось вытянуть пути из скрипта, а по путям узнать пакеты.

NextGenenration ★★ ()
Ответ на: комментарий от Jedi-to-be

Проблема в том, что я

На этом можно остановиться.

Именно ты и такие как ты «пиарщики» и есть основная проблема проекта.

Если более чем за двадцать лет оно так и не может установиться загрузиться на реальное (даже старое) железо, то возникает резонный вопрос.

От тебя сразу переход на личности и сортирное хамство.

Убого выглядишь, джеди

anonymous ()
Ответ на: комментарий от anonymous

переход на личности

Залогинься, личность.

thesis ★★★★★ ()
Ответ на: комментарий от NextGenenration

Тепрь осталось вытянуть пути из скрипта, а по путям узнать пакеты.

Ну да, пакеты:)))) Вот тебе пример строки со сборочной командой:

fpc programma.pp -Fu\lib/i386-linux/* -Fu\zagluski/1/ -Fl/usr/lib32/ -Fl/usr/lib32/*  -XX -XC

Всё компактно и с масками разрешающими компилятору лазить по вложенным каталогам.

Napilnik ★★★★★ ()
Ответ на: комментарий от Napilnik

Похоже на то, раз для тебя такая проблема в получении списка пакетов.

NextGenenration ★★ ()
Ответ на: комментарий от NextGenenration

Проблема в отсутствии в репе _одного_ метапакета выкачивающего сотни 3 метров основных 32 битных пакетов для запуска бинарей. В центоси такого не встречал.

Napilnik ★★★★★ ()
Ответ на: комментарий от Napilnik

Как узнать какие конкртетно библиотеки нужно скачать?

В центоси такого не встречал.

Что там за пакет?

NextGenenration ★★ ()
Ответ на: комментарий от thesis

Дискиминация по признаку авторизации на лоре?

anonymous ()
Ответ на: комментарий от anonymous

Никакой дискриминации. Аноним - не личность.

thesis ★★★★★ ()
Ответ на: комментарий от NextGenenration

Как узнать какие конкртетно библиотеки нужно скачать?

Берём штук 20 программ из репозитория и их неэкзотические зависимости заносим в список.

Что там за пакет?

Смотри как раньше было сделано в бубунте http://www.linuxrussia.com/32-libs-ubuntu.html

Napilnik ★★★★★ ()
Ответ на: комментарий от ne-vlezay

У меня рутрекер редиректит на сайт провайдера.

Конечно не по теме, но Tor, VPN, или тот-же frigate для браузера для кого придуман был?

По сабжу

Вот в правительстве вместо того, чтоб выделять финансы на всякие дистрибутивы аля ОСь, выделили бы лаве на РеактОС, пользы бы больше было

Masterildar ()
Ответ на: комментарий от thesis

Ты уж определись :)

То ты в предыдущем сообщении обращаешься как к личности, теперь уже не личность ;)

Как наведешь в своей голове порядок, так и приходи.

Аноним всегда на лоре и готов тебя выслушать :)

anonymous ()
Ответ на: комментарий от anonymous

обращаешься как к личности

Кстати, люди с легкой степенью дебильности не различают сарказм, отчего в целом доброжелательны и миролюбивы.

thesis ★★★★★ ()
Ответ на: комментарий от thesis

это ты самокритично :)

ну раз у тебя такое расстройство, не буду больше тебя беспокоить.

не запускай, таблеточки принимай! :)

anonymous ()
Ответ на: комментарий от Masterildar

Вот в правительстве вместо того, чтоб выделять финансы на всякие дистрибутивы аля ОСь, выделили бы лаве на РеактОС, пользы бы больше было

Лучше бы linux или openbsd(на самый худой конец) поддержали!!!ОСъ - это просто очередной дистрибутив с кучей всякого говна, которое есть в говносборках. Плюс ко всему старое ядро без поддержки MPLS.
MPLS в linux появился с 4.1, нормально заработал с 4.9, многометочность появится только в 4.12.
В openbsd mpls правда однометочный, к тому же у openbsd медленный сетевой стек.
А reactos умеет выдовать только синие экрвны после установки.

ne-vlezay ★★★★★ ()
Последнее исправление: ne-vlezay (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.